- Posts: 99
- Thank you received: 5
Update Hikashop + PHP
-- Joomla version -- : 3.10.4
-- PHP version -- : PHP Version 8.0.2
After updating to PHP8x
2 issues:
#1) error on checkout with payment using Eslect plugin +PHP 8 *note- works with PHP7.4:
#2 error report on Admin + Public
Warning: Narrowing occurred during type inference of ZEND_FETCH_DIM_W. Please file a bug report on bugs.php.net in /home/xxx_dev/xxx_dev/administrator/components/com_hikashop/helpers/helper.php on line 1381
Please advise.
Please Log in or Create an account to join the conversation.
1. Thank you for your feedback. The eSelect / Moneris plugin indeed has troubles with PHP 8. I've made a patch on our end for this.
Please download again the install package of HikaShop on our website and install it on yours and you'll get the patch for this.
2. Regarding the warning, it seems to be something linked to a bug in opcache with the compiling of PHP files.
So I don't think we can do anything on our end to avoid it.
Best is to report it on bugs.php.net
In the meantime, you can turn off the "error reporting" in the Joomla settings in order to hide the warning.
Please Log in or Create an account to join the conversation.
Please Log in or Create an account to join the conversation.
It seems there is a similar error on MASS ACTIONS that we only just found out about during weekly reporting and so I have reverted to PHP7.4
Error: of 0 attempt to modify property value on null.
Trust it is okay to post here.
Please Log in or Create an account to join the conversation.
It's ok yes. However, without the full error message, I can't say anything as the error could be anywhere.
Could you reproduce the issue after activating the "debug system" setting of the Joomla configuration in order to get the full error message ?
Please Log in or Create an account to join the conversation.
Please Log in or Create an account to join the conversation.
FROM ADMIN - "process MASS ACTION"
thousands of lines of warnings... (limitation filter set to 2,000):
+ Duplicate DB Queries
I can sent either a PDF of the ADMIN SCREEN
or login details.
Please Log in or Create an account to join the conversation.
Thank you for that. I've added some patches for these.
Download again the install package of the latest version of HikaShop on our website and install it on yours to get them and you should not have these anymore.
If you have other issues after this, please provide again the debug and a screenshot of the settings of the mass action would be great too.
Please Log in or Create an account to join the conversation.
I have a new question about triggering multiple massactions via cron - I will start a new thread.
Please Log in or Create an account to join the conversation.
I found another PHP 8 issue
To replicate:- need to have an order for customer with no tax.
Client in Canada sells to USA and does not charge tax outside of Canada.
When editing the order in the admin interface and changing the quantity there is an error.
However I have reverted to PHP7.4 and it works as expected
Please Log in or Create an account to join the conversation.
Thank you for that. I've added a patch for this.
Download again the install package of the latest version of HikaShop on our website and install it on yours to get them and you should not have that error anymore.
Please Log in or Create an account to join the conversation.
Please Log in or Create an account to join the conversation.
It looks like this error stil exist! But only in combination with HikaSerial installed!!!!
We have installed again the latest 4.5 version today in combination with PHP 8.
But on the back-and we get this error:
Warning: Narrowing occurred during type inference of ZEND_FETCH_DIM_W. Please file a bug report on bugs.php.net in /data/sites/web/domainnl/subsites/domain.eu/administrator/components/com_hikashop/helpers/helper.php on line 1381
Switching back to PHP 7.4 fixes this issue so it's indeed related to PHP 8.
And in the check-out we get this error with PHP 8 and not with PHP 7.4:
0
Attempt to modify property "checkout_top" on null
We also get this error with PHP 7.4 on check-out:
Warning: Creating default object from empty value in /data/sites/web/domainsnl/subsites/domain.eu/plugins/hikashop/auto_fill/auto_fill.php on line 109
Hope you can fix this.
Kind regards,
Lumiga
Kind regards,
Lumiga
Please Log in or Create an account to join the conversation.
1. So do you mean that if you go on PHP8, you get the error, but then if you disable hikaserial while staying on PHP8, you don't have the error ? That would indeed confirm that it's linked to a problem with PHP8 and HikaSerial.
2. Thank you for the report on the warning with the Auto Fill plugin. I've made a patch in the plugin for this. Download again the install package of the plugin on our website and install it on yours to get it fixed.
Please Log in or Create an account to join the conversation.
We did not have installed the HikaShop Address Auto fill plugin on this site.
But I downloaded en installed the latest version of Hikashop again and now the issue is solved.
And all errors/warnings etc. are gone!
So thankyou!
Kind regards,
Lumiga
Kind regards,
Lumiga
Please Log in or Create an account to join the conversation.
Do you still have a copy of the helper.php file where the error message was pointing at before you update HikaShop ?
If so, could you provide a copy ?
Please Log in or Create an account to join the conversation.
Please log in or register to see it.
Kind regards,
Lumiga
Please Log in or Create an account to join the conversation.
Thank you.
I've created an issue on PHP's github:
github.com/php/php-src/issues/8251
Hopefully, something can come out of this.
Please Log in or Create an account to join the conversation.
What is important to know is that we have been on PHP 8 for a while and did not experience any problems.
Only after we installed HikaSerial we get these issues!
Kind regards,
Lumiga
Kind regards,
Lumiga
Please Log in or Create an account to join the conversation.
Now we get this error on an other website when we update to Hikashop 4.5 without HikaSerial.
So maybe it has nothing to do with Hikaserial.
And after refreshing the warning is gone!
Warning: Narrowing occurred during type inference of ZEND_FETCH_DIM_W. Please file a bug report on bugs.php.net in /data/sites/web/domainnam/subsites/domainname/administrator/components/com_hikashop/helpers/helper.php on line 1381
Kind regards,
Lumiga
Kind regards,
Lumiga
Please Log in or Create an account to join the conversation.