- Posts: 132
- Thank you received: 3
Not goint to paypal
- alexmartin
-
Topic Author
- Offline
Less
More
4 years 3 months ago #342531
by alexmartin
Not goint to paypal was created by alexmartin
-- HikaShop version -- : 4.6.0
-- Joomla version -- : Joomla! 4.1.4 Stable
-- PHP version -- : 8.0.20
-- Browser(s) name and version -- : Chrome
-- Error-message(debug-mod must be tuned on) -- : 0 Missing format specifier at end of string
My site was working well and HikaShop Paypal payment plugin works well until I upgraded to Hika 6 and PHP 8.0.20
When a user on the front end selects PayPal as payment and click to finalize payment => getting 404 error page and error:
0 Missing format specifier at end of string
My customers are not able to process payments any more.
Could you please help?
-- Joomla version -- : Joomla! 4.1.4 Stable
-- PHP version -- : 8.0.20
-- Browser(s) name and version -- : Chrome
-- Error-message(debug-mod must be tuned on) -- : 0 Missing format specifier at end of string
My site was working well and HikaShop Paypal payment plugin works well until I upgraded to Hika 6 and PHP 8.0.20
When a user on the front end selects PayPal as payment and click to finalize payment => getting 404 error page and error:
0 Missing format specifier at end of string
My customers are not able to process payments any more.
Could you please help?
Please Log in or Create an account to join the conversation.
4 years 3 months ago #342543
by nicolas
Replied by nicolas on topic Not goint to paypal
Hi,
Please activate the "debug mode" of the joomla configuration and try again.
It will display the error message with more information which will help us understand the reason of that error and tell you what to do.
Please activate the "debug mode" of the joomla configuration and try again.
It will display the error message with more information which will help us understand the reason of that error and tell you what to do.
Please Log in or Create an account to join the conversation.
- alexmartin
-
Topic Author
- Offline
Less
More
- Posts: 132
- Thank you received: 3
4 years 3 months ago - 4 years 3 months ago #342579
by alexmartin
Replied by alexmartin on topic Not goint to paypal
Last edit: 4 years 3 months ago by alexmartin.
Please Log in or Create an account to join the conversation.
4 years 3 months ago #342583
by nicolas
Replied by nicolas on topic Not goint to paypal
Hi,
Thank you.
Yes.
This error happens when HikaShop translates the translation key THANK_YOU_FOR_YOUR_ORDER_BEGIN used in the emails.
Looking online for this error for the sprintf function, I found this:
github.com/freescout-helpdesk/freescout/...1d6de0ace3f76fc2419a
This indicates that in the text to be replaced there is a % instead of a %s (we always use %s not %c as in the link but it's the same) and PHP8 crashes instead of ignoring the issue.
So I looked at all the translation files we have for HikaShop and I found that both the Russian and the Malaysian translation files have an issue with that translation key.
I also looked for the website associated with your subscription on our end and it seems to be in Russian, which confirms that the issue is with the Russian translation file.
In it (file administrator/language/ru-RU/ru-RU.com_hikashop.ini, you have the line:
THANK_YOU_FOR_YOUR_ORDER_BEGIN="Спасибо за Ваш заказ %."
which should instead be:
THANK_YOU_FOR_YOUR_ORDER_BEGIN="Спасибо за Ваш заказ %s."
You can manually edit that file via FTP to do the change and it should then fix the problem.
We'll include the modification on our end too.
Thank you.
Yes.
This error happens when HikaShop translates the translation key THANK_YOU_FOR_YOUR_ORDER_BEGIN used in the emails.
Looking online for this error for the sprintf function, I found this:
github.com/freescout-helpdesk/freescout/...1d6de0ace3f76fc2419a
This indicates that in the text to be replaced there is a % instead of a %s (we always use %s not %c as in the link but it's the same) and PHP8 crashes instead of ignoring the issue.
So I looked at all the translation files we have for HikaShop and I found that both the Russian and the Malaysian translation files have an issue with that translation key.
I also looked for the website associated with your subscription on our end and it seems to be in Russian, which confirms that the issue is with the Russian translation file.
In it (file administrator/language/ru-RU/ru-RU.com_hikashop.ini, you have the line:
THANK_YOU_FOR_YOUR_ORDER_BEGIN="Спасибо за Ваш заказ %."
which should instead be:
THANK_YOU_FOR_YOUR_ORDER_BEGIN="Спасибо за Ваш заказ %s."
You can manually edit that file via FTP to do the change and it should then fix the problem.
We'll include the modification on our end too.
Please Log in or Create an account to join the conversation.
- alexmartin
-
Topic Author
- Offline
Less
More
- Posts: 132
- Thank you received: 3
4 years 3 months ago #342613
by alexmartin
Replied by alexmartin on topic Not goint to paypal
Please Log in or Create an account to join the conversation.
4 years 3 months ago #342618
by nicolas
Replied by nicolas on topic Not goint to paypal
Hi,
Ah yes, there is another problem in the Russian language file.
The line:
should be
change that and it will remove that error.
We'll add that change on our end too.
Ah yes, there is another problem in the Russian language file.
The line:
Code:
ACCESS_ORDER_WITH_LINK="Вы можете получить доступ к подробностям заказа, перейдя по ссылке ниже, после прохождения авторизации на сайте:<br /><a href='%s'>%s</a>"
Code:
ACCESS_ORDER_WITH_LINK="Вы можете получить доступ к подробностям заказа, перейдя по ссылке ниже, после прохождения авторизации на сайте:<br /><a href='%1$s'>%1$s</a>"
We'll add that change on our end too.
Please Log in or Create an account to join the conversation.
Time to create page: 0.184 seconds