- Posts: 4
- Thank you received: 0
ERROR!!
15 years 2 months ago #21431
by johan
Hello everybody,
I got a big problem. I cannot make a new catagory. When i save a new catagory i get this error:
Call stack
# Function Location
1 JAdministrator->dispatch() /home/terminat/domains/terminate.nl/public_html/administrator/index.php:67
2 JComponentHelper->renderComponent() /home/terminat/domains/terminate.nl/public_html/administrator/includes/application.php:136
3 require_once() /home/terminat/domains/terminate.nl/public_html/libraries/joomla/application/component/helper.php:162
4 JController->execute() /home/terminat/domains/terminate.nl/public_html/administrator/components/com_installer/admin.installer.php:44
5 InstallerController->doInstall() /home/terminat/domains/terminate.nl/public_html/libraries/joomla/application/component/controller.php:236
6 InstallerModelInstall->install() /home/terminat/domains/terminate.nl/public_html/administrator/components/com_installer/controller.php:71
7 JInstaller->install() /home/terminat/domains/terminate.nl/public_html/administrator/components/com_installer/models/install.php:86
8 JInstallerComponent->install() /home/terminat/domains/terminate.nl/public_html/libraries/joomla/installer/installer.php:332
9 JInstaller->parseFiles() /home/terminat/domains/terminate.nl/public_html/libraries/joomla/installer/adapters/component.php:172
10 JInstaller->copyFiles() /home/terminat/domains/terminate.nl/public_html/libraries/joomla/installer/installer.php:642
11 JFolder->copy() /home/terminat/domains/terminate.nl/public_html/libraries/joomla/installer/installer.php:931
12 JFolder->copy() /home/terminat/domains/terminate.nl/public_html/libraries/joomla/filesystem/folder.php:113
13 JError->raiseError() /home/terminat/domains/terminate.nl/public_html/libraries/joomla/filesystem/folder.php:122
14 JError->raise() /home/terminat/domains/terminate.nl/public_html/libraries/joomla/error/error.php:171
15 JException->__construct() /home/terminat/domains/terminate.nl/public_html/libraries/joomla/error/error.php:136
What is the problem and how can i fix it!!? Please help.
Regards.
Johan
I got a big problem. I cannot make a new catagory. When i save a new catagory i get this error:
Call stack
# Function Location
1 JAdministrator->dispatch() /home/terminat/domains/terminate.nl/public_html/administrator/index.php:67
2 JComponentHelper->renderComponent() /home/terminat/domains/terminate.nl/public_html/administrator/includes/application.php:136
3 require_once() /home/terminat/domains/terminate.nl/public_html/libraries/joomla/application/component/helper.php:162
4 JController->execute() /home/terminat/domains/terminate.nl/public_html/administrator/components/com_installer/admin.installer.php:44
5 InstallerController->doInstall() /home/terminat/domains/terminate.nl/public_html/libraries/joomla/application/component/controller.php:236
6 InstallerModelInstall->install() /home/terminat/domains/terminate.nl/public_html/administrator/components/com_installer/controller.php:71
7 JInstaller->install() /home/terminat/domains/terminate.nl/public_html/administrator/components/com_installer/models/install.php:86
8 JInstallerComponent->install() /home/terminat/domains/terminate.nl/public_html/libraries/joomla/installer/installer.php:332
9 JInstaller->parseFiles() /home/terminat/domains/terminate.nl/public_html/libraries/joomla/installer/adapters/component.php:172
10 JInstaller->copyFiles() /home/terminat/domains/terminate.nl/public_html/libraries/joomla/installer/installer.php:642
11 JFolder->copy() /home/terminat/domains/terminate.nl/public_html/libraries/joomla/installer/installer.php:931
12 JFolder->copy() /home/terminat/domains/terminate.nl/public_html/libraries/joomla/filesystem/folder.php:113
13 JError->raiseError() /home/terminat/domains/terminate.nl/public_html/libraries/joomla/filesystem/folder.php:122
14 JError->raise() /home/terminat/domains/terminate.nl/public_html/libraries/joomla/error/error.php:171
15 JException->__construct() /home/terminat/domains/terminate.nl/public_html/libraries/joomla/error/error.php:136
What is the problem and how can i fix it!!? Please help.
Regards.
Johan
Please Log in or Create an account to join the conversation.
15 years 2 months ago #21432
by nicolas
Replied by nicolas on topic Re: ERROR!!
Hi,
The error you copy/pasted does not involved HikaShop at all. It's an error during the copy of the files of an install package during the installation of an extension with the joomla installer.
Are you sure that you copy/pasted the good error ?
The error you copy/pasted does not involved HikaShop at all. It's an error during the copy of the files of an install package during the installation of an extension with the joomla installer.
Are you sure that you copy/pasted the good error ?
Please Log in or Create an account to join the conversation.
15 years 2 months ago #21433
by johan
Replied by johan on topic Re: ERROR!!
Sorry Nicolas,
Here is the good error page.
JDatabaseMySQL::query: 1054 - Unknown column 'category_meta_description' in 'field list' SQL=INSERT IGNORE INTO `jos_hikashop_category` ( `category_name`,`category_meta_description`,`category_keywords`,`category_published`,`category_parent_id`,`category_id`,`category_type`,`category_description`,`category_modified`,`category_created`,`category_namekey` ) VALUES ( 'Batman','','','1','2','','product','','1310917494','1310917494','product_1310917494_860885884' )
Call stack
# Function Location
1 JAdministrator->dispatch() /home/terminat/domains/terminate.nl/public_html/administrator/index.php:67
2 JComponentHelper->renderComponent() /home/terminat/domains/terminate.nl/public_html/administrator/includes/application.php:136
3 require_once() /home/terminat/domains/terminate.nl/public_html/libraries/joomla/application/component/helper.php:162
4 JController->execute() /home/terminat/domains/terminate.nl/public_html/administrator/components/com_hikashop/admin.hikashop.php:32
5 hikashopController->save() /home/terminat/domains/terminate.nl/public_html/libraries/joomla/application/component/controller.php:236
6 hikashopController->store() /home/terminat/domains/terminate.nl/public_html/administrator/components/com_hikashop/helpers/helper.php:814
7 hikashopCategoryClass->saveForm() /home/terminat/domains/terminate.nl/public_html/administrator/components/com_hikashop/helpers/helper.php:865
8 hikashopCategoryClass->save() /home/terminat/domains/terminate.nl/public_html/administrator/components/com_hikashop/classes/category.php:51
9 hikashopClass->save() /home/terminat/domains/terminate.nl/public_html/administrator/components/com_hikashop/classes/category.php:130
10 JDatabaseMySQL->query() /home/terminat/domains/terminate.nl/public_html/administrator/components/com_hikashop/helpers/helper.php:993
11 JError->raiseError() /home/terminat/domains/terminate.nl/public_html/libraries/joomla/database/database/mysql.php:231
12 JError->raise() /home/terminat/domains/terminate.nl/public_html/libraries/joomla/error/error.php:171
13 JException->__construct() /home/terminat/domains/terminate.nl/public_html/libraries/joomla/error/error.php:136
The first error page was the error joomla is giving when i update 1.5.1 to 1.5.2. that doesnt work to.
I hope you can help me.
Regards,
Johan
Here is the good error page.
JDatabaseMySQL::query: 1054 - Unknown column 'category_meta_description' in 'field list' SQL=INSERT IGNORE INTO `jos_hikashop_category` ( `category_name`,`category_meta_description`,`category_keywords`,`category_published`,`category_parent_id`,`category_id`,`category_type`,`category_description`,`category_modified`,`category_created`,`category_namekey` ) VALUES ( 'Batman','','','1','2','','product','','1310917494','1310917494','product_1310917494_860885884' )
Call stack
# Function Location
1 JAdministrator->dispatch() /home/terminat/domains/terminate.nl/public_html/administrator/index.php:67
2 JComponentHelper->renderComponent() /home/terminat/domains/terminate.nl/public_html/administrator/includes/application.php:136
3 require_once() /home/terminat/domains/terminate.nl/public_html/libraries/joomla/application/component/helper.php:162
4 JController->execute() /home/terminat/domains/terminate.nl/public_html/administrator/components/com_hikashop/admin.hikashop.php:32
5 hikashopController->save() /home/terminat/domains/terminate.nl/public_html/libraries/joomla/application/component/controller.php:236
6 hikashopController->store() /home/terminat/domains/terminate.nl/public_html/administrator/components/com_hikashop/helpers/helper.php:814
7 hikashopCategoryClass->saveForm() /home/terminat/domains/terminate.nl/public_html/administrator/components/com_hikashop/helpers/helper.php:865
8 hikashopCategoryClass->save() /home/terminat/domains/terminate.nl/public_html/administrator/components/com_hikashop/classes/category.php:51
9 hikashopClass->save() /home/terminat/domains/terminate.nl/public_html/administrator/components/com_hikashop/classes/category.php:130
10 JDatabaseMySQL->query() /home/terminat/domains/terminate.nl/public_html/administrator/components/com_hikashop/helpers/helper.php:993
11 JError->raiseError() /home/terminat/domains/terminate.nl/public_html/libraries/joomla/database/database/mysql.php:231
12 JError->raise() /home/terminat/domains/terminate.nl/public_html/libraries/joomla/error/error.php:171
13 JException->__construct() /home/terminat/domains/terminate.nl/public_html/libraries/joomla/error/error.php:136
The first error page was the error joomla is giving when i update 1.5.1 to 1.5.2. that doesnt work to.
I hope you can help me.
Regards,
Johan
Please Log in or Create an account to join the conversation.
15 years 2 months ago #21434
by nicolas
Replied by nicolas on topic Re: ERROR!!
You had a problem during an update and the database structure of HikaShop could not be updated. You will have to update it manually. You need to go in your database management tool (phpmyadmin), which is provided by your hosting company and run the query below on your database:
ALTER TABLE `jos_hikashop_category` ADD `category_meta_description` varchar(155) NOT NULL DEFAULT ''
For the update of HikaShop from 1.5.1 to 1.5.2, as I said in my previous post, it's an error during the copy of the files. It often happens because the permissions of the folders on your website are not configured properly. There are several ways to go around it but the best is to correct the permissions of the folders listed on the page www.hikashop.com/en/support/documentatio...-install.html#errors via FTP.
ALTER TABLE `jos_hikashop_category` ADD `category_meta_description` varchar(155) NOT NULL DEFAULT ''
For the update of HikaShop from 1.5.1 to 1.5.2, as I said in my previous post, it's an error during the copy of the files. It often happens because the permissions of the folders on your website are not configured properly. There are several ways to go around it but the best is to correct the permissions of the folders listed on the page www.hikashop.com/en/support/documentatio...-install.html#errors via FTP.
Please Log in or Create an account to join the conversation.
15 years 2 months ago #21437
by johan
Replied by johan on topic Re: ERROR!!
I dont know how to do this in PHP admin.
ALTER TABLE `jos_hikashop_category` ADD `category_meta_description` varchar(155) NOT NULL DEFAULT ''
I dont what you meen, im sorry. can you explain to me please
Thank you
johan
ALTER TABLE `jos_hikashop_category` ADD `category_meta_description` varchar(155) NOT NULL DEFAULT ''
I dont what you meen, im sorry. can you explain to me please
Thank you
johan
Please Log in or Create an account to join the conversation.
15 years 2 months ago #21438
by nicolas
Replied by nicolas on topic Re: ERROR!!
Please contact your hosting company and ask them how you can access your mysql database administration tool (phpMyAdmin).
Here is a tutorial on how to use phpMyAdmin: www.reg.ca/faq/PhpMyAdminTutorial.html
Here is a tutorial on how to use phpMyAdmin: www.reg.ca/faq/PhpMyAdminTutorial.html
Please Log in or Create an account to join the conversation.
15 years 2 months ago #21441
by johan
Replied by johan on topic Re: ERROR!!
I have acces to myphp. but i cant find and add category_meta_description in jos_hikashop_category. How is that possible.
Please Log in or Create an account to join the conversation.
15 years 2 months ago #21442
by nicolas
Replied by nicolas on topic Re: ERROR!!
You need to click on the "query" tab at the top of the interface, paste the query I provided earlier and run that query. It will add the column to the table.
Please Log in or Create an account to join the conversation.
Time to create page: 0.211 seconds