Skip to main content

[Solved] canonical URLs 404 error

More
10 years 9 months ago - 10 years 9 months ago #224894 by Seans
-- HikaShop version -- : 2.6.0
-- Joomla version -- : 3.4.7
-- PHP version -- : 5.10.1

Hello.
the only time i don't get the 404 error is if i use no generate canonical urls.
For some reason when i don't get the 404 error my "product description is missing"
i tried manually putting canonical url on my product and that did not help
is there a quick fix it seems like an easy problem but i can't figure it out.
Best regards
Last edit: 10 years 9 months ago by Seans.

Please Log in or Create an account to join the conversation.

More
10 years 9 months ago #224902 by nicolas
Replied by nicolas on topic canonical URLs 404 error
Hi,

The canonical URL needs to be a valid URL of the product. You can't put a random URL in there.
So it's better to leave it empty if you don't know what you put.

I don't see why the description wouldn't be displayed based on the URL. It must be something, like a problem with your template.
Try to switch temporarily to the default template of Joomla and see if the product page displays normally. If so, then you should contact your template provider as there is apparently a problem with the view override of the product page in the template.
The following user(s) said Thank You: Seans

Please Log in or Create an account to join the conversation.

Time to create page: 0.183 seconds
Powered by Kunena Forum