- Posts: 92
- Thank you received: 5
404 error on step 3 of checkout process
-- HikaShop version -- : HikaShop Business: 2.6.2
-- Joomla version -- : 3.5.1 Stable
-- PHP version -- : 5.5.23
-- Browser(s) name and version -- : Firefox / Chrome
-- Error-message(debug-mod must be tuned on) -- : 404
0 Invalid address: KiteOutlet.eu
I have just updated both Joomla and Hikashop business to the latest version. Now when I try to place an order I get a 404 error (and in the basic protostar Joomla template "0 Invalid address: KiteOutlet.eu"). The error occurs when you go to step 3 of the checkout process ( www.kiteoutlet.eu/en/checkout/checkout/task-step/step-3 ).
I have tried to figure out what is wrong, but I am now at a loss for what is causing this error.
There is no menu item forced on checkout. But even when there is the error remains.
I have tried both with and without simplified URLs, and my SEF and SEO settings are as in the attached image.
It does not matter which payment method I use.
Before updating everything worked fine. Any help in getting it to work again is much appreciated!
Please Log in or Create an account to join the conversation.
From the error message "0 Invalid address: KiteOutlet.eu" I think this error may have something to do with the site trying to connect to the address "KiteOutlet.eu" that I may have filled out in the back end somewhere, where there should have been www.kiteoutlet.eu . It also may have something to do with the emails that are sent from the site at step 3 of the checkout process.
Please Log in or Create an account to join the conversation.
Any solution?
Please Log in or Create an account to join the conversation.
- Posts: 3
- Thank you received: 1
Please confirm if there are any solutions other than reverting to a previous version of Joomla via a backup.
Please Log in or Create an account to join the conversation.
It's a small change in the new release of Joomla which causes the problem.
In the file administrator/components/com_hikashop/classes/mail.php
Change the line:
And in the file administrator/components/com_hikashop/classes/order.php
Change the line
We've added the patches on our end too, so you can also just download the install package via the menu My account>My subscriptions and install it on your website and that will add the patches and fix the problem.
Please Log in or Create an account to join the conversation.
Sorry for my English.
Please Log in or Create an account to join the conversation.
Thank you for the feedback. We've added another patch for it. Alternatively, you can, and we recommend, to switch to the "vex" popup mode in the Hikashop configuration and that should also fix the problem.
Please Log in or Create an account to join the conversation.
- Posts: 332
- Thank you received: 6
Thanks for the quick response. I have confirmed that the HikaShop 2.6.2 does fix this issue.
FYI, it was not only HikaShop that was affected by this Joomla 3.5.1 update. I have three different form generation applications used on a variety of websites and each one were broken. My gut tells me that 'any' application that is submitting data to a 'reply-to' field is going to be broken. :woohoo: :evil:
Please Log in or Create an account to join the conversation.
I've posted that here so that anybody else Googling it should find this thread.
It's annoying that these bugs occur but good to find the solution here - thanks for the support Nicolas!
Ian
Please Log in or Create an account to join the conversation.
Please Log in or Create an account to join the conversation.
I also had error on a hikshop (business) site with error page. The update to 2.6.2 (i could not see that update in Joomla, needed to donload it from your site) seems to help with the problem. With a testorder the error was gone and the order was going well from start to end.
I'll keep on trying!
Please Log in or Create an account to join the conversation.
I've done some tests on my end and I'm able to have several email addresses.
What error do you have with that. And how did you configure these options ? Could you provide a screenshot ?
Please Log in or Create an account to join the conversation.
- Posts: 1
- Thank you received: 0
we at Crosstec thought the problem was just about the wrong use of addReplyTo() but in fact Joomla's behaviour changed in other areas, as well.
Before, Joomla! allowed previous transactions, such as form submissions, to pass and displayed notification messages at the top of the page about email issues that happened.
Now, Joomla! will throw a hard error (500) and stop the current transaction. This requires all extension developers to handle the thrown error, for example using a try / catch block and enqueuing the error message in the catch-block to restore the old behaviour (displaying a notification at the top of the page).
After we solved the addReplyTo() issue we were wondering why some people still faced this error message, so we had to adjust to other possible issues accordingly.
Best Regards,
Markus
Please Log in or Create an account to join the conversation.
I had the same problem with checkout on www.e-driver.net
The code fixed the problem.
I had to say thanks Nicolas
Please Log in or Create an account to join the conversation.
Please Log in or Create an account to join the conversation.
nicolas wrote: @SarahW:
I've done some tests on my end and I'm able to have several email addresses.
What error do you have with that. And how did you configure these options ? Could you provide a screenshot ?
I had a couple of sites on which the 404 error persisted despite the update, and it only cleared when I removed the second email address from the configuration fields I mentioned. In both cases, they'd been there for years without problems. They were separated by commas, It think - I've removed them now, so unfortunately I can't provide a screenshot.
Please Log in or Create an account to join the conversation.
I've added some modifications on our end to hopefully help with that.
If you want to try, you can download again the install package on our website and install it on your website and then try with several email addresses again. It should hopefully work.
Please Log in or Create an account to join the conversation.
Please Log in or Create an account to join the conversation.
I have downloaded the latest version of Hikashop & Hikamarket but still get the error.
Regards
Trevor
UPDATE: I have found a similar line in administrator/components/com_hikamarket/classes/product.php
I tried changing it to:
but get a Fatal error: Fatal error: Call to undefined method stdClass::cleanText()
I guess the class needs including. Am I heading in the right direction?
Trevor
Please Log in or Create an account to join the conversation.
Please apply the right patch.
www.hikashop.com/forum/19-hikamarket/883...-produit.html#235845
And for your HikaMarket questions ; you have to use the HikaMarket forum....
Regards,
Jerome - Obsidev.com
HikaMarket & HikaSerial developer / HikaShop core dev team.
Also helping the HikaShop support team when having some time or couldn't sleep.
By the way, do not send me private message, use the "contact us" form instead.
Please Log in or Create an account to join the conversation.