- Posts: 45
- Thank you received: 0
Fatal error after updating
I've just installed the latest version of Hikashop and now I've got this error message while I try to enter in any product or in any menu from hikashop.
This happened inmediately after I've updated the hikashop.
Let me know, please, what can be causing this.
Thanks a lot.
Best regards,
Pedro Lima
Please Log in or Create an account to join the conversation.
That error comes from the jat3 system plugin you have installed on your website. If you disable it, it should work properly.
No one reported such error with the latest version of HikaShop so far or any other version for that matter.
Please Log in or Create an account to join the conversation.
I know it is, but if I disable the plug-in my template just don't work as well as the entire website.
Everything was working just perfect before I proceed with this last update so I guess this must be some kind of conflict.
Do you have a clue on what can be causing this conflict?
Can you suggest me things to disable that were implemented on this new update so I can test if there's some conflict?
Thanks.
Best regards,
Pedro Lima
Please Log in or Create an account to join the conversation.
Not sure really. That class is not even related to HikaShop. We just use it to add stuff in the header of the website like CSS and javascript and we always did so.
The RSS and social networks plugin were added recently and use it so you might want to try to disable them. The RSS can be disabled in the configuration and the social network plugin can be disabled in the joomla plugins manager.
Also, I see that in the file components/com_hikashop/views/product/view.html.php we have the line:
$doc = JFactory::getDocument();
Normally, it should be :
$doc =& JFactory::getDocument();
So you might want to try to change that... It might help.
I don't have other ideas.
Please Log in or Create an account to join the conversation.
Unfortunately everything is the same after the changes!
I really don't know what to do and the shop isn't working... :'(
Please Log in or Create an account to join the conversation.
Please Log in or Create an account to join the conversation.
I get the same error after upgrading hikashop to the latest version 1.5.4.
Fatal error: Cannot redeclare class JDocumentHTML in
\wamp\apps\dev07112011\plugins\system\jat3\jat3\core\joomla\documenthtml.php on line 514.I've noticed that all hikashop links having 'product' in the paths fail with the error above. For example a link to hikashop checkout works fine.
Any idea how this can be fixed? Do you have previous version of hikashop that I could try just to see if the issue happens?
I need to upgrade hikashop as soon as possible but now due to this error I can't
YOur help would be much appreciated.
Please Log in or Create an account to join the conversation.
We have copies of the previous versions of HikaShop, and you can use our contact form if you want to request one in particular.
As you could read before, we were not able to determine why that error would happen as it's an error coming from a plugin of your template. So you should really ask your template provider about that problem as they are the ones with the best knowledge to solve it.
Please Log in or Create an account to join the conversation.
I can't remember how I solevd the problem, unfortunately.
What I do know is that I'm using a Jm-Experts template and I've searched for something to do with the error and the template and I could find other people complaining about other software that also gave some errors like this one.
So the thing that I can suggest you is: try to search for the error in Google and try to match it with the template and/or with the plug-in used on the template (mine is JAT3).
I'm not sure but I think I've just upgraded the template files I guess. But I can't say for sure if I changed something on my code or not. But if I did, it was based on something that eventually I found online, so just search and you will do it!
I'm sorry, this is so much things during only one day that I can't even remember what I did 2 days ago.
Good luck pal!
Best regards,
Pedro Lima
Please Log in or Create an account to join the conversation.
www.joomlart.com/forums/showthread.php?5...315a081bdecdca923298
Please Log in or Create an account to join the conversation.
Indeed, I found that page on the JA forum:
www.joomlart.com/forums/showthread.php?5...315a081bdecdca923298
Exactly!
Please Log in or Create an account to join the conversation.
I tend to think it's got something to do with the latest version of hikashop since the error never happened before the upgrade and as I tried to explain it happens when accessing specific hikashop pages related to product view. There is something changed in hikashop that now causes the issue because no other components, upgrades have been made on my system, just the hikashop upgrade.
Can you think of something else, Nicolas? I need to upgrade hikashop badly...
Please Log in or Create an account to join the conversation.
Believe me, I was in the very same position as you are right now and I've searched a lot and found a solution.
The problem is, definitely, something with the plug-in from the template.
Try to search a little bit more and try other things.
Please Log in or Create an account to join the conversation.
Sure something must be different in HikaShop. But we change lot of things in each version (almost all the files have something different in them) so I can't say what could be the problem since I don't know how that template work and that HikaShop does not have that problem on any other template.
Why not just ask the JA support ? They will be able to answer you bette than me on their own template.
Please Log in or Create an account to join the conversation.
I hope you can help me with this error...
This attachment is hidden for guests.
Please log in or register to see it.
Please Log in or Create an account to join the conversation.
That would explain why you get that notice and why you don't see the australia post plugin:
the country is not found in the address and thus the request so the australia post server fails.
Please Log in or Create an account to join the conversation.
Please Log in or Create an account to join the conversation.