- Posts: 20
- Thank you received: 5
HikaShop 1.5.6 / client denied by server configura
- Schultz-IT-Solutions
-
Topic Author
- Offline
Less
More
14 years 8 months ago #36985
by Schultz-IT-Solutions
Hello,
after upgrading to HikaShop 1.5.6 our product-images are no longer visible. These images did show up in the previous version, and we did not change any server configuration during install. In the webserver's error log I have such messages as below
Apache errorlog:
[Fri Jan 27 11:37:00 2012] [error] [client XXX.XXX.XXX.XXX] client denied by server configuration: /home/httpd/vhosts/XXXXXX/httpdocs/images/XXXXXX/shop/images/thumbnail_100x100/ts_pr_edn_front_cover2.jpg, referer: www.XXXXXXX/index.php/featured-books
Any ideas here?
best regards
Ruediger Schultz
after upgrading to HikaShop 1.5.6 our product-images are no longer visible. These images did show up in the previous version, and we did not change any server configuration during install. In the webserver's error log I have such messages as below
Apache errorlog:
[Fri Jan 27 11:37:00 2012] [error] [client XXX.XXX.XXX.XXX] client denied by server configuration: /home/httpd/vhosts/XXXXXX/httpdocs/images/XXXXXX/shop/images/thumbnail_100x100/ts_pr_edn_front_cover2.jpg, referer: www.XXXXXXX/index.php/featured-books
Any ideas here?
best regards
Ruediger Schultz
Please Log in or Create an account to join the conversation.
14 years 8 months ago #37094
by nicolas
Replied by nicolas on topic Re: HikaShop 1.5.6 / client denied by server configura
Hi,
Did you change the images upload folder location ?
We didn't change anything on that end for the new release and these errors in your log means that the server refused the access to the file often because of access rights.
You should check the access rights of your images and make sure that they are displayable by your web server.
Did you change the images upload folder location ?
We didn't change anything on that end for the new release and these errors in your log means that the server refused the access to the file often because of access rights.
You should check the access rights of your images and make sure that they are displayable by your web server.
Please Log in or Create an account to join the conversation.
- Schultz-IT-Solutions
-
Topic Author
- Offline
Less
More
- Posts: 20
- Thank you received: 5
13 years 10 months ago #76995
by Schultz-IT-Solutions
Replied by Schultz-IT-Solutions on topic HikaShop 1.5.6 / client denied by server configura
We solved the problem by deactivating the .htaccess in the images folder. this file contains only one directive "deny from all", which prevents showing the images.
We did again deactivate this .htaccess file today after updating to version 2.0.0, what is the purpose of this directive in the HikaShop component?
best regards
Ruediger Schultz
We did again deactivate this .htaccess file today after updating to version 2.0.0, what is the purpose of this directive in the HikaShop component?
best regards
Ruediger Schultz
Please Log in or Create an account to join the conversation.
13 years 10 months ago #77099
by Jerome
Jerome - Obsidev.com
HikaMarket & HikaSerial developer / HikaShop core dev team.
Replied by Jerome on topic HikaShop 1.5.6 / client denied by server configura
Hi,
HikaShop installer create this .htaccess file in the "upload/safe" directory, in order to protect files which need to be protected (downloadable files).
Knowing more about your configuration could help us yo understand why the file was created in the wrong folder.
Best regards,
HikaShop installer create this .htaccess file in the "upload/safe" directory, in order to protect files which need to be protected (downloadable files).
Knowing more about your configuration could help us yo understand why the file was created in the wrong folder.
Best regards,
Jerome - Obsidev.com
HikaMarket & HikaSerial developer / HikaShop core dev team.
Please Log in or Create an account to join the conversation.
- Schultz-IT-Solutions
-
Topic Author
- Offline
Less
More
- Posts: 20
- Thank you received: 5
13 years 10 months ago #77211
by Schultz-IT-Solutions
Replied by Schultz-IT-Solutions on topic HikaShop 1.5.6 / client denied by server configura
ah well, this clarifies the issue.
there is a configuration mistake, as the download/save directory is the same as the images directory. I will correct this and reactivate the .htaccess
thanks for your help.
best regards
Ruediger
there is a configuration mistake, as the download/save directory is the same as the images directory. I will correct this and reactivate the .htaccess
thanks for your help.
best regards
Ruediger
Please Log in or Create an account to join the conversation.
Time to create page: 0.194 seconds