Skip to main content

Affiliate PHP PHPMyAdmin Bug

More
13 years 8 months ago - 13 years 8 months ago #86360 by sharq
Hi. This is (maybe?) a Bug and Fix as well :)

I noticed that affiliate not working as I wanted, that's why I checked a background started with PHPMyAdmin. When I tried to list the hikashop_sale_view table I get #1356 error in myAdmin.

I googling around and found this: www.ubmedia.it/blog/2012/02/21/mysql-err...-rights-to-use-them/

And this post solved the problem.

In this topic they say, that It is a PHP or PHPMyAdmin related bug,

www.insidethebook.com/ee/index.php/site/...view_access_problem/

but the code didn't changed in Hikashop 2.0 neither, that's what I decided to notice you. :) I hope it's help :)

Peter
Last edit: 13 years 8 months ago by sharq.

Please Log in or Create an account to join the conversation.

More
13 years 8 months ago - 13 years 8 months ago #86364 by sharq
Replied by sharq on topic Affiliate PHP PHPMyAdmin Bug
sorry wrong post. :)
Last edit: 13 years 8 months ago by sharq.

Please Log in or Create an account to join the conversation.

More
13 years 8 months ago #86444 by nicolas
That's because HikaShop uses views to process the affiliate fees. And based on how your hosting company configured your MySQL, your MySQL user might not have the right to create/modify/display/delete views resulting in that error.
So it's not a bug.

Please Log in or Create an account to join the conversation.

Time to create page: 0.166 seconds
Powered by Kunena Forum