Thankyou for you ongoing support of the software guys,
another headscratcher
I get a missing 'STATE' dropdown, replaced by massive 404 error in the address editing iframe when accessed through the 'manage my addresses page'.
This doesn't happen when sef is switched of, OR when accessed through the address segment of the checkout flow,
permanently disabling joomla's native SEF isn't an option, so any ideas what could be causing this problem?