Display problem when changing variants

  • Posts: 138
  • Thank you received: 0
11 years 3 months ago #15822

Hello,

Remember when I asked how to place the product description and I had all kind of problems with the images and display www.hikashop.com/en/support/forum/3-bug-...lem-with-images.html ?

We worked that out but now when I change a characteristic of a product the display goes bad again. The child images are in the large image again and the description is displayed incorrectly. Please see what I mean by testing all four products on this listing page daydreamercreative.cloudaccess.net/tees.html . Thanks in advance.

Please Log in or Create an account to join the conversation.

  • Posts: 76114
  • Thank you received: 11912
  • MODERATOR
11 years 3 months ago #15833

If you have variants, you should use the CSS:
.hikashop_product_main_image_thumb{height: 310px !important;}

instead of: #hikashop_main_image_thumb_div{height: 310px !important;}

Last edit: 11 years 3 months ago by nicolas.

Please Log in or Create an account to join the conversation.

  • Posts: 138
  • Thank you received: 0
11 years 3 months ago #15860

That solution did not work. I am still having the same issue.

Please Log in or Create an account to join the conversation.

  • Posts: 76114
  • Thank you received: 11912
  • MODERATOR
11 years 3 months ago #15861

The class name was not good. I changed it in my previous post.

Please Log in or Create an account to join the conversation.

  • Posts: 138
  • Thank you received: 0
11 years 3 months ago #15865

Thanks. The first bullet is still moved when I change the variant. Is this something I have to change via css or edit description in the HTML?

Please Log in or Create an account to join the conversation.

  • Posts: 76114
  • Thank you received: 11912
  • MODERATOR
11 years 3 months ago #15867

It's because you don't have the same number of br tags for the main product quantity zone and the variant quantity zone.
That's something which was corrected in a previous version of hikashop so I suppose that it's because you have override the views before updating and thus didn't get that modification.
You should check the file show of the view product for the <br/> tags and make sure that you have the same number for the main product and the variants.

Please Log in or Create an account to join the conversation.

  • Posts: 138
  • Thank you received: 0
11 years 3 months ago #15868

I'm a bit confused. I counted 7 <br> tags in the product zone and 4 in the variant zone. Do I add to the variant zone or take away from the product zone? And if I do either won't I change the display of the product page?

Please Log in or Create an account to join the conversation.

  • Posts: 76114
  • Thank you received: 11912
  • MODERATOR
11 years 3 months ago #15870

You apparently need to add one at the end of the quantity area of the variant zone.

Last edit: 11 years 3 months ago by nicolas.

Please Log in or Create an account to join the conversation.

  • Posts: 138
  • Thank you received: 0
11 years 3 months ago #15871

My man. Thanks

Please Log in or Create an account to join the conversation.

Time to create page: 0.067 seconds
Powered by Kunena Forum