Skip to main content

1.5.7 (26-03) user registration

More
14 years 6 months ago - 14 years 6 months ago #44829 by erickb
Quand un nouvel utilisateur s'enregistre avec enregistrement automatique sans devoir activer le compte
sur cette url http://localhost:8888/sacapuce.biz/component/hikashop/user/register j'ai une page blanche avec

jos-Error: Accès interdit

JSite -> dispatch() @ /www/sacapuce.biz/index.php:42
JComponentHelper :: renderComponent() @ /www/sacapuce.biz/includes/application.php:187
JComponentHelper :: executeComponent() @ /www/sacapuce.biz/libraries/joomla/application/component/helper.php:357
require_once() @ /www/sacapuce.biz/libraries/joomla/application/component/helper.php:388
JController -> execute() @ /www/sacapuce.biz/components/com_hikashop/hikashop.php:53
JError :: raiseError() @ /www/sacapuce.biz/libraries/joomla/application/component/controller.php:759
JError :: raise() @ /www/sacapuce.biz/libraries/joomla/error/error.php:251


php_error.log


[27-Mar-2012 10:35:34] PHP Notice: Undefined property: hikashopGeolocationInc::$curl in /www/sacapuce.biz/administrator/components/com_hikashop/inc/geolocation.php on line 53
[27-Mar-2012 10:36:06] PHP Notice: Undefined index: view in /www/sacapuce.biz/plugins/system/hikashopregistrationredirect/hikashopregistrationredirect.php on line 25

si je reviens en arriere dans le navigateur je suis bien loggé
Last edit: 14 years 6 months ago by erickb.

Please Log in or Create an account to join the conversation.

More
14 years 6 months ago #44835 by nicolas
What is the page that you configured to be redirected to? Do you have the link ?
It seems that this page is not allowed.
Or maybe this comes from the token validation. So you could try to change the line:
var $modify = array('register');
to:
var $display = array('register');
in the file components/com_hikashop/controllers/user.php and that might help.

Please Log in or Create an account to join the conversation.

More
14 years 6 months ago #44837 by erickb
I have not configured any page for registration redirection , where can I find the registration settings in Hikashop ?

I try to modify components/com_hikashop/controllers/user.php but it is core code and it will be impossible to update without taking care for that page

Do you have the link

I am on localhost

thanks

Please Log in or Create an account to join the conversation.

More
14 years 6 months ago - 14 years 6 months ago #44838 by erickb
with var $display = array('register'); in ./components/com_hikashop/controllers/user.php it works

will you change this line in the new 1.5.7 package too ?
Last edit: 14 years 6 months ago by erickb.

Please Log in or Create an account to join the conversation.

More
14 years 6 months ago #44844 by nicolas
Yes, we'll change that on our end if that solves the problem.

Please Log in or Create an account to join the conversation.

More
14 years 6 months ago #44846 by erickb
for me it works

Please Log in or Create an account to join the conversation.

More
14 years 6 months ago #44877 by erickb
il y a quand meme une erreur, des que je me logge j'ai le message

Veuillez saisir votre nom. au dessus de mon compte client qui est bon

Please Log in or Create an account to join the conversation.

More
14 years 6 months ago #44880 by nicolas
Pourriez vous faire une capture ?

Please Log in or Create an account to join the conversation.

More
14 years 6 months ago - 14 years 6 months ago #44892 by erickb
je m'enregistre et j'ai le message

Merci de vous être enregistré sur http://localhost:8888/sacapuce.biz/.

ensuite je me logge et j'ai



si je vais dans la table #__users le user_type est vide alors qu'il devrait etre sur Registered
Last edit: 14 years 6 months ago by erickb.

Please Log in or Create an account to join the conversation.

More
14 years 6 months ago #45097 by nicolas
Le user_type est initialisé avec le code
Code:
$newUsertype = $usersConfig->get( 'new_usertype' ); if (!$newUsertype) { if(version_compare(JVERSION,'1.6','<')){ $newUsertype = 'Registered'; }else{ $newUsertype = 2; } }
dans le fichier administrator/components/com_hikashop/classes/user.php
Bizarre que cela ne fonctionne pas chez vous. Pourriez vous mettre un peu de débug dans la fonction register de ce fichier pour voir si c'est le user_type qui n'est pas défini ?
Si vous rajouter le user_type manuellement, est ce que cela résoud le problème ? Car d'après le message, le problème n'est pas le user_type, mais le nom d'utilisateur. En avez vous un ?
Avez vous le champs sur votre formulaire d'enregistrement ?

Please Log in or Create an account to join the conversation.

More
14 years 6 months ago #45100 by erickb
j'ai redirige sur l'accueil apres connexion donc je ne vois plus ce message, ça vient peut etre de l’enregistrement simplifie, l'email est le nom d'utilisateur
sinon maintenant l'utilisateur est bien dans le groupe 2 , ça marche mais j'ignore pourquoi peut etre les maj

merci

Please Log in or Create an account to join the conversation.

More
14 years 6 months ago #45115 by erickb
dans la table #__users le user_type est vide pour un nouvel enregistrement

Please Log in or Create an account to join the conversation.

More
14 years 6 months ago #45134 by nicolas
Est-ce que cela crée un problème ?
Quel mode d'erengistrement utilisez vous ?
C'est pour le passage en caisse, le formulaire d'enregistrement séparé, ou les deux ?

Please Log in or Create an account to join the conversation.

More
14 years 6 months ago - 14 years 6 months ago #45138 by erickb
c'est juste que ce champ de la table reste vide et que ce n'est pas normal, donc problemes a venir sans doute
j'utilise enregistrement simplifie avec mot de passe, email = username
Last edit: 14 years 6 months ago by erickb.

Please Log in or Create an account to join the conversation.

More
14 years 6 months ago #45355 by nicolas
D'après nos recherches il est normal que ce champs là soit vide vu que la colonne n'est plus du tout utilisée par joomla depuis 1.6

Please Log in or Create an account to join the conversation.

More
14 years 6 months ago #45356 by erickb
ok merci

Please Log in or Create an account to join the conversation.

More
13 years 10 months ago #74057 by likandev

erickb wrote: I have not configured any page for registration redirection , where can I find the registration settings in Hikashop ?


This would be a real nice to have.

Eduardo Chongkan - Likan Development
likandevelopment.com

Please Log in or Create an account to join the conversation.

More
13 years 10 months ago #74060 by nicolas
You can publish the hikashop registration redirection plugin for that.

Please Log in or Create an account to join the conversation.

More
13 years 10 months ago - 13 years 10 months ago #74062 by likandev
Sorry, what would be nice to have is a way to specify to Hikashop where to redirect after registration.

I used an override for the after_register.php file, I ask:
Code:
$user = JFactory::getUser(); global $Itemid; if ($user -> guest) { $app = &JFactory::getApplication(); $app -> enqueueMessage(JText::_('PLEASE_LOGIN_FIRST')); $url = ''; if (!empty($Itemid)) { $url = '&Itemid=' . $Itemid; } if (version_compare(JVERSION, '1.6', '<')) { $url = 'index.php?option=com_user&view=login' . $url; } else { $url = 'index.php?option=com_users&view=login' . $url; } $app -> redirect(JRoute::_($url . '&return=' . urlencode(base64_encode(hikashop_currentUrl())), false)); return false; } $app -> redirect(JRoute::_('index.php?option=com_hikashop&view=user&layout=cpanel&Itemid='.$Itemid), false); return false;

because I don't want the user to land in a white page with only a message.

But now I get a Joomla Warning right after I Login the FIRST time after registration: Please enter your name.

screencast.com/t/kd1d4jvbAH

It comes from: JLIB_DATABASE_ERROR_PLEASE_ENTER_YOUR_NAME.

It does the same if I use:
Code:
JRequest::setVar( 'layout', 'cpanel' ); return parent::display();

At the end of the php in that file.

I'm using: Simple register with Password and Joomla is set to No Activation Required.

Eduardo Chongkan - Likan Development
likandevelopment.com
Last edit: 13 years 10 months ago by likandev.

Please Log in or Create an account to join the conversation.

More
13 years 10 months ago #74082 by likandev
Note, the problem was that I was sending the Register URL in the return parameter of my custom login form.

Eduardo Chongkan - Likan Development
likandevelopment.com

Please Log in or Create an account to join the conversation.

Time to create page: 0.283 seconds
Powered by Kunena Forum