Adding and Deleting from cart

  • Posts: 19
  • Thank you received: 0
9 years 5 months ago #990

It seems when using google chrome when i click add item to cart button it sometimes blinks the page and doesn't add the item. It also does this while deleting from the cart. I tried IE and it worked fine there unable to make it fail there. So this could be a chrome thing but figured I would let you know. www.drivenmetal.com/joomla

Last edit: 9 years 5 months ago by silentblood.

Please Log in or Create an account to join the conversation.

  • Posts: 19
  • Thank you received: 0
9 years 5 months ago #991

Ok now its doing it on IE lol.

Please Log in or Create an account to join the conversation.

  • Posts: 19
  • Thank you received: 0
9 years 5 months ago #993

It seems if i shut my browser and then reopen it. It will add and delete fine. But once i have added and deleted, then attempt to readd again is when it starts getting iffy.

Please Log in or Create an account to join the conversation.

  • Posts: 68556
  • Thank you received: 10217
  • MODERATOR
9 years 5 months ago #996

I see that in the hikashopModifyQuantity javascript function you have the code

window.location = '';
after the ajax request, which is not something we have in the hikashop code. It seems that you added that yourself. That's why you have this behavior. If you download the latest version and reinstall hikashop, the problem should disappear.

Please Log in or Create an account to join the conversation.

  • Posts: 36
  • Thank you received: 0
9 years 5 months ago #1015

I seem to have the same problem, but I haven't changed any such code. I was testing some redirect code I had written and afterwards I noticed that I couldn't add/remove items from my cart..?

I could've written faulty code (since I have little-to-no experience with PHP) that is causing this, but I doubt it because all I changed was some redirect addresses.

Please Log in or Create an account to join the conversation.

  • Posts: 19
  • Thank you received: 0
9 years 5 months ago #1020

I didn't intentionally change any code. Only thing i ever changed that i am aware of is per unit in the english lan :woohoo: guage. Also if i remove it and reinstall will I have to redo all the settings products and stuff. Thxs in advance for all your help.

Last edit: 9 years 5 months ago by silentblood.

Please Log in or Create an account to join the conversation.

  • Posts: 68556
  • Thank you received: 10217
  • MODERATOR
9 years 5 months ago #1023

You don't have to uninstall hikashop. Just download the latest version and install it on top of the previous. You won't loose anything.

Please Log in or Create an account to join the conversation.

  • Posts: 19
  • Thank you received: 0
9 years 5 months ago #1027

ok i did that i got the errors
JInstaller::install: WARNSAME
Error installing Plugin plg_community_hikashop

and my cart posistion reverted to the bottom on the variant items. I know how to fix that from other thread but still didn't fix the problem.

Please Log in or Create an account to join the conversation.

  • Posts: 68556
  • Thank you received: 10217
  • MODERATOR
9 years 5 months ago #1031

You can ignore the WARNSAME error. It's just that your access rights in the plugins folder are not correct.

Try to change the code from

if($this->cartCount()!=1){
to
if($this->cartCount()!=1 && !empty($url)){
in the file administrator/components/com_hikashop/helper/cart.php near line 150. That should avoid the refresh of the page after the refresh of the cart.

Please Log in or Create an account to join the conversation.

  • Posts: 19
  • Thank you received: 0
9 years 5 months ago #1055

I am at work right now. I will try when I get home.

Please Log in or Create an account to join the conversation.

  • Posts: 19
  • Thank you received: 0
9 years 5 months ago #1057

fixed. again good support.

Please Log in or Create an account to join the conversation.

  • Posts: 36
  • Thank you received: 0
9 years 5 months ago #1078

The code you posted helped me as well. Thank you.

Please Log in or Create an account to join the conversation.

  • Posts: 7
  • Thank you received: 0
9 years 4 months ago #1314

Ok, I'm stuck I inherited this site because the last person did not know what they were doing. I'm finding out why he was having problems. The site is having the same issue described above I have to click on add to cart multiple time before any will be added. This also happen when trying to delete items from the cart.

I have tried installing a new copy of the cart and changing the code described above. Please help if you can.

You can visit the live site at www.greenbuffalofood.com

Please Log in or Create an account to join the conversation.

  • Posts: 68556
  • Thank you received: 10217
  • MODERATOR
9 years 4 months ago #1318

Hi,

This issue is fixed in the latest version of HikaShop that we released today. Please update and the problem should be fixed automatically.

Please Log in or Create an account to join the conversation.

  • Posts: 7
  • Thank you received: 0
9 years 4 months ago #1319

OK I just updated using the updater in the shop not 30 min ago. Should this still fix it? I'm running 1.3.4.

Last edit: 9 years 4 months ago by suite121.

Please Log in or Create an account to join the conversation.

  • Posts: 68556
  • Thank you received: 10217
  • MODERATOR
9 years 4 months ago #1320

I just checked your website and I'm able to add products to the cart without the artifact.

Please Log in or Create an account to join the conversation.

  • Posts: 7
  • Thank you received: 0
9 years 4 months ago #1321

Based off you above statement. I'm assuming you are using IE. It is working better in IE, its still a little buggy. In Firefox it is still having the same issue.

Please Log in or Create an account to join the conversation.

  • Posts: 68556
  • Thank you received: 10217
  • MODERATOR
9 years 4 months ago #1322

Actually, I tried with firefox.

Mmm, I tested a bit more and found that sometimes the product isn't added to the cart.

I think it comes for the way the javascript is done: the ajax request which updates the cart is aborted by the browser before it finishes in order to redirect the page. It probably only occurs on your website because it seems a bit slow to load.

Please replace the file administrator/components/com_hikashop/helpers/cart.php by the file in the package enclosed in this post.

File Attachment:

File Name: cart.zip
File Size:2 KB

Attachments:

Please Log in or Create an account to join the conversation.

Time to create page: 0.097 seconds
Powered by Kunena Forum