Skip to main content

HTTP 500 Internal Server Error

More
14 years 2 days ago #67267 by tommo
Hi,

I am getting an HTTP 500 Internal Server Error on checkout. The site has a login area to access the shop.

automaxionltd.com/pur-prod.html If you have a twitter or linkedin account you can login with that

I can setup a user/admin account via pm if you require.

Many thanks,

Tom

Please Log in or Create an account to join the conversation.

More
14 years 2 days ago #67275 by Mohamed Thelji
Hi Tom,

Can you please :
- Turn on the debug mode of the joomla configuration
- Try again
- Do a screenshot of the full error message so that we can see what is going on

Thanks.

Please Log in or Create an account to join the conversation.

More
14 years 2 days ago #67276 by tommo
I am getting this:

Fatal error: Allowed memory size of 25165824 bytes exhausted (tried to allocate 491520 bytes) in /home/sites/automaxionltd.com/public_html/components/com_hikashop/views/product/tmpl/cart.php on line 340

Thanks

Please Log in or Create an account to join the conversation.

More
14 years 2 days ago #67307 by Mohamed Thelji
It means that the memory requirements exceed the default memory limit of your server so you'll probably find your answer there :).

Please Log in or Create an account to join the conversation.

More
13 years 4 months ago #102046 by webhelpus
I'm experiencing the same problem, but memory is not my issue. When I turn on the debugging the "Proceed the Checkout" Link goes to a blank page so I can't give you a screenshot, otherwise it says:

The website encountered an error while retrieving bearstitches.com/new/index.php/component...type-cart?Itemid=102 . It may be down for maintenance or configured incorrectly.
Here are some suggestions:
Reload this webpage later.
HTTP Error 500 (Internal Server Error): An unexpected condition was encountered while the server was attempting to fulfill the request.


site is here bearstitches.com/new/

Please Log in or Create an account to join the conversation.

More
13 years 4 months ago #102056 by nicolas
Please look for the fatal error message corresponding to that 500 error in your PHP error log (you can ask your hosting company if you don't know how). That will give us the necessary information to tell you what's going on.

Please Log in or Create an account to join the conversation.

More
13 years 4 months ago #102059 by webhelpus
Well, apparently now it's working...so I'm guessing it was a hosting issue rather than a HikaShop issue but looking at the log I got this error alot:

Undefined property: stdClass::$category_id in /home2/bearstit/public_html/current/components/com_hikashop/views/product/view.feed.php on line 125

Please Log in or Create an account to join the conversation.

More
13 years 4 months ago #102061 by webhelpus
And now it's not working again with this error in the PHP log

Undefined property: stdClass::$category_id in /home2/bearstit/public_html/current/components/com_hikashop/views/product/view.feed.php on line 125

Please Log in or Create an account to join the conversation.

More
13 years 4 months ago #102065 by nicolas
That is just a warning and it is not related.

Please look for a FATAL ERROR message in the PHP error log.

Please Log in or Create an account to join the conversation.

More
13 years 4 months ago #102067 by webhelpus
It's not displaying any Fatal errors.

Please Log in or Create an account to join the conversation.

More
13 years 4 months ago #102084 by webhelpus
Alright, I'm narrowing it down. The error only happens when I press the "Proceed tho Checkout" on the home page. Any other page it seems to work fine. The difference in links is this:

Home page

bearstitches.com/new/index.php/component...type-cart?Itemid=102


Other pages

bearstitches.com/new/index.php/component...type-cart?Itemid=232
bearstitches.com/new/index.php/handmade-...ckout/cart_type-cart
bearstitches.com/new/index.php/handmade-...ckout/cart_type-cart
bearstitches.com/new/index.php/component...type-cart?Itemid=264



This was the most recent error after I clicked on the link that caused the 500

[02-May-2013 15:33:28 America/Denver] PHP Notice: Undefined property: stdClass::$product_parent_id in /home2/bearstit/public_html/new/administrator/components/com_hikashop/views/product/tmpl/common.php on line 50

Please Log in or Create an account to join the conversation.

More
13 years 4 months ago #102212 by nicolas
So it seems to be caused by the current menu of the checkout.

Maybe you should try to use the "force a menu on checkout" option of the configuration. Maybe that will help to avoid the problem.
The following user(s) said Thank You: webhelpus

Please Log in or Create an account to join the conversation.

More
13 years 4 months ago - 13 years 4 months ago #102261 by webhelpus
That seemed to fix it! Thanks
Last edit: 13 years 4 months ago by webhelpus.

Please Log in or Create an account to join the conversation.

Time to create page: 0.320 seconds
Powered by Kunena Forum