Skip to main content

error processing transaction:270 line item 1 inval

More
13 years 4 months ago - 13 years 4 months ago #105828 by cpaschen
I'm using the latest version of HS (2.1.3) on J2.5.11.
We're using the Authorize.net checkout and when we get to the 'review your order' screen in the checkout process (advanced workflow) we're getting the following error:

There was an error while processing your transaction: 270 Line item 1 is invalid.

And the user is just taken back to that same status page whenever you click the next button.

We also have the check payment (and bank transfer) payment plugin enabled.

We are using UPS and manual shipping methods.

We do require login to checkout.

Can't find anything here that is close to this issue.

Any ideas what might be causing this?

It was working fine prior to a switch to a new server a few days ago.


CORRECTION: When pressing the NEXT button after that error is displayed the user is taken back to the Payment step where they have to fill in their CC info again.

Using the Pay by Check method works fine.
Last edit: 13 years 4 months ago by cpaschen.

Please Log in or Create an account to join the conversation.

More
13 years 4 months ago #105937 by nicolas
Hi,

This is an error returned by Authorize.net because the data being passed to it is not valid.
I see that you're testing with an amount of 0.15 dollars. Are you sure that this amount is not too low for authorize.net ?
It could potentially be because of a non ASCII character in the name of your products:
www.dotnetnuke.com/Resources/Forums/foru...078/scope/posts.aspx

Please Log in or Create an account to join the conversation.

More
13 years 4 months ago #105938 by cpaschen
Any chance anyone has a solution for this?
We've had to disable the shopping cart and client is getting very frustrated.

I guess I'll have to start debugging code to try to isolate this. Just seems that someone might have run into this before (but can't find anything searching here).

Please Log in or Create an account to join the conversation.

More
13 years 4 months ago #105939 by cpaschen
Thanks for those tips; however, these products/prices were working fine before we moved to a new server.

Is there a certain port that the authorize.net hikashop plugin uses?
Just wondering if it might be blocked on the new server.

Please Log in or Create an account to join the conversation.

More
13 years 4 months ago #105973 by cpaschen
Just for 'fun' I've tried with another transaction ($15) and with a product that has only letters in the name/code - still same error.

Can you even tell me where this might be coming from?

I also recently updated HS to the latest version - before the upgrade and the server change everything was working fine.

Please Log in or Create an account to join the conversation.

More
13 years 4 months ago #105974 by cpaschen
Also, we're using a CDN (Incapsula) as well as some tight HTACCESS security controls (only allowing connection to the server from certain IP addresses - mainly the CDN IPs).
Does authorize.net require a live connection to the server from the auth.net servers?

Please Log in or Create an account to join the conversation.

More
13 years 4 months ago #105983 by cpaschen
OK ... finally tracked it down (for anyone else having this issue).

It WAS related to what non-printable ascii codes in the title HOWEVER, Authorize.net (or the HS auth.net payment plugin) somehow interprets " - " (i.e. <space><hyphen><space>) as a non-ascii sequence and that is what was blocking the processing.

I'm not sure exactly how this was working before. But after replacing a couple m-dashes with hyphens and then making sure the spaces around all hyphens were removed, it seems to be working properly.

Thanks for pointing me in the right direction.
The following user(s) said Thank You: nicolas

Please Log in or Create an account to join the conversation.

Time to create page: 0.244 seconds
Powered by Kunena Forum