- Posts: 30
- Thank you received: 0
Authorize.net Transaction Error - Script timed out
We are experienceing repetitive transaction errors with the Authorize.net payment method due to the POST not responding.
The error notice states:
Your script timed out while we were trying to post transaction results to it.
Transaction Result: This transaction has been approved.
This results in the customer being shown a message on screen that 'An error occured . . . contact the merchant'
We are using SIM.
Please advise as to how we can debug and resolve this.
Paul
Please Log in or Create an account to join the conversation.
- Posts: 12953
- Thank you received: 1778
Can you please :
- put ON the "Debug" Option of your Authorize.net payement method
- do a simple test of purshase
- and then send me screenshots of your logs (Hikashop -> Configuration -> Files -> see the report)
It would help us to see what exactly happening.
Please Log in or Create an account to join the conversation.
I activated the logs, placed a couple orders through billing, received the error almost instantaneously. Supposed to be a 10 second timeout.
Logs state they are empty??
Very confused.
Please Log in or Create an account to join the conversation.
Also, try to deactivate the language filter plugin via the plugins manager, it can sometimes cause problems, especially if you don't use the latest version of Joomla.
Please Log in or Create an account to join the conversation.
Thank you for your suggestions.
Unfortunately I am still coming up empty.
The log file path is writable. The reported file path to the log did not exist, as there was no 'logs' directory. After testing and failing a few more times, I created the 'logs' folder, and still POST fails but no log content.
/home/ip3inc/public_html/media/com_hikashop/upload/safe/logs/
I could not locate any language filter plugin, either in the Hikashop or the Joomla plugin manager.
I experimented with the Authorize.net hash value, still with no success.
To confirm use of the Authorize.net MD5 Hash Feature; the value entered in the Authorize.net merchant account settings, and the value entered in the Hikashop Payment plugin 'Your MD5 Hash on Authorize.net' are the same; ie plaintext values?
Your assistance is greatly appreciated.
Please Log in or Create an account to join the conversation.
The value in authorize and in hikashop for the hash should indeed be the same.
Can you give a link to your shop so that we can see the problem ?
Please Log in or Create an account to join the conversation.
Thanks again for your help.
Yes, we are on Joomla 1.5.26
I tried to 'turn off' the Authorize.net MD5 hash value to eliminate that as a possibility, but according to their support once it is activated it cannot be turned off. Verified the values as correct, thank you for the clarification.
POST is still failing, Debug still enabled but still no log file.
Link to cart is www.ip3inc.com/index.php/cloud
There is a coupon 'test' that will reduce the amount.
If you want a temporary admin account I can set that up for you.
Paul
Please Log in or Create an account to join the conversation.
www.zen-cart.com/content.php?302
It could potentially be the sending of the email if your email server is slow.
Someone else having that error had the problem fixed after switching to another hosting:
www.zen-cart.com/showthread.php?82164-Au...o-the-merchant/page3
MD5 should be set in both HikaShop and authorize.net.
Please Log in or Create an account to join the conversation.
Thanks for the information.
This error appears in the log:
client denied by server configuration: /home/ip3inc/public_html/media/com_hikashop/upload/safe/logs/
That help any?
I have opened a ticket with our host, hopefully that can point me in a new direction.
Paul
Please Log in or Create an account to join the conversation.
[30-Apr-2012 20:41:09 UTC] PHP Warning: include(/home/ip3inc/public_html/components/com_hikashop/controllers/.php) [<a href='function.include'>function.include</a>]: failed to open stream: No such file or directory in /home/ip3inc/public_html/components/com_hikashop/hikashop.php on line 44
First appeared April 30, and recurrs quite a lot since. I suspect that was around the time I added the MD5 hash value.
Paul
Please Log in or Create an account to join the conversation.
Array
(
[x_MD5_Hash_calculated] => 49372D923B9B9D28BD0C15D5F6AF35A4
)
Could not load any order for your notification Array
(
[x_MD5_Hash_calculated] => 49372D923B9B9D28BD0C15D5F6AF35A4
)
Could not load any order for your notification Array
(
[x_MD5_Hash_calculated] => 49372D923B9B9D28BD0C15D5F6AF35A4
)
Could not load any order for your notification
--Which is what I thought. Something amiss with the Hash value.
Please Log in or Create an account to join the conversation.
There must be a plugin on your website which redirects the notification request to another page BEFORE it reachs HikaShop and thus when it reachs HikaShop, all the parameters of the notification are already lost.
On 2.5, the language filter plugin can cause such things.
SEF components can sometimes cause such things.
I would recommend you to try to disable the plugins one by one on your website to try to identify if it comes from one of them.
Please Log in or Create an account to join the conversation.
I have 150 plugins.
Would this be true if it were not using the MD5 hash value?
Before setting the value, it worked fine.
Paul
Please Log in or Create an account to join the conversation.
Repeated tests of the Authorize.net payment plugin result in the same hash value in the log. This value should change with the amount of the order.
Why wouldn't the hash value change?
Also, this error persists in the logs:
[21-May-2012 13:40:38 UTC] PHP Warning: include() [<a href='function.include'>function.include</a>]: Failed opening '/home/ip3inc/public_html/components/com_hikashop/controllers/.php' for inclusion (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/ip3inc/public_html/components/com_hikashop/hikashop.php on line 44
Please explain.
Paul
Please Log in or Create an account to join the conversation.
That error also comes from that. The post parameters are lost when the payment notification from authorize.net arrives to HikaShop, so HikaShop cannot load the correct controller.
If you were to remove the md5 hash, it wouldn't work either.
Please Log in or Create an account to join the conversation.
Thank you again for the information.
From the access logs, this appears to be the request;
21/May/2012:08:41:18 -0500] "POST /index.php?option=com_hikashop&ctrl=checkout&task=notify¬if_payment=authorize&tmpl=component&lang=en&Itemid=540 HTTP/1.1" 303 - "-" "-"
That help any?
Paul
Please Log in or Create an account to join the conversation.
Mobile Joomla 1.0.3.1
Gonna post on their forum to see what advice they can provide.
With it off, Hika and Authorize play just fine, even using MD5 hash
Thanks Nicolas.
Please Log in or Create an account to join the conversation.
I'll add mobile joomla to the list of possibilities in the documentation.
Let us know what they say. It's probably because they don't take into account that requests to the website can come from payment servers and thus don't handle these requests properly.
Please Log in or Create an account to join the conversation.
This was not mentioned in the documentation, nor in this forum post.
Now I have two customer transactions, total $4,200, that appeared to process normally when they did not.
PLEASE adjust the documentation to reflect the fact that placing the Authorize.net payment plugin in Debug mode will place the account in Test Mode and transactions will generate 'Merchant Email Receipt' indicating 'This transaction has been approved.' and update the Hikashop order status, but they will not post to customer credit card nor to your merchant account.
Please Log in or Create an account to join the conversation.
Note that you have big "test mode" messages on authorize.net's interface when you activate the test mode.
Please Log in or Create an account to join the conversation.