[j4] l'insertin de produit via le plugin fait planté mon site

  • Posts: 138
  • Thank you received: 2
  • Hikashop Business
1 week 4 days ago #336100

-- HikaShop version -- : 4.4.3
-- Joomla version -- : 4.0.3

hello je viens de faire un test
1 j'ajoute un produit via l'appel produit

{product 123|name|cart|description|pricedis3|pricetax1}
2 je lance ma page
le template en template creator plante
avec cassiopeda j'ai cette erreur
WebAssetManager is locked, you came late
des idées ?

Please Log in or Create an account to join the conversation.

  • Posts: 73880
  • Thank you received: 11330
  • MODERATOR
1 week 3 days ago #336108

Bonjour,

Je n'ai pas le souci de mon coté.
L'erreur indique qu'il y a quelque chose qui essai de rajouter un fichier JS ou CSS ou directement du CSS ou du JS dans le head de la page alors que la page a déjà été générée.
Cependant, de notre coté, nous rajoutons directement le CSS/JS au head sans passer par Joomla, donc cela évite ce problème.
Du coup, je ne sais pas pourquoi vous avez cette erreur.
Pourriez-vous activer l'error reporting et le debug system dans la configuration Joomla et refaire l'expérience ? Cela devrait fournir plus d'information sur le soucis et nous permettre de comprendre d'où vient le problème.

Please Log in or Create an account to join the conversation.

  • Posts: 138
  • Thank you received: 2
  • Hikashop Business
1 week 3 days ago #336110

Please Log in or Create an account to join the conversation.

  • Posts: 73880
  • Thank you received: 11330
  • MODERATOR
1 week 3 days ago #336112

Bonjour,

L'erreur est différente sur cette page. C'est d'ailleurs une erreur que nous avons corrigé de notre coté début juillet.
Téléchargez à nouveau le paquet d'installation de la 4.4.3 sur notre site et installez-le sur le votre et vous aurez le patch pour ce souci.

Please Log in or Create an account to join the conversation.

  • Posts: 138
  • Thank you received: 2
  • Hikashop Business
1 week 3 days ago #336114

et bien c'est ca ! j'ai du avoir un version pas complete !
juste une autre question
c'est un produit de donation
si je charge que mon produit j'ai bien le champs pour ajouter la valeur voulue
mais si j'utilise l'appel plugin le champs ne s'affiche pas j'ai que le bouton ajouter au panier !
comment faire ?

Last edit: 1 week 3 days ago by c-line.

Please Log in or Create an account to join the conversation.

  • Posts: 73880
  • Thank you received: 11330
  • MODERATOR
1 week 3 days ago #336117

Bonjour,

Il n'y a pas de paramètre dans les tags de contenu qui permette de gérer cela.
Le système se base sur l'option "Display custom item fields" de l'onglet "Display" de la configuration HikaShop pour afficher ou non les champs personnalisés item (article) pour les tags de contenu.
Donc j'imagine que vous devez avoir cette option désactivée.

Please Log in or Create an account to join the conversation.

  • Posts: 138
  • Thank you received: 2
  • Hikashop Business
1 week 3 days ago #336129

alors l'option est bien activé je voit bien le champs quand je suis dans le produit mais pas quand je charge le produit dans un article

Please Log in or Create an account to join the conversation.

  • Posts: 73880
  • Thank you received: 11330
  • MODERATOR
1 week 3 days ago #336132

Désolé, j'ai vérifié le code mais il n'y a pas de support des champs personnalisés de la table item pour les tags de contenu.

Nous allons voir pour rajouter cela pour la prochaine version d'HikaShop.

Please Log in or Create an account to join the conversation.

  • Posts: 138
  • Thank you received: 2
  • Hikashop Business
1 week 3 days ago #336147

ok cool ! des idée du timing pour la prochaine version ?

Please Log in or Create an account to join the conversation.

  • Posts: 73880
  • Thank you received: 11330
  • MODERATOR
1 week 2 days ago #336148

Courant Octobre

Please Log in or Create an account to join the conversation.

  • Posts: 138
  • Thank you received: 2
  • Hikashop Business
1 week 2 days ago #336166

Super

Please Log in or Create an account to join the conversation.

  • Posts: 138
  • Thank you received: 2
  • Hikashop Business
3 days 15 hours ago #336272

j'ai mis a jour en 4.4.4
et j'ai la page qui plante

0 Too few arguments to function hikashopProductClass::loadCustomItemFieldsForProductsListing(), 1 passed in /home/com3web5/revue.com3elles.com/plugins/system/hikashopproductinsert/hikashopproductinsert.php on line 389 and exactly 2 expected
Call stack
#	Function	Location
1	()	JROOT/administrator/components/com_hikashop/classes/product.php:2510
2	hikashopProductClass->loadCustomItemFieldsForProductsListing()	JROOT/plugins/system/hikashopproductinsert/hikashopproductinsert.php:389
3	plgSystemHikashopproductInsert->_processProduct()	JROOT/plugins/system/hikashopproductinsert/hikashopproductinsert.php:123
4	plgSystemHikashopproductInsert->onAfterRender()	JROOT/libraries/src/Plugin/CMSPlugin.php:285
5	Joomla\CMS\Plugin\CMSPlugin->Joomla\CMS\Plugin\{closure}()	JROOT/libraries/vendor/joomla/event/src/Dispatcher.php:486
6	Joomla\Event\Dispatcher->dispatch()	JROOT/libraries/src/Application/EventAware.php:111
7	Joomla\CMS\Application\WebApplication->triggerEvent()	JROOT/libraries/src/Application/CMSApplication.php:1042
8	Joomla\CMS\Application\CMSApplication->render()	JROOT/libraries/src/Application/SiteApplication.php:804
9	Joomla\CMS\Application\SiteApplication->render()	JROOT/libraries/src/Application/CMSApplication.php:284
10	Joomla\CMS\Application\CMSApplication->execute()	JROOT/includes/app.php:63
11	require_once()	JROOT/index.php:32
des idées ?

Please Log in or Create an account to join the conversation.

  • Posts: 73880
  • Thank you received: 11330
  • MODERATOR
3 days 14 hours ago #336274

Merci du retour.
C'est un oubli.
Changez la ligne:
function loadCustomItemFieldsForProductsListing(&$rows, $options) {
en:
function loadCustomItemFieldsForProductsListing(&$rows, $options = array()) {
dans /administrator/components/com_hikashop/classes/product.php et cela corrigera le souci.
Nous allons rajouter la modification de notre coté aussi.

Last edit: 3 days 14 hours ago by nicolas.

Please Log in or Create an account to join the conversation.

  • Posts: 138
  • Thank you received: 2
  • Hikashop Business
3 days 14 hours ago #336277

C'est top c'est réglé
par contre je ne voit pas dans le change log l'ajout des champs custom comme évoquer dans ce post

Please Log in or Create an account to join the conversation.

  • Posts: 73880
  • Thank you received: 11330
  • MODERATOR
3 days 11 hours ago #336279

Pourtant c'est bien mentionné dans le changelog:

We've made some modifications to support custom item fields for content tags.

Please Log in or Create an account to join the conversation.

  • Posts: 138
  • Thank you received: 2
  • Hikashop Business
3 days 10 hours ago #336287

a bizarre de mon coté le champs ne s'affiche pas ...
il faut mettre a jour l'appel du plugin ?.

Please Log in or Create an account to join the conversation.

  • Posts: 73880
  • Thank you received: 11330
  • MODERATOR
3 days 6 hours ago #336289

Avez-vous bien activé l'option "Display custom item fields" de l'onglet "Display" de la configuration HikaShop ?
Aussi, il se pourrait que le souci soit particulier à un certain cas de figure. Pourriez-vous fournir une capture d'écran des paramètres de votre champ personnalisé ? Quel tag utilisez-vous exactement ? Et pourriez vous aussi fournir une capture d'écran des options du produit pour lequel vous ajoutez ce tag ?
Cela nous permettra d'avoir un cas concret et précis pour reproduire le problème.

Please Log in or Create an account to join the conversation.

  • Posts: 138
  • Thank you received: 2
  • Hikashop Business
3 days 6 hours ago #336296

pour l'affichage du champ
oui


pour le produit


pour le champ


le tag
{product 123|name|cart|link}
la page
This message contains confidential information


Dans la vrai page produit aucun soucis

Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 73880
  • Thank you received: 11330
  • MODERATOR
3 days 3 hours ago #336299

Bonjour,

Comme un tag peut afficher plusieurs produits à la fois, c'est considéré comme un listing de produit. Donc si vous voulez que le champs s'affiche avec le tag, il faut que l'option "liste de produits en partie publique" soit activée dans le champ personnalisé.
Aussi, vous voudrez surement que le champs soit requis. Si vous auriez fait cela, le bouton d'ajout au panier se serait transformé en bouton "choisir les options" si l'option d'affichage sur les listings n'était pas activée.

Please Log in or Create an account to join the conversation.

  • Posts: 138
  • Thank you received: 2
  • Hikashop Business
3 days 3 hours ago #336301

parfait !!!
Merci

Please Log in or Create an account to join the conversation.

Time to create page: 0.111 seconds
Powered by Kunena Forum