Not all images loading into Product Carousel

  • Posts: 51
  • Thank you received: 0
7 years 3 months ago #188072

-- HikaShop version -- : 2.3.5
-- Joomla version -- : 3.3.6
-- PHP version -- : 5.3.27
-- Browser(s) name and version -- : Chrome 40.0.2214.91 and IE 11

No error messages, but have noticed on the pages where I have the carousel enabled, only 7 of the product images will load. The remaining images do not load. The title text displays and the links work, but the images do not load. I do not observe this behaviour in Safari, but I do in Firefox, Chrome and IE 11. I am using a JoomlaBamboo template that is supposed to be optimized for Hikashop. Not sure if this issue is Joomla, Hikashop, the template, or from my ISP. Have you encountered this issue before? Do you know of a solution.

Thanks!

Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 25258
  • Thank you received: 3909
  • MODERATOR
7 years 3 months ago #188076

Hi,

The link you gave require to be logged ; so we can't take a look at your issue.

Regards,


Jerome - Obsidev.com
HikaMarket & HikaSerial developer / HikaShop core dev team.

Also helping the HikaShop support team when having some time or couldn't sleep.
By the way, do not send me private message, use the "contact us" form instead.

Please Log in or Create an account to join the conversation.

  • Posts: 25258
  • Thank you received: 3909
  • MODERATOR
7 years 3 months ago #188193

Hi,

Your template have a "image lazy loading" in his javascript.
This script hide all images which are not "visible" in the page (outside of the page size) and display them when you "scroll".

Because some images in the carousssel are outside of the page, the script hide them ; but when you navigate in the carousel, you do not scroll.
That's why this "lazyload" script hide the images but not re-display them.
You can test it by moving the carousel in order to "see" the not loaded image and scroll in the page.

Regards,


Jerome - Obsidev.com
HikaMarket & HikaSerial developer / HikaShop core dev team.

Also helping the HikaShop support team when having some time or couldn't sleep.
By the way, do not send me private message, use the "contact us" form instead.

Please Log in or Create an account to join the conversation.

  • Posts: 158
  • Thank you received: 6
7 years 3 months ago #188611

I also had the same issue. It can be controlled by one of two methods. I am using the T3 framework with a Joomla Bamboo template:

1. If the slideshow is on the homepage only, create a copy of your template and assign it to Home Menu Item. Under effects elect to turn off Lazy Load.

2. If you have it on multiple pages, simply add the module class suffix nolazy to your carousel module. screencast.com/t/9xuF477nH This nolazy is denoted under effects in the template parameters.

It fixed it for me.

Best,

Dawn

The following user(s) said Thank You: Jerome

Please Log in or Create an account to join the conversation.

  • Posts: 51
  • Thank you received: 0
7 years 3 months ago #189102

Thank you both so much. That did the trick!

Please Log in or Create an account to join the conversation.

Time to create page: 0.072 seconds
Powered by Kunena Forum