checkout loop

  • Posts: 38
  • Thank you received: 0
3 weeks 2 days ago #313347

-- url of the page with the problem -- : www.barbaragiganti.com/shop/bags.html
-- HikaShop version -- : 4.0.0
-- Joomla version -- : 3.9.13

Hi
I made a check trying to process an order on the site and I'm currently stuck at checkout step 2.
If I press NEXT, it goes back to step 1.

What could be the issue?

Please Log in or Create an account to join the conversation.

  • Posts: 2328
  • Thank you received: 302
  • MODERATOR
3 weeks 2 days ago #313348

Hello,

Most often in this kind of issue, if your checkout is unable to reach next step, it's because an element is missing, can say more without more elements.
And so, can you provide :
- Your Checkout Configuration page screenshot (complete page will be better).
- An Url link to see by ourselves your checkout

Awaiting news from you.
Regards

Last edit: 3 weeks 2 days ago by Philip.

Please Log in or Create an account to join the conversation.

  • Posts: 38
  • Thank you received: 0
2 weeks 3 days ago #313520

Hi Philip
I'm sending the link via PM
Thanks

Please Log in or Create an account to join the conversation.

  • Posts: 67676
  • Thank you received: 10046
  • MODERATOR
2 weeks 3 days ago #313522

Hi,

We tried to look into it.
However, the checkout require a user account, and thus I tried creating a user account, but then I had to validate the account with the confirmation link sent by email, but there is an error displayed on your website stating that there is an error with the SMTP settings of your Joomla configuration.
So I couldn't move past that.
Please provide a test user account so that we can reproduce the issue.

Please Log in or Create an account to join the conversation.

  • Posts: 38
  • Thank you received: 0
2 weeks 2 days ago #313552

Hi, sorry.
I've corrected the SMTP settings and it's now working.
I'm sending you a test account via PM

Thanks for your help

Please Log in or Create an account to join the conversation.

  • Posts: 67676
  • Thank you received: 10046
  • MODERATOR
2 weeks 2 days ago #313556

Hi,

Thank you. I was able to reproduce the issue.
I would recommend to turn off the "checkout legacy" setting in the HikaShop configuration in order to switch to the new checkout system instead of the legacy checkout you're now using which comes from HikaShop 1.x and is really old.
That should fix the problem.
If not, updating your HikaShop would be the next thing I would recommend.

Please Log in or Create an account to join the conversation.

  • Posts: 38
  • Thank you received: 0
2 weeks 2 days ago #313579

Salut Nicolas
cela a fonctionné. Merci beaucoup!

Please Log in or Create an account to join the conversation.

Time to create page: 0.063 seconds
Powered by Kunena Forum