Création produit impossible à cause de variantes

  • Posts: 9
  • Thank you received: 2
1 year 9 months ago #344153

-- url of the page with the problem -- : pepiniere-ellebore.com/fr/boutique/category/188-b
-- HikaShop version -- : 7.4.25
-- Joomla version -- : 3.10.11 Stable
-- PHP version -- : 7.4.25
-- Browser(s) name and version -- : Chrome Version 104.0.5112.101
-- Error-message(debug-mod must be tuned on) -- : Veuillez remplir le champ Fam
Veuillez remplir le champ Origine
Erreur lors de la sauvegarde

Bonjour à la communauté.
Je ne peux plus créer de produit sur mon site.
J'ai un pb avec les variantes ce alors que j'en ai créé.
Il s'agit d'une pépinière et j'ai des caractériques avec Famille, Origine et nombre de pieds. Seule la dernière a été conservée. J'ai du recréer les deux premières mais cela ne suffit pas.
L'onglet Variantes apparaît bien après que j'ai tenté d'enregistrer un nouveau produit mais j'ai en rouge un message qui dit :

Veuillez remplir le champ Fam
Veuillez remplir le champ Origine
Erreur lors de la sauvegarde

Comment régler ce souci ? Je vous remercie.

Christophe MAUBOUSSIN

Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 81853
  • Thank you received: 13143
  • MODERATOR
1 year 9 months ago #344165

Bonjour,

Ces messages indiquent que vous avez des champs personnalisés de la table "produit" avec le nom "Fam" et "Origine" qui sont requis et que vous n'avez pas rempli.
Vérifiez cela via le menu Affichage>Champs personnalisés.

Please Log in or Create an account to join the conversation.

  • Posts: 9
  • Thank you received: 2
1 year 9 months ago #344227

Bonjour Nicolas et merci pour votre retour.
Je suis allé dans Affichage>Champs personnalisés.
Je ne peux ajouter de champ dans table (en l'occurence Adress...) et non produits.


Je n'avais pas utilisé cette méthode quand j'avais créé les spec il y a de cela plusieurs années mais dans produits -> Caractéristiques.
J'ai recréé "Origin" et "Fam", seul "nombre de pieds" est resté, très étrange.

Quand je créé un produit, je peux ajouter des spéc (ici Origin-> Corse et famille = truc) mais lorsque j'enregistre j'ai à nouveau le même message d'erreur en rouge...


J'avais acheté la version commerciale à l'origine de ce projet, je ne l'ai pas renouvelé (pour info).

Je ne vraiment pas comment me dépatouiller de ce pb.

Bonne fin de journée

Christophe

Please Log in or Create an account to join the conversation.

  • Posts: 81853
  • Thank you received: 13143
  • MODERATOR
1 year 9 months ago #344232

Bonjour,

Le message "Veuillez remplir le champ" vient du système de champ personnalisé.
J'imagine que vous aviez créé des champs sur la table produit avec HikaShop Business, et en passant sur HikaShop Starter, vous ne les avez plus dans l'interface, mais le code de la sauvegarde du produit doit quand même les trouver.
Allez dans votre PHPMyAdmin, et ouvrez la table hikashop_field
Vérifiez si vous avez des champs avec field_table égal à "product". Si oui, supprimez-les vu que de toute façon, vous ne pouvez plus les utiliser avec la Starter et cela devrait régler le problème.

Please Log in or Create an account to join the conversation.

  • Posts: 9
  • Thank you received: 2
1 year 9 months ago #344256

Bonjour et merci Nicolas.
C'était bien cela.
Ca fonctionne à nouveau.
Mille mercis.

Bonne fin de journée

Cordialement

Christophe

The following user(s) said Thank You: nicolas

Please Log in or Create an account to join the conversation.

Time to create page: 0.100 seconds
Powered by Kunena Forum