Coupon percentage of shipping blocks checkout

  • Posts: 18
  • Thank you received: 0
  • Hikashop Business
9 months 3 weeks ago #301910

-- HikaShop version -- : HikaShop Business 4.0.1
-- Joomla version -- : 3.9.1
-- PHP version -- : 7.2.12
-- Browser(s) name and version -- : Firefox 65.0b5

Hello,

I am running into an issue with the shipping discount coupon system.

My checkout process is configured this way :
1. Cart review
2. Connexion
3. Adress
4. shipping method
5. recap and coupon field and terms checkbox

The issue appears when a coupon is selected and user comes back to step 1. 2. 3. or 4.
When a coupon is selected, the checkout is blocked either at the address selection step, either at the shipping selection step.
When the shipping coupon is 100% or 0% of shipping price, everthing works, when the shipping coupon reduction is another value, the next button click stays on the same checkout step.
When the chosen shipping method is free, the checkout process works fine too.
Is there an paramter I didn't se correctly?

Please Log in or Create an account to join the conversation.

  • Posts: 67109
  • Thank you received: 9946
  • MODERATOR
9 months 2 weeks ago #301924

Hi,

Please provide precise instructions to reproduce the problem on your website and a screenshot of the settings of the coupon we can use to reproduce the issue.
Please also provide a screenshot of the settings of the shipping method.
That will allow us to get a better idea of how everything is setup.

Please Log in or Create an account to join the conversation.

  • Posts: 18
  • Thank you received: 0
  • Hikashop Business
9 months 2 weeks ago #301937

Thank you for your reply, this is the screenshot of the coupon :



This is the screenshot of the checkout configuration :


The steps to reproduce :
  1. Add items to cart
  2. Proceed to checkout untill last step
  3. Enter a coupon code
  4. Go back to first step
  5. Proceed to checkout
  6. Choose a non free shipping method
  7. Click next button

Expected behaviour : The checkout proceeds to next step
Behaviour I am experiencing : The click on next button doesn't proceed to next step and reloads the same page over and over again

As said in previous post, choosing a free shipping method works and coupons with 100% or 0% disount on shipping fees work too.
I hope I have describe the issue sufficiently, if you need more information, feel free to ask.

Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 67109
  • Thank you received: 9946
  • MODERATOR
9 months 2 weeks ago #301940

HI,

I'm sorry but I'm not able to reproduce the problem. I couldn't find any add to cart button on the different pages of your website where I went. Please provide precise instructions.
Also, you didn't provide a screenshot of the settings of your shipping methods (menu System>Shipping methods) and the screenshot of the configuration settings is not readable as it's too blurry. Could you provide these please ?

Please Log in or Create an account to join the conversation.

  • Posts: 18
  • Thank you received: 0
  • Hikashop Business
9 months 2 weeks ago #301989

Hello,

It is normal as the website is live and I am hiding the ad to cart buttons from users at the moment. I cannot display them yet as hikashop isn't fully configured. For the shipping methods, I have 19 configured. Maybe the simplest would be to give you acces to the backend so you can take a look? Please give me an emails so I can send you credentials.

Please Log in or Create an account to join the conversation.

  • Posts: 67109
  • Thank you received: 9946
  • MODERATOR
9 months 2 weeks ago #301993

Hi,

I don't need the screenshot of the settings of all your shipping methods.
What I need are precise instructions to reproduce the problem on your website, and a screenshot of the settings of the elements involved (coupon settings if there is one used, shipping method settings if there is one used, product settings).
If I can't reproduce the problem and see these settings I can't say much since I don't have the problem on my end and I can't analyze the situation on your website.

Please Log in or Create an account to join the conversation.

  • Posts: 18
  • Thank you received: 0
  • Hikashop Business
9 months 1 week ago #302099

Hello Nicolas,

Sorry for the long delay and happy new year ;)
Here is the screenshot of one of my shipping methods :



And here are screenshots of the checkout global configuration :




Last edit: 9 months 1 week ago by web-tiki.

Please Log in or Create an account to join the conversation.

  • Posts: 67109
  • Thank you received: 9946
  • MODERATOR
9 months 1 week ago #302111

Hi,

So I don't see a screenshot of the settings of a coupon. Does that mean that the problem happens even without a coupon ?
Also, I see that you have a restriction on a custom zone in your shipping method. Could you do a screenshot of the settings of that zone ?
Also, I see that you have custom fields of the table "order" set on your checkout. It might well be linked to that. Do you still have the problem if you remove the "fields" view from your checkout workflow ?
The goal of all this is to narrow down the possibilities.

Finally, you didn't provide any instructions to reproduce the problem on your website.
If you don't want users to have the add to cart buttons you could just hide them with one line of CSS. That way, I would be able to easily use the add to cart buttons while your users won't even see any difference.

The following user(s) said Thank You: web-tiki

Please Log in or Create an account to join the conversation.

  • Posts: 18
  • Thank you received: 0
  • Hikashop Business
9 months 1 week ago #302152

Hello Nicolas,
I have tried disabling the custom fields but the issue is still there. I have sent you an email with the steps to reproduce the issue (I sent it to this address : This email address is being protected from spambots. You need JavaScript enabled to view it.).
Thank you for your help.

Please Log in or Create an account to join the conversation.

  • Posts: 67109
  • Thank you received: 9946
  • MODERATOR
9 months 1 week ago #302160

Hi,

I was able to reproduce the issue with the instructions provided.
However, I wasn't able to access your HikaShop configuration. It seems that the user account you provided doesn't have the access rights to access the HikaShop configuration.
It is crutial that we can access the HikaShop checkout settings to better understand the situation.
Also, a FTP access might be necessary so that we can debug the code as it seems to be more complex than I initially thought. Coudl you also provide that via our contact form ?

Please Log in or Create an account to join the conversation.

  • Posts: 18
  • Thank you received: 0
  • Hikashop Business
9 months 6 days ago #302225

Hi Nicolas,
I have changed the access rights and provided the FTP information by mail.
Thank yoyu for you help.

Please Log in or Create an account to join the conversation.

  • Posts: 67109
  • Thank you received: 9946
  • MODERATOR
9 months 4 days ago #302364

Hi,

Thank you. We were able to find the issue and applied a patch. It's now working fine.
For anyone else reading this, this patch was added as a hot fix so you can download the install package on our website and install it on yours to get the patch. IT will also be in the next releases of HikaShop.

Please Log in or Create an account to join the conversation.

  • Posts: 18
  • Thank you received: 0
  • Hikashop Business
9 months 4 days ago #302369

Hello Nicolas,

Thank you for the patch, is there anything I need to do now? I have tested again and the bug is still there.
I can't go to next step once I have selected a coupon and come back to first step.

Please Log in or Create an account to join the conversation.

  • Posts: 67109
  • Thank you received: 9946
  • MODERATOR
9 months 4 days ago #302387

Hi,

There was nothing else. I had tested the solution and it worked. However, I tested again today and I was able to reproduce again the issue. However, this time it came from something else and the issue only happened some times, not always. I've added a second patch to fix that and it seems to be ok now.

Please Log in or Create an account to join the conversation.

  • Posts: 18
  • Thank you received: 0
  • Hikashop Business
9 months 3 days ago #302413

Hello Nicolas,
Thank you for the work but I have tested again (with firefox and chrome) but the bug doesn't seems to be solved and I am still blocked at the address step...

Please Log in or Create an account to join the conversation.

  • Posts: 67109
  • Thank you received: 9946
  • MODERATOR
9 months 3 days ago #302421

Hi,

I've added yet another patch. Can you try again please ?

The following user(s) said Thank You: web-tiki

Please Log in or Create an account to join the conversation.

  • Posts: 18
  • Thank you received: 0
  • Hikashop Business
9 months 3 days ago #302455

Hello Nicolas,
I have tested and it worked!
Thank you for the support :)

Please Log in or Create an account to join the conversation.

Time to create page: 0.120 seconds
Powered by Kunena Forum