Problems with Hikashop search (filters)

  • Posts: 144
  • Thank you received: 2
1 year 9 months ago #299298

-- HikaShop version -- : 3.4.0
-- Joomla version -- : 3.8.12
-- PHP version -- : 7.1

Hello, I'm having issues with my search. I've configured it to search on the product name and sku, but when I cut n paste the full product name into my search bar, it finds nothing. I also can't get the product code search to work either. It does return basic search results i.e. if I type in part of the product name - very odd!

I've attached my config screens

Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 70181
  • Thank you received: 10507
  • MODERATOR
1 year 9 months ago #299303

Hi,

I don't see the problem: monosnap.com/file/U01LTCOH8qId1TXzAuiiKLfHglSuWz
Could you provide a precise example along with a screenshot of the settings of the product you're searching for ?

Please Log in or Create an account to join the conversation.

  • Posts: 144
  • Thank you received: 2
1 year 9 months ago #299312

Here's an example ... Yamaha RX-A870 Aventage 7.2 Black Receiver returns a page of assorted products including other yamaha products but not the one I searched for?

Here's the config for that product.I thought it might be the canonical urls as I changed the menu heading recently but none of my products have them.

Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 70181
  • Thank you received: 10507
  • MODERATOR
1 year 9 months ago #299314

Hi,

I do see that product at the end of the first page of results when searching for its name:
monosnap.com/file/dfwOL43R0lXId4shbm1BvLVOCI5zOB

And it's normal that you have the other products there since you've configured your filter's "search processing" setting to "any word".
So if you search for "Yamaha RX-A680 Aventage 7.2 Black Receiver" all the products with at least one of these words will show up in the results.

Please Log in or Create an account to join the conversation.

  • Posts: 144
  • Thank you received: 2
1 year 9 months ago #299361

OK, I've changed the setting to 'every words' but I still can't get some products to return results - try searching for Panasonic TX-65EZ1002B 65 inch UHD 4K Pro HDR OLED TV.

Here is the config for that product;

Attachments:
Last edit: 1 year 9 months ago by serbofleconcepts.

Please Log in or Create an account to join the conversation.

  • Posts: 70181
  • Thank you received: 10507
  • MODERATOR
1 year 9 months ago #299395

Hi,

When you're looking at that page without any filter:
test.leconcepts.com/search
you get a listing of 115 products. So it's supposed to be all the products of your shop.
And the filters will search among these products.
However, that product doesn't appear there:
monosnap.com/file/npwPRPDBDGCsas2vKmbYuSt8zwFrt3
So that's why you can't search for that product.
In the menu item "search", you need to configure it to display a listing of all the products of your shop if you want the filters to apply on all of them.
So you need to check the settings of that menu item via the Joomla menu manager.

Please Log in or Create an account to join the conversation.

  • Posts: 144
  • Thank you received: 2
1 year 9 months ago #299418

Great, I think I've sorted it. I had the menu item for search set for direct sub elements. When I set it for all sub sub elements it fixed it. I had no idea that sub elements actually meant sub menu items.

Thank you for your help.

Please Log in or Create an account to join the conversation.

  • Posts: 70181
  • Thank you received: 10507
  • MODERATOR
1 year 9 months ago #299419

Hi,

It's not sub menu items, but sub categories.

Please Log in or Create an account to join the conversation.

  • Posts: 144
  • Thank you received: 2
1 year 9 months ago #299480

Thanks for the response Nicolas.

That doesn't make any sense as I only have direct sub categories?


My search stopped working correctly when I added the additional sub menu level under some of my categories.

Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 70181
  • Thank you received: 10507
  • MODERATOR
1 year 9 months ago #299483

Hi,

Well, I don't know what you did exactly but I can assure you that this option is for sub categories.
When it is set to "direct sub elements", it will only display the products of the category selected in the "main category" setting above.
When it is set to "all sub elements", it will display both these products and the products of the categories below the category selected in that main category setting.

Last edit: 1 year 9 months ago by nicolas.

Please Log in or Create an account to join the conversation.

Time to create page: 0.097 seconds
Powered by Kunena Forum