Filter options dissapear on filter

  • Posts: 172
  • Thank you received: 8
  • Hikashop Multisite
2 weeks 6 hours ago #315355

-- HikaShop version -- : 4.2.2
-- Joomla version -- : 3.9
-- PHP version -- : 7.2

Hi guys,

When i have the filter for category and the filter is submitted, on click or on the button all other categories disappear.
So it is not really flexible to add, change delete one by one filters and that is kinda frustrating.

This is a preview of a big website with good filters:
tweakers.net/categorie/822/tablets/produ...RKijKTE71zcxTsjKoBQA

This website has many many products.
When i click on a filter it is just checked and directly filtered.
I can add filters, delete it by deselecting the checkbox.

Here a video to show my issue:
www.dropbox.com/s/cpp927b55bauo84/filterissue.mov?dl=0

So when i do this on Hikashop all other filters disappear.
If I am super fast I can filter 2 categories but hey are added as one filter and i must delete both before i see the others again.
If you ask me this is unwanted, not user friendly and i never have seen this way on an other website.

The benefits of the Tweakers website is that you always see all the filters, it does not collapse.
Also you see the products behind the filter that are in that category (not calculated again after filter, just total).
Joomlart does the same but rewrite the whole page that i do not want, you loos many Hikashop options :-)
ja-megafilter.demo.joomlart.com/index.ph...rt=price&sortdir=asc

Please Log in or Create an account to join the conversation.

  • Posts: 1119
  • Thank you received: 114
2 weeks 5 hours ago #315357

Hi,

Have you tried to set "Deletable filter" to "NO" in filter settings? That's should fix your issue.

Hope that helps.

Thanks

Please Log in or Create an account to join the conversation.

  • Posts: 68132
  • Thank you received: 10158
  • MODERATOR
1 week 6 days ago #315356

Hi,

If the filter options disappear when you use a filter that's because you either have the "deletable filter" setting activated or the "dynamic display" setting activated.
Please turn off both options in your filters and it should work the same.

Please Log in or Create an account to join the conversation.

  • Posts: 172
  • Thank you received: 8
  • Hikashop Multisite
1 week 6 days ago #315390

Wauw that easy :-)
It is working!

Sorry that i did not find this solution myself :-D

Please Log in or Create an account to join the conversation.

Time to create page: 0.068 seconds
Powered by Kunena Forum