Joomla 4 indexer error

  • Posts: 463
  • Thank you received: 5
  • Hikashop Business
1 week 1 day ago #345030

-- HikaShop version -- : 4.6.1
-- Joomla version -- : 4.2.2
-- PHP version -- : 8
-- Browser(s) name and version -- : chrome

Hi, I cannot get 'search' to work in J4 and guessing its because J4 wont index products and stop at 63 every time?

I have followed a link to one that has indexed and the gives a 404 error?

See attached

please

Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 76573
  • Thank you received: 12023
  • MODERATOR
1 week 1 day ago #345033

Hi,

I have around 150 products on my Joomla 4.2.2 test website with HikaShop 4.6.2 and the indexing works fine.
Regarding the error during the indexing, could you try again with the "debug" setting activated ?
It should hopefully give an error message with more information on where the issue is.

Please Log in or Create an account to join the conversation.

  • Posts: 463
  • Thank you received: 5
  • Hikashop Business
1 week 1 day ago #345052

Hi, It does not give any error message? with the setting switched to max it does not even show the count although its run and appears to have stopped in the same place.

You can see I have arroung 17,000 products an dvarients.

Rgds

Please Log in or Create an account to join the conversation.

  • Posts: 463
  • Thank you received: 5
  • Hikashop Business
1 week 1 day ago #345058

only error I can find in error log is this:
[Sat Sep 24 09:16:19.994398 2022] [proxy_fcgi:error] [pid 30356:tid 140613773080320] [client 86.6.230.28:55174] AH01071: Got error 'PHP message: PHP Warning: Attempt to read property "id" on null in /var/www/vhosts/mohxxxxxxx/public_html/libraries/src/Updater/Adapter/ExtensionAdapter.php on line 303PHP message: PHP Warning: Attempt to read property "id" on null in /var/www/vhosts/mohxxxxxx/public_html/libraries/src/Updater/Adapter/ExtensionAdapter.php on line 303', referer:

Rgds

Please Log in or Create an account to join the conversation.

  • Posts: 76573
  • Thank you received: 12023
  • MODERATOR
1 week 20 hours ago #345061

Hi,

I'm not following you. You're saying it doesn't display any error message.
But on your previous screenshots, I see the "Undefined Attempt to assign property "images" to null". That's an error message. Do you mean that you don't see that message anymore ?
Normally, with the debug activated, that message should display more information like the file path where the error is happening.
And that "Attempt to assign property "images" to null" should be logged in your PHP error log.

Please Log in or Create an account to join the conversation.

  • Posts: 463
  • Thank you received: 5
  • Hikashop Business
1 week 20 hours ago #345069

Hi, No that message is still there, that is the only one shown on screen even with the setting at max. The next message I sent is what looks like information refering to this in the error in logs/error_log

Last edit: 1 week 20 hours ago by mohairbears.

Please Log in or Create an account to join the conversation.

  • Posts: 76573
  • Thank you received: 12023
  • MODERATOR
6 days 2 hours ago #345098

Hi,

Then we'll need a backend and a FTP accesses to be able to look into it as we're not able to reproduce the problem on our end.
Please provide this via our contact form with a link to this thread for reference:
www.hikashop.com/support/contact-us.html

Please Log in or Create an account to join the conversation.

  • Posts: 463
  • Thank you received: 5
  • Hikashop Business
6 days 1 hour ago #345101

messaged info

Rgds

Please Log in or Create an account to join the conversation.

  • Posts: 76573
  • Thank you received: 12023
  • MODERATOR
5 days 22 hours ago #345103

Hi,

We got the backend access but no FTP access. Can you either provide a FTP access, or install a file manager on the website (the version of ProFiles on your website is not compatible with Joomla 4) ?

Please Log in or Create an account to join the conversation.

  • Posts: 463
  • Thank you received: 5
  • Hikashop Business
5 days 22 hours ago #345106

Hi, File manager installed

Please Log in or Create an account to join the conversation.

  • Posts: 76573
  • Thank you received: 12023
  • MODERATOR
5 days 19 hours ago #345109

Hi,

I don't see any I can use. The ProFiles one is broken and the Quantum Manager is only for the Media files. I cannot edit the PHP files with it.

Please Log in or Create an account to join the conversation.

  • Posts: 463
  • Thank you received: 5
  • Hikashop Business
5 days 19 hours ago #345113

Do you have a suggetion as to what to add as I edit files through my ISP?

Please Log in or Create an account to join the conversation.

  • Posts: 463
  • Thank you received: 5
  • Hikashop Business
5 days 19 hours ago #345114

messaged with ftp info

Please Log in or Create an account to join the conversation.

  • Posts: 76573
  • Thank you received: 12023
  • MODERATOR
5 days 15 hours ago #345118

Hi,

Thank you for the access. I was able to do some debugging to understand the issue and made a patch.
The issue is that you have a variant pointing to a product which doesn't exist anymore in the database and the smart search tries to index it instead of ignoring it. This leads to a PHP error which would previously only generate a warning, but since you're on PHP8, it stops the process. So it's not really linked to Joomla 4, but to PHP8.

The patch fixes the issue on your website. We've included it on our end and it will be in the next version of HikaShop.

Please Log in or Create an account to join the conversation.

  • Posts: 463
  • Thank you received: 5
  • Hikashop Business
5 days 15 hours ago #345119

brilliant service above and beyond as usual.

thank you

Please Log in or Create an account to join the conversation.

Time to create page: 0.094 seconds
Powered by Kunena Forum