- Posts: 205
- Thank you received: 12
[SOLVED] Error 1054 Unknown column in mass action (user)
-- Joomla version -- : 3.9.18
-- PHP version -- : 7.2.30
While searching to find a way to solve the issue of HikaMarket vendor ACL not being updated when the joomla is updated, we run on to a new issue with the Mass Actions when setting filters.
Please check screenshot to see the problem
Please Log in or Create an account to join the conversation.
Could you do this modification so that you get the full MySQL query when you get that error ?
www.hikashop.com/support/forum/product-c...eld-list.html#304882
That would help us better understand why this is happening.
Please Log in or Create an account to join the conversation.
i CHANGED the database table prefix to " xxx "
An error has occurred.
1054 Unknown column 'hk_user.user_cms_id' in 'where clause' SELECT COUNT(DISTINCT hk_user.user_id) FROM xxx_hikashop_user as hk_user LEFT JOIN xxx_users as joomla_user ON joomla_user.id = hk_user.user_cms_id WHERE (`hk_user.user_cms_id` IS NOT NULL)
Please Log in or Create an account to join the conversation.
The query do not correspond to the previous screenshot of your mass-action configuration.
More than that, it is nearly impossible to not have the "user_cms_id" column in your database, otherwise your HikaShop store won't work at all (and the "left join" wouldn't work too).
I don't know what is your Mysql version but right now, the only potential issue I can see is the fact that the column in the "where" clause is quoted..
But we can't guarantee anything since we have a SQL query which is not related to a mass-action configuration and the issue is different than your first post.
So please provide a full and homogeneous example.
You can also copy your SQL query and process it in "phpmyadmin" ; but please be sure to right copy/paste it (there and here too).
Regards,
Jerome - Obsidev.com
HikaMarket & HikaSerial developer / HikaShop core dev team.
Also helping the HikaShop support team when having some time or couldn't sleep.
By the way, do not send me private message, use the "contact us" form instead.
Please Log in or Create an account to join the conversation.
This is possible because i am not able to save anything so maybe i i have chosen something else in my Mass action filter. But the error is there! Maybe another error, but this needs fixing too.The query do not correspond to the previous screenshot of your mass-action configuration.
"Nearly impossible" tells me nothing! I copied the error from my page and posted it here to get a solution. Not to be informed if it is possible or not.More than that, it is nearly impossible to not have the "user_cms_id" column in your database, otherwise your HikaShop store won't work at all (and the "left join" wouldn't work too).
Mysql version is 5.7.30. So now what? you see a potential issue and that's it? Am i expected to know if the "where" clause is quoted? I am not a programmer.I don't know what is your Mysql version but right now, the only potential issue I can see is the fact that the column in the "where" clause is quoted..
You have a SQL query taken from an error that shows when creating a mass action. I do not know if this is related to something. I am not the component developer.But we can't guarantee anything since we have a SQL query which is not related to a mass-action configuration and the issue is different than your first post.
Why not provide login credentials instead of providing info that you do not believe. Please tell me and i will send Admin login credentials to you so that you can check.So please provide a full and homogeneous example.
I can also provide cpanel credentials to check database too.You can also copy your SQL query and process it in "phpmyadmin" ; but please be sure to right copy/paste it (there and here too).
Please forgive me but i am not a programmer as i mentioned before. My knowledge is limited on setting up joomla and the required components like HikaShop and HikaMarket. I do not have the knowledge to fix issues on components.
Please tell me if i may send you admin credentials
Thank you in advance!
Please Log in or Create an account to join the conversation.
What Jerome means is that since it's a new error message it would be great that you tell us how do you get that error (on which page and by doing what ?) so that we can better understand the situation.
Also, this error you posted "Unknown column 'hk_user.user_cms_id'" means that the whole store should be broken. Is that the case ?
We sure can have a look on your website. We'll need you to provide:
- a link to the shop
- a backend access
- a phpmyadmin access
- precise steps to reproduce the error (and if you have several different errors on different pages, please tell us which one is where)
- a link to this thread for reference
You can send these via our contact form and we'll be able to check on the situation:
www.hikashop.com/support/contact-us.html
Please Log in or Create an account to join the conversation.
Thank you
Please Log in or Create an account to join the conversation.
Thank you for the access. I was able to reproduce the issue and found where the problem is coming from.
I've added a patch on our end to fix the problem. Download again the install package of the 4.3.0 on our website and install it on yours and it should work properly after that.
Please Log in or Create an account to join the conversation.
Thank you for your fast and professional support!
Issue resolved.
Please Log in or Create an account to join the conversation.