- Posts: 16
- Thank you received: 2
SQL error
-- Joomla version -- : 3.5.1
-- PHP version -- : 5.4.43
-- Browser(s) name and version -- : Firefox Developer Edition 48.0a2 (2016-05-31)
-- Error-message(debug-mod must be tuned on) -- : 1064 You have an error in your SQL syntax; check the manual that corresponds to your MariaDB server version for the right syntax to use near '' at line 1 SQL=SELECT * FROM #__hikashop_address WHERE address_id =
While trying to confirm an order of a client in the backend we get a SQL error:
Any idea what might trigger this?
Edit: found the reason... The user table was corrupt. All works as exprected now... Sorry for any inconvenience...
Please Log in or Create an account to join the conversation.
It seem that when I directly try to alter the order status in the list view from , the SQL error is presented (although the order status is altered!).
Opening the order via the order number and altering the status via the "Main information" section does not trigger the error.
I figure it has something to do with line 322 of the /administrator/components/com_hikashop/controllers/order.php file
Please Log in or Create an account to join the conversation.
- Posts: 12953
- Thank you received: 1778
Can you click on the "Check database" button via "Hikashop->System->Configuration" and test it again after the check is complete ?
Thank you.
Please Log in or Create an account to join the conversation.
Please Log in or Create an account to join the conversation.
The error doesn't come from
It's another MySQL query.$db->setQuery('SELECT address_id FROM '.hikashop_table('address').' WHERE address_user_id = '. (int)$user_id . ' AND address_published = 1 ORDER BY address_default DESC, address_id ASC LIMIT 1');
Please try again after activating the "debug mode" and "error reporting" settings of the Joomla configuration.
It will provide more precise information on what's going on, which will help us tell you what to do.
Please Log in or Create an account to join the conversation.
Please use our contact form and provide a link to this thread in your message:
www.hikashop.com/support/contact-us.html
Please Log in or Create an account to join the conversation.
- Posts: 502
- Thank you received: 12
i have the same problem !!! Exactly !
Can you give me a solution ???
Thank you !!!
Please Log in or Create an account to join the conversation.
Meanwhile, it might interest you that you can still confirm an order (or alter the status of the order) by clicking on the order number to view the details of the order.
Change the details and save your new status like that. I didn't get any error working like this.
If needed you see this in more detail (with images, although in dutch) over here: vaconi.com/klanten/ondersteuning/ticket/...bevestigen-lukt-niet
Please Log in or Create an account to join the conversation.
- Posts: 502
- Thank you received: 12
I can still confirm an order (or alter the status of the order) by clicking on the order number to view the details of the order.
It's ok for me
Thank you !
Please Log in or Create an account to join the conversation.
Thank you for the access, I was able to see the debug data:
As you can see, the problem is with a MySQL query in the invoicemanager plugin. That's not a plugin from HikaShop. So you need to contact the developer of that plugin so tha they can tell you what to change in order to avoid the problem.
It should be an easy modification to do near the line 78 of the file plugins/hikashop/invoicemanager/invoicemanager.php
If you provide the debug data above to the developer, he will be able to tell you what to do.
Please Log in or Create an account to join the conversation.
I posted a (positive) review in the Joomla Extension Directory for Hikashop.
@fafamaster: I'll keep you posted on the Invoice manager issue if I get to know exactly what triggers the error.
Please Log in or Create an account to join the conversation.
- Posts: 502
- Thank you received: 12
Nicolas thank you for your return ausi always effective, and thank you for vaconiit back!
Please Log in or Create an account to join the conversation.
It seemed there was a new version of the plugin available that solved the issue, but it was not published in the Invoice Manager downloads section.
Installing this new version of the plugin did resolve the issue.
More info can be found in the the Joomlathat! Forum
Please Log in or Create an account to join the conversation.
- Posts: 502
- Thank you received: 12
But where is the version 2.0.2 of plugin joomlathat
?
Please Log in or Create an account to join the conversation.