Pas d'envoi d'email après statut confirmé

  • Posts: 177
  • Thank you received: 11
  • Hikashop Business
1 month 4 weeks ago #360453

-- url of the page with the problem -- : www.rko.fr/
-- HikaShop version -- : 5.0.4
-- Joomla version -- : 4.4.4
-- PHP version -- : 8.1.18

Bonjour,
Après le passage d'une commande payée et validée par la banque le statut de la commande est passé à "Confirmé" mais dans le journal des emails on ne voit pas l'envoi de l'email de commande confirmée et il n'a pas été reçu par le client.
Aucune modification n'a été faite dans la méthode de paiement
Pour info nous avons changé d'hébergeur hier vendredi matin, donc changer les DNS, il y a peut-être un rapport ?

Autre problème : lorsque je veux modifier les emails dans Système/Emails/Notification de commande à l'administrateur par exemple, je ne peux pas sauvegarder car j'ai une erreur 403. En avez-vous l'explication ?

Merci pour votre aide

Last edit: 1 month 4 weeks ago by chlyroju.

Please Log in or Create an account to join the conversation.

  • Posts: 81852
  • Thank you received: 13140
  • MODERATOR
1 month 4 weeks ago #360459

Bonjour,

Si la commande passe en confirmé mais que l'email n'apparaît pas dans le journal des emails envoyés, c'est normalement que l'email a été dépublié dans le menu Système>Emails.
Vu que cela fonctionnait avant la migration de serveur, je doute que cela vienne de là.
Une autre possibilité est qu'il y a une erreur PHP entre la sauvegarde du nouveau statut de la commande et l'envoi de l'email.
Peut être que la version PHP a évoluée avec la migration, et que vous avez quelque part du vieux code qui n'est pas compatible avec votre nouvelle version de PHP.
En supposant que c'est quelque chose comme cela, cela pourrait venir de la personnalisation de l'email, ou d'un plugin non inclut dans HikaShop.
Essayez de changer le statut de commande manuellement de créer à confirmer via le dropdown du listing des commandes et activez la notification à l'utilisateur.
Il est fort possible que vous ayez un message d'erreur qui permettra de comprendre quel est le problème.

Concernant l'erreur 403 à la sauvegarde des emails, c'est surement un système de sécurité sur le serveur qui fait cela. il voit le code PHP du "preload" de l'email et refuse préemptivement de traiter la requête HTTP pour éviter tout problème potentiel.

Please Log in or Create an account to join the conversation.

  • Posts: 177
  • Thank you received: 11
  • Hikashop Business
1 month 4 weeks ago #360461

L'email est publié dans le menu Système>Emails.
Version de php précédente 8.2, version actuelle 8.1.18
J'ai créé une commande que j'ai passé manuellement à Confirmé et l'email de commande a été envoyé et réceptionné par le client. Pas de message d'erreur

Pour l'erreur 403, c'est le pare feu applicatif web qui créé l'erreur. Plus de 403 quand je le désactive. Une règle doit poser problème. Je suis en train de voir avec l'hébergeur

Please Log in or Create an account to join the conversation.

  • Posts: 177
  • Thank you received: 11
  • Hikashop Business
1 month 4 weeks ago #360463

C'est le pare feu qui pose aussi problème pour l'envoi des emails
Pare feu désactivé, plus de problème !

Please Log in or Create an account to join the conversation.

  • Posts: 177
  • Thank you received: 11
  • Hikashop Business
1 month 4 weeks ago #360464

Problèmes réglés après la désactivation de certaines règles du pare feu
Chez Planethoster, on peut désactiver les règles du pare feu qui posent problème et le support est très efficace
Merci pour votre aide

Last edit: 1 month 4 weeks ago by chlyroju.
The following user(s) said Thank You: nicolas

Please Log in or Create an account to join the conversation.

Time to create page: 0.059 seconds
Powered by Kunena Forum