Not showing Brands

  • Posts: 99
  • Thank you received: 5
  • Hikashop Business
1 month 2 weeks ago #309318

-- url of the page with the problem -- : www.luxminime.com/index.php/en/girls
-- HikaShop version -- : 4.2.1
-- Joomla version -- : 3.9.10
-- PHP version -- : 7.2.19

Hi,

I have configured Hikashop to display the brand, but it is not showing. 'Display the btrand' is set to 'Yes' and the menu setting is 'Inherit'.

Regards,
Colin.

Please Log in or Create an account to join the conversation.

  • Posts: 66849
  • Thank you received: 9881
  • MODERATOR
1 month 2 weeks ago #309321

Hi,

It seems that your product details page layout is customized.
So I suspect that the customization doesn't display the brand area.
Check the folder templates/YOUR_TEMPLATE/html/com_hikashop/product/ via FTP.
There, you'll find several view file overrides. Try renaming them one by one to deactivate them and see if it helps until you find the file which customize that part and prevent the brand from being displayed.
Then, you can contact either your template provider or the person who customized the layout for you to ask them to look into it.

Please Log in or Create an account to join the conversation.

  • Posts: 99
  • Thank you received: 5
  • Hikashop Business
1 month 2 weeks ago #309419

Hi Nicolas,

I renamed each of the 6 files and it made no difference.
I contacted the template provider and they say it must be somehow disabled.
My Hikkashop configuration is: Display/Product Options/Display the brand = Yes
Hope you can help.

Regards,
Colin

Please Log in or Create an account to join the conversation.

  • Posts: 99
  • Thank you received: 5
  • Hikashop Business
1 month 2 weeks ago #309420

Here is the image they sent me.

Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 66849
  • Thank you received: 9881
  • MODERATOR
1 month 2 weeks ago #309428

Hi,

Well, from what I can understand it should come from the file templates/YOUR_TEMPLATE/html/com_hikashop/product/show_tabular.php which modifies the tabs system incorrectly.
What you can do is to add such CSS on your website to prevent that:
#hikashop_show_tabular_specification{ display:block !important; }

Please Log in or Create an account to join the conversation.

  • Posts: 99
  • Thank you received: 5
  • Hikashop Business
1 month 2 weeks ago #309435

Thanks Nicolas, the css worked.
It displays the brand near the bottom of the page. Could you let me know how to display near the top, just above the SKU?

Thanks again,
Colin.

Please Log in or Create an account to join the conversation.

  • Posts: 12131
  • Thank you received: 1673
  • MODERATOR
1 month 2 weeks ago #309462

Hello Colin,

Can you show us more screenshots of what you have and of how you want it to be displayed ? Thank you.

You'll probably have to directly edit the code of the "show_default" file via "Hikashop->Display->Views".

Kind regards,
Mohamed Thelji.

Please Log in or Create an account to join the conversation.

  • Posts: 99
  • Thank you received: 5
  • Hikashop Business
1 month 2 weeks ago #309472

Hi,

For info an example is HERE

I have attached a screenshot.
'A' is the current view with the Brand at the bottom of the page.
'B' is how I would like it to look with the brand just above the SKU.
Thanks.

Regards,
Colin.

Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 12131
  • Thank you received: 1673
  • MODERATOR
1 month 2 weeks ago #309476

Hello,

In that case the solution will be to directly edit the "show_default" file of the "product" view of your front-end template via "Hikashop->Display->Views", and move that code where you want it to be displayed :

<span id="hikashop_product_url_main" class="hikashop_product_url_main"><?php
	if(!empty($this->element->product_url)) {
		// DISPLAY the manufacturer
		echo JText::sprintf('MANUFACTURER_URL', '<a href="' . $this->element->product_url . '" target="_blank">' . $this->element->product_url . '</a>');
	}
?>
</span>

Please Log in or Create an account to join the conversation.

  • Posts: 99
  • Thank you received: 5
  • Hikashop Business
1 month 2 weeks ago #309497

Hi,

I found similar code and moved it, but it made no difference?
Here is my code:
<span id="hikashop_product_url_main" class="hikashop_product_url_main"><?php
if(!empty($this->element->product_url)) {
echo JText::sprintf('MANUFACTURER_URL', '<a href="' . $this->element->product_url . '" target="_blank">' . $this->element->product_url . '</a>');
}
?></span>

Regards,
Colin.

Please Log in or Create an account to join the conversation.

  • Posts: 12131
  • Thank you received: 1673
  • MODERATOR
1 month 1 week ago #309499

Hello Colin,

In that case you're probably editing the file of the wrong front-end template via "Hikashop->Display->Views".

Kind regards,
Mohamed Thelji.

Please Log in or Create an account to join the conversation.

  • Posts: 99
  • Thank you received: 5
  • Hikashop Business
1 month 1 week ago #309538

Hi,

This is the file I am editing:



Regards,
Colin.

Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 12131
  • Thank you received: 1673
  • MODERATOR
1 month 1 week ago #309545

Hello Colin,

You can eventually send us a temporary back-end access through our contact form so that we can directly check why you can't apply your modification (please don't forget to add a link to that thread in your message) :
www.hikashop.com/support/contact-us.html

Kind regards,
Mohamed Thelji

Please Log in or Create an account to join the conversation.

  • Posts: 99
  • Thank you received: 5
  • Hikashop Business
1 month 1 week ago #309581

Thanks.
I have sent the info.

Regards,
Colin.

Please Log in or Create an account to join the conversation.

  • Posts: 12131
  • Thank you received: 1673
  • MODERATOR
1 month 1 week ago #309585

Hello,

My bad I mistook the brand url and the manufacturer url.
The modification was added through the "Show_tabular" file of the "Product" view of our front-end template.

Kind regards,
Mohamed Thelji.

Please Log in or Create an account to join the conversation.

  • Posts: 99
  • Thank you received: 5
  • Hikashop Business
1 month 1 week ago #309607

That's great.

Thank you for your help with this.
I can't see the code in the JD Shop template. Am I looking at the right file?
Also, I have removed the word 'Brand' via Joomla Language Overrides, but I can't remove the colon ':'?

Regards,
Colin.

Last edit: 1 month 1 week ago by Crashbandi.

Please Log in or Create an account to join the conversation.

  • Posts: 12131
  • Thank you received: 1673
  • MODERATOR
1 month 1 week ago #309627

Hello Colin,

I can't see the code in the JD Shop template. Am I looking at the right file?


We had to edit the "Show_tabular" file of the "product" view of your front-end template via "Hikashop->Display->Views" and move that code :
if(isset($specif_tab_content))
	echo $specif_tab_content.'</br>';

So you'll have to edit the $specif_tab_content variable.


We wish you a nice day,
Kind regards,
Mohamed Thelji.

Please Log in or Create an account to join the conversation.

  • Posts: 99
  • Thank you received: 5
  • Hikashop Business
1 month 1 week ago #309640

OK, thanks.

Regards,
Colin.

Please Log in or Create an account to join the conversation.

  • Posts: 99
  • Thank you received: 5
  • Hikashop Business
1 month 1 day ago #310011

Hi,

Just a quick one. Where can I delete the colon just before the brand name. As shown in the attachment.

Regards,
Colin.

Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 66849
  • Thank you received: 9881
  • MODERATOR
1 month 16 hours ago #310014

Hi,

Normally, it's from the line:

echo JText::_('MANUFACTURER').': '.'<a href="'.hikashop_contentLink('category&task=listing&cid='.$manufacturer->category_id.'&name='.$manufacturer->alias.'&Itemid='.$Itemid,$manufacturer).'">'.$manufacturer->category_name.'</a>';
in show_block_dimensions.php
However, as your product page layout is customized, it might be in another file of the product view.

Please Log in or Create an account to join the conversation.

Time to create page: 0.098 seconds
Powered by Kunena Forum