A product with options with a product with a choice of characteristics

  • Posts: 188
  • Thank you received: 15
  • Hikashop Business
1 year 4 months ago #349042

-- HikaShop version -- : 4.7.1
-- Joomla version -- : 4.2.6
-- PHP version -- : 7.4

Hello,
I have a product that has a different product option, but this product has different sizes.
I have the option to choose an optional product, but there is no option to opt out. There is no position no.
How to configure it so that it is possible to buy only the main product without options.

Tomek

Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 4585
  • Thank you received: 616
  • MODERATOR
1 year 4 months ago #349047

Hello,

You have a solution in order to add an "no" you can have a look in this forum subject .
Hope this will fit your needs.

Regards

Last edit: 1 year 4 months ago by Philip.

Please Log in or Create an account to join the conversation.

  • Posts: 188
  • Thank you received: 15
  • Hikashop Business
1 year 4 months ago #349057

I just have to add this:
"If you want the system to automatically add a "No" choice for all the options with variants, you can go in your PHPMyAdmin and open the hikashop_config table. There, add an entry with the namekey add_no_to_options and the value 1
And if you want the "No" to be selected instead of the default variant, you can add an entry with the namekey select_option_default_value and the value 0 at the same place."

???

Adding only what you write about - does not solve the problem.

Please Log in or Create an account to join the conversation.

  • Posts: 81875
  • Thank you received: 13145
  • MODERATOR
1 year 4 months ago #349058

Hi,

What I wrote in the other thread Philippe linked to will allow you to add a "no" choice to the options.
If you don't see the "no" choice after following the instructions, it means you made a mistake when trying to follow them.
Please do some screenshots of what you did in your PHPMyAdmin and make sure you don't have space(s) at the end of the namekey / value or it won't work properly.

Please Log in or Create an account to join the conversation.

  • Posts: 188
  • Thank you received: 15
  • Hikashop Business
1 year 4 months ago #349069

Nicolas,
thanks for the tips.
The key word is: "check carefully" :)
It turned out that I had two table prefixes in one database. I entered new records into the wrong table.

Thank you very much for your support.
Tomek

The following user(s) said Thank You: nicolas

Please Log in or Create an account to join the conversation.

Time to create page: 0.064 seconds
Powered by Kunena Forum