shipstation plugin causes order details page to go blank

  • Posts: 5
  • Thank you received: 2
2 months 2 weeks ago #309287

-- HikaShop version -- : 3.1.1
-- Joomla version -- : 2.5.28
-- PHP version -- : 5.6
-- Browser(s) name and version -- : firefox
-- Error-message(debug-mod must be tuned on) -- : white screen

customer installed shipstation integration plugin on test site on subfoler off root. /test18

plugin worked great.

installed plugin on live site on root.

plugin installed fine but when go to check an order detail page, the screen goes white?

Please Log in or Create an account to join the conversation.

  • Posts: 67110
  • Thank you received: 9946
  • MODERATOR
2 months 2 weeks ago #309298

Hi,

Please turn on the "error reporting" and "debug mode" settings of the Joomla configuration and try again. You should get some error message on that blank page which will help us understand what's going on.

Please Log in or Create an account to join the conversation.

  • Posts: 5
  • Thank you received: 2
2 months 2 weeks ago #309304

this is the error message when accessing an order details page:

Fatal error: Class 'hikaInput' not found in /home/hy0mbt0wogpa/public_html/e-force.com/test18/plugins/system/shipstation/shipstation.php on line 639

this is on the test folder /test18 live site does the same white page

The shipstation plugin successfully sends orders from Hikashop into the Shipstation platform. the issue is the white blank page when accessing a single order detail when the plugin is enabled. Access to individual orders works fine if the plugin is turned off.

Any help you can provide would be greatly appreciated.

This is a client I had a couple years back and we purchased your Hikashop Business, they asked for a lot of crazy variations, modifications and your system always came through, thanks!

**FYI** They do not want to upgrade anything, so any help along the lines of not upgrading their php level or joomla level, etc would be greatly appreciated. I am doing these guys a favor by contacting you since i dont work for them, so any help to resolve this issue would be apprecitated. I am NOT a programmer, I am a designer with a decent knowledge of Joomla and your Hikashop but altering php files is something I am not comfortable with at almost any level.

I look forward to any help you can provide.

Please Log in or Create an account to join the conversation.

  • Posts: 67110
  • Thank you received: 9946
  • MODERATOR
2 months 2 weeks ago #309306

Hi,

Well, the issue is precisely that you're using an old version of HikaShop for which the plugin isn't supposed to work. Updating HikaShop would be the solution here.
I'm doing these guys a favor too by modifying the plugin to avoid that error, but you might get other surprises using it with old versions of HikaShop.
Here is attached a modified version of the plugin you can install on top of the other one to fix that error.

File Attachment:

File Name: shipstation.zip
File Size:8 KB

Attachments:
Last edit: 2 months 2 weeks ago by nicolas.
The following user(s) said Thank You: andrewHS

Please Log in or Create an account to join the conversation.

  • Posts: 5
  • Thank you received: 2
2 months 1 week ago #309424

Plugin installation successful. Once again, thank you for your help and wonderful component. I have been asked to look into other ecommerce sites such as shopify, prestashop and woocommerce and they all were lacking in comparison to what your platform offers and in levels of functionality. Great work.

The following user(s) said Thank You: nicolas

Please Log in or Create an account to join the conversation.

  • Posts: 67110
  • Thank you received: 9946
  • MODERATOR
2 months 1 week ago #309430

Hi,

Thank you ! Don't hesitate to leave a comment on extensions.joomla.org/extensions/extensi...pping-cart/hikashop/
It helps us a lot !

Please Log in or Create an account to join the conversation.

  • Posts: 5
  • Thank you received: 2
1 month 2 days ago #310828

Hi Nicholas,
I did leave a nice review for you.

This just came in so I'm not sure if its the pluging code or Shipstation themselves. Local state tax is used for products shipped in state.

It seems tax is being added to a product then exported to Shipstation as the product cost then tax is exported again in effect causing double taxation for each order. The attached Shipstation page was for an order that was $74.50 and you can see how the price is exported as $79.90 and then tax is added again The other attachments are code grabs from the guys at Shipstation pointing out where they think the issue is.

Attachments:
Last edit: 1 month 2 days ago by andrewHS. Reason: added extra code snippets
The following user(s) said Thank You: nicolas

Please Log in or Create an account to join the conversation.

  • Posts: 67110
  • Thank you received: 9946
  • MODERATOR
1 month 2 days ago #310841

Hi,

Well, the documentation on their end doesn't specify if the price sent should be taxed or not:
shipstation.docs.apiary.io/#reference/model-order
Now, if you want to change that, change the line:
<UnitPrice>' .((float) $product_price + (float)$product_tax) . '</UnitPrice>
to:
<UnitPrice>' .((float) $product_price) . '</UnitPrice>
and the line:
<OrderTotal>' . round($order->order_full_price, 2) . '</OrderTotal>'.
to:

<OrderTotal>' . round($order->order_full_price-$taxes_calculation, 2) . '</OrderTotal>'.
in the file plugins/system/shipstation/shipstation.php
Let us know how it goes so that we can add these changes for future versions of the plugin.

Please Log in or Create an account to join the conversation.

Time to create page: 0.067 seconds
Powered by Kunena Forum