VAT not charged on EU order

  • Posts: 429
  • Thank you received: 3
  • Hikashop Business
7 months 5 days ago #324462

-- HikaShop version -- : 4.3.0
-- Joomla version -- : 3.9.21
-- PHP version -- : 7.3.22
-- Browser(s) name and version -- : Google Chrome

Hi, I have a case of a order NOT charging VAT on the order. The user has entered a UK billing address with a VAT number BUT our system is set to 'Shipping Address' for Tax purposes.

This should not have been allowed to happened with the configuration settings?


Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 72763
  • Thank you received: 11096
  • MODERATOR
7 months 5 days ago #324473

Hi,

Since the option "Type of address used for tax" is set to "shipping" the billing address is ignored and the tax system bases itself on the shipping address.
If the order was not charged taxes, it means that there is no tax rule configured for the tax category of that product and the country / state selected in the shipping address for the customer type "individual" (as there is no VAT number and no company name in the shipping address)

Please Log in or Create an account to join the conversation.

  • Posts: 429
  • Thank you received: 3
  • Hikashop Business
7 months 4 days ago #324511

Hi, That's not correct.

I have been using your cart for 10 years now and not had this issue before? France is in the EU and therefore pays VAT unless they are registered in France for VAT and they enter a French valid VAT code.

The main tax zone (Europe) is ALL EU countries that will not pay tax if a valid code is provided. The UK is in there and of course they do pay VAT on everything. I ship lots to the EU and some with UK billing addresses and EU shipping addresses and its always charged the VAT, the only difference with this order is a UK VAT code has been entered in the billing address.

It appears the issue is because they have entered a VAT code from the UK (billing address) and that should not have removed the VAT as you can see VAT is set to the shipping address?

Rgds

Last edit: 7 months 4 days ago by mohairbears.

Please Log in or Create an account to join the conversation.

  • Posts: 72763
  • Thank you received: 11096
  • MODERATOR
7 months 4 days ago #324515

Hi,

I'm happy to have a look at the situation if you believe there is a bug. But I doubt that's the case. I'm thinking it's a issue with some setting.
Please provide a link to the shop with precise instructions to reproduce the issue and a backend access so that we can check on your settings.
You can do so privately via our contact form:
www.hikashop.com/support/contact-us.html
Make sure you provide a link to this thread for reference.

Please Log in or Create an account to join the conversation.

Time to create page: 0.077 seconds
Powered by Kunena Forum