Moving items from Wishlist to Cart products SQL error

  • Posts: 158
  • Thank you received: 6
3 years 8 months ago #254460

-- url of the page with the problem -- : www.tashatudorandfamily.com/my-account/cart/showcart
-- HikaShop version -- : 3.6.4
-- Joomla version -- : 3.6.4
-- PHP version -- : 5.6
-- Browser(s) name and version -- : all
-- Error-message(debug-mod must be tuned on) -- : 1054 Unknown column '2814' in 'field list' SQL=INSERT INTO #__hikashop_cart_product (cart_id,cart_product_modified,product_id,cart_product_parent_id,cart_product_quantity,cart_product_option_parent_id,cart_product_wishlist_id,`2814`,`2816`,`2817`,`2917`,`2918`) VALUES (1721,1478274695,473,3061,5,0,1582,'5,1','1,1','3,1','2,1','1,1')

Hello,

I have a wishlist setup for a customer and I checked each item I wanted to move to the cart. When I clicked the button to move them I got this message:
1054 Unknown column '2814' in 'field list' SQL=INSERT INTO #__hikashop_cart_product (cart_id,cart_product_modified,product_id,cart_product_parent_id,cart_product_quantity,cart_product_option_parent_id,cart_product_wishlist_id,`2814`,`2816`,`2817`,`2917`,`2918`) VALUES (1721,1478274695,473,3061,5,0,1582,'5,1','1,1','3,1','2,1','1,1')

Please advise.

Thanks,

Dawn

Please Log in or Create an account to join the conversation.

  • Posts: 69999
  • Thank you received: 10483
  • MODERATOR
3 years 8 months ago #254497

Hi,

Download the install package on our website and install it on yours. It should add a patch to avoid that.

Please Log in or Create an account to join the conversation.

  • Posts: 158
  • Thank you received: 6
3 years 8 months ago #254670

Hello,

I updated the package as you recommended and tried to move everything in the wishlist to the basket. I click the Add to for each product, then click Add to Basket at the bottom of the wishlist. The page refreshes, but nothing is added to the cart. The wishlist is still intact. There is no error message.

Thanks,

Dawn

Please Log in or Create an account to join the conversation.

  • Posts: 69999
  • Thank you received: 10483
  • MODERATOR
3 years 8 months ago #254693

Hi,

Then could you provide a test user account and the steps to reproduce the problem so that we can analyze the situation ?

Please Log in or Create an account to join the conversation.

  • Posts: 158
  • Thank you received: 6
3 years 7 months ago #255531

Hello,

I have given you super admin login via private message.

Go to users and click to Login as Suzanne Raab. Go to her wishlist and try to move it to the cart.

Please let me know how it goes.

Thanks,

Dawn

Please Log in or Create an account to join the conversation.

  • Posts: 24228
  • Thank you received: 3743
  • MODERATOR
3 years 7 months ago #255533

Hi,

Please, never use private message to contact the support team.
You can use the "contact us" form but private message are not useful at all ; that's mostly why we do not receive any email notification for private message and why we have inbox with hundreds of unread messages.

Thank you for your understanding.


Jerome - Obsidev.com
HikaMarket & HikaSerial developer / HikaShop core dev team.

Also helping the HikaShop support team when having some time or couldn't sleep.
By the way, do not send me private message, use the "contact us" form instead.

Please Log in or Create an account to join the conversation.

  • Posts: 158
  • Thank you received: 6
3 years 7 months ago #255617

Dear Jerome,

Thank you for letting me know. Just to confirm, you have a secure contact form that is only reviewed by trusted employees? I was sending super administrator login for an international ecommerce site, so security is a big concern for me.

Thanks,

Dawn

Please Log in or Create an account to join the conversation.

  • Posts: 158
  • Thank you received: 6
3 years 7 months ago #255619

Hello,

The problem is now solved with moving the items from the Wishlist to the Cart and back again. I'm guessing the patch solved it as I cannot connect it to anything else. With the patch the "Status" returned again in the Wishlist only and CSS display:none breaks the table so I'll open a new ticket for that issue.

Warm Regards,

Dawn

Please Log in or Create an account to join the conversation.

Time to create page: 0.061 seconds
Powered by Kunena Forum