Bugs et Questions diverses

  • Posts: 130
  • Thank you received: 1
9 years 8 months ago #128

Salut Nicolas,

Bon j'ai bien avancé par rapport à l'apparition de mes articles une fois toutes mes sous-catégories défilées...(comme quoi en lisant le manuel :blush: ). Par contre, je coince encore sur deux trois truc :

Question numéro 1 :

Comment puis-je faire pour que mes produits n'apparaissent pas en même temps que mes sous-catégories ? Je m'explique par l'exemple :

Je gère des motos avec 2 Catégories : Enduro et Racing
Dans Enduro j'ai 2 marques : Yamaha et Suzuki
Dans Yamaha j'ai 3 produits : Cadre, Moteur et Frein.

J'ai créer mon Menu de catégorie Enduro et j'y est affecté mon module de produits Yamaha.

Ben quand je clique sur mon menu Enduro, il me propose Yamaha ou Suzuki PUIS, dessous, mes produits Cadre, moteur et Frein !! Mais moi je ne veut pas les voir ici.. !! :evil:
Je veux qu'ils apparaissent uniquement quand je clique sur Yamaha...

Heu... tu as bien compris ? :blink:

Bon voilà.. ça c'est mon premier souhait important pour la structure de mon site... et ce coup-ci je viens de relire toute la doc... ;)

Question numéro 2 :

Est il possible de virer les deux lignes Diplay# et result 1-5 of 5 car moche et pas trés pratique (enfin plutôt inutile...) pour les petites boutiques :ohmy:

Bug numéro 1 :

Quand je créé un menu à partir d'hikashop, que ce soit de produit ou de catégories et que je l'applique j'ai le message d'erreur suivant :

Fatal error: Call to undefined method: hikashopmenusclass->setquery() in /homepages/0/d343685902/htdocs/fsa/administrator/components/com_hikashop/classes/menus.php on line 90

C'est grave docteur ? :blink: (je m'en sors en passant d'abord par le main menu de Joomla...)

Bug numéro 2 :

Quand j'applique la création ou une modification d'un module de contenu... il me réinitialise l'affichage des paramètre... du coup si on fait pas attention et que l'on sort par sauver au lieu de annuler... on se retrouve avec les paramétrage initiaux...


Bon voila... c'est tout pour aujourd'hui... encore merci ! et longue vie à Hikashop... !!!


It's nice to be important... but more important to be nice !

Please Log in or Create an account to join the conversation.

  • Posts: 69940
  • Thank you received: 10476
  • MODERATOR
9 years 8 months ago #129

BOnsoir,

Merci pour le retour.

Q1: D'abord il faut que tes produits soient seulement liés aux sous catégories et pas aux catégories principales ( c'est à dire: tu mets juste Yamaha et pas Yamaha et Enduro). Ensuite, dans le module de produits, il y a une option pour afficher soit "Sous-éléments directs" soit "Tous les sous-éléments". En mettant la première option, tu auras ce que tu voudras car quand tant que tu n'afficheras pas Yamaha, les produits ne seront pas affichés. Avec l'autre option, les produits liés aux sous catégories de la catégorie courante seront aussi affichés.

Q2: L'affichage de la pagination peut être changé via un fichier de ton template joomla: docs.joomla.org/Understanding_Output_Ove...the_Pagination_Links
Sinon, en plus simple, nous avons rajouté des divs autour de la pagination avec les classes CSS hikashop_subcategories_pagination et hikashop_products_pagination, et donc, il est possible de les cacher avec une ligne de CSS dans le fichier CSS de ton template:

div.hikashop_products_pagination, div.hikashop_subcategories_pagination{ display: none; }

Bug 1 : Wow, effectivement. Petit oubli ^^; Ca sera corrigé demain avec la nouvelle version d'hikashop. Il suffit de changer cette ligne par
$this->database->setQuery($query);

Bug 2 : Je n'arrive pas à reproduire le problème sur nos sites de test :/ Peut être que j'ai mal compris ? Est ce que tu as le même problème si tu essaies cela sur le site de démo ?

Last edit: 9 years 8 months ago by nicolas. Reason: corrected CSS code

Please Log in or Create an account to join the conversation.

  • Posts: 69940
  • Thank you received: 10476
  • MODERATOR
9 years 8 months ago #134

Bonjour, une nouvelle version d'HikaShop est disponible en téléchargement avec le bug 1 corrigé, entre autre.

Please Log in or Create an account to join the conversation.

  • Posts: 130
  • Thank you received: 1
9 years 8 months ago #140

Bon, soit je suis maudit... soit moi y être pas très malin du tout.... ou les deux ! :S

Pour la Q1, j'ai bien fait ce que tu me dis... mais je n'y arrive toujours pas... c'est même pire que ça, je vais tenter de t'expliquer :

Si j'associe à mon menu ENDURO aucun module de produit = aucun produit ne s'affiche nul part !
Si j'associe à mon menu ENDURO mon module de produit SUZUKI = Quand je clique sur mon menu ENDURO, j'ai mes catégories YAMAHA et SUZUKI + Mes produits SUZUKI dessous et donc si je clique sur ma catégorie SUZUKI, j'ai bien mes produits... Mais ce qui est fort c'est que si je vais sur ma catégorie YAMAHA, J'ai mes produits YAMAHA !!!!! c'est à n'y rien comprendre... puisque mon module de produit Yamaha n'est associé à aucun menu ???? :S :blink: :dry:

EDIT :
Si j'associe en plus du module SUZUKI, le module YAMAHA au menu ENDURO = Quand je clique sur mon menu ENDURO, j'ai mes catégories YAMAHA et SUZUKI + Mes produits SUZUKI et YAMAHA dessous et si je clique sur Suzuki j'ai mes produits SUZUKI + YAMAHA !!!! et si je clique sur YAMAHA j'ai mes produits YAMAHA en double !!!!!!!!

Y a du gag là non ? :blink: j'en perds la tête ! :silly:

Sinon j'ai fait la mise à jour, mais le bug1 persiste... enfin non l'erreur n'est pas tout à fait la même :
Fatal error: Call to undefined method: hikashopmenusclass->loadresult() in /homepages/0/d343685902/htdocs/fsa/administrator/components/com_hikashop/classes/menus.php on line 91

Pour le bug 2, oui j'ai le même soucis sur le site de démo... mais pas pour les même variables... Attention cela ne se produit que lors de la création d'un module d'affichage, et lors du premier clic sur Appliquer...
Sur mon site je perds toutes mes varibales qui reviennent à l'origine, mais si j'annule et que je reviens, elles sont ok !
Sur le site de démo, j'ai eu ce gag surtout avec la variable de tri du prix... les autres aléatoirement...

Enfin pour la Q2 je nage ! dans mon Template j'ai un dossier Css... j'ai rajouter la ligne que tu m'as donné dans tous les fichiers avec l'extension CSS que j'ai trouvé dedans... mais rien y fait la pagination est toujours là... J'ai tenter d'aller sur le lien que tu m'as donné... j'ai bien trouver le fichier pagination.php mais la moitié est en note et j'avoue etre un veritable newbe en code... je sais c'est pas bien j'ai honte... mais c'est aussi la force de joomla... non ;)

Encore merci pour ton aide...

Avec le boulot que ça me prends ! j'te jure qu'il va se payer la version pro mon client !!! à coup de marteau s'il faut... mais il va le payer :laugh:


It's nice to be important... but more important to be nice !
Last edit: 9 years 8 months ago by Stephane. Reason: Mise à jour Test pour Q1

Please Log in or Create an account to join the conversation.

  • Posts: 130
  • Thank you received: 1
9 years 8 months ago #141

En fait je commence à cerner le soucis de la Q1...

Je viens de créer un niveau de plus... c'est à dire que avant mon niveau enduro j'ai créer un niveau MOTO

si j'affecte par exemple le module YAMAHA à MOTO, quand je clique sur MOTO, je vais avoir la catégorie ENDURO + les produits YAMAHA... mais quand je clique sur ENDURO, je vais avoir uniquement mes catégories YAMAHA et SUZUKI donc SANS mes produits YAMAHA qui eux s'afficheront nickel quand je cliquerais sur YAMAHA... idem pour SUZUKI d'ailleurs..

Donc en Français dans le texte, Quand j'affecte un module de produits à un menu... les produits s'affichent DANS ce menu en plus de la catégorie finale... mais pas dans les sou-catéogorie intermédiaires...

c'est que chez moi ? ou c'est chez des autres aussi... ?


It's nice to be important... but more important to be nice !

Please Log in or Create an account to join the conversation.

  • Posts: 69940
  • Thank you received: 10476
  • MODERATOR
9 years 8 months ago #142

Q1:
Si le module a l'option "synchronisation" à oui, il n'affichera que les produits de la catégorie sélectionnée (ou ses sous catégories si l'option Tous les sous-éléments est sélectionnée). Donc si tu as un menu de type "category listing layout" avec comme catégorie parente moto qui a comme sous catégories enduro et racing, et que ce menu a ton module de produits associé. Quand tu cliqueras sur le menu la catégorie sélectionnée sera moto. Donc si ton module de produits est synchro et qu'il a l'option "Sous-éléments directs", il n'affichera QUE les produits avec la catégorie MOTO dans leur liste de catégories. si tu cliques sur enduro, la catégorie sélectionnée sera donc enduro, et ce meme module de produits n'affichera QUE les produits avec la catégorie enduro dans leur liste de catégories, etc.

Bug1: oups encore :) J'aurais dû testé...la ligne d'après avait le même problème...J'ai refait un paquet... Si tu réinstalles le nouveau paquet disponible sur le site ca devrait être réglé.

Bug2: Ok je vais voir ca...

Q2: Il faut rafraichir le cache du browser après la modification sinon on ne voit pas la modif. sinon en rajoutant ce meme code à la fin du fichier CSS du hikashop (éditable dans la config de hikashop, dans l'onglet affichage), ca devrait le faire...

Please Log in or Create an account to join the conversation.

  • Posts: 69940
  • Thank you received: 10476
  • MODERATOR
9 years 8 months ago #143

Pour le bug 2, il y a effectivement un problème sur le tri du produit. Je l'ai corrigé. A part ça, je ne vois pas d'autre problème à première vue.

Please Log in or Create an account to join the conversation.

  • Posts: 130
  • Thank you received: 1
9 years 8 months ago #144

Bon alors... reprenons !

Bug 1 : Nickel :P ça marche !!!! (j'ai donc pas noté qu'une version sans test a été distribué... pas bien !)r

Bug 2 : Je travail sous Chrome 7... je ferais des test sous les autres OS...

Q2 : Rien a faire, vidage du cache... copie de la ligne sous le CSS de hikashop... j'ai toujours la pagination... eventuellement si j'abuserais je te demanderais le nom exact du fichier Css de hikashop... si tu peux faire un test et me dire ou tu as mis la ligne de commande...?

Q1 : ha... ma Q1 adorée... :laugh:

Bon alors je te joins mes paramétrages en une image pour que tu regardes ça...

[img size=(01-499)] www.ncreativ.fr/cheminement.jpg [/img]

ben je t'assure que mes produits 690 apparaissent en plus des catégories quand je cliques sur Enduro ... pas sur KTM... pourquoi ???? OUIN !!!!!!!!

Tiens tant que j'y suis, j'ai un Bug 3 (désolé) : La synchro du titre avec celui du module ne fonctionne pas... ou alors là aussi j'ai pas compris l'astuce...

Ha la la.. la nuit va être courte encore... :pinch:


It's nice to be important... but more important to be nice !

Please Log in or Create an account to join the conversation.

  • Posts: 69940
  • Thank you received: 10476
  • MODERATOR
9 years 8 months ago #145

Q1: ces parametres ont l'air corrects. Théoriquement, avec cette config, les 3 produits du screenshot ne devraient ni apparaitre sous enduro, ni sous KTM mais seulement sous 690. Et les produits sont bien affectés seulement à une seule catégorie ? Car la seule raison que je vois pour le résultat que tu me dis c'est que les produits ont la catégories enduro et la catégorie 690 affectées. Sinon, ca serait possible d'avoir accès au back end demain pour jeter un coup d'oeil et tester ça moi-même ?

Bug 2 : j'utilise chrome comme navigateur principal également, j'aurais dû avoir le même pb :/

Pour le CSS, avec l'accès au site je pourrais voir ca vite fait aussi.

Bug 3 : demain sera un nouveau jour :)

Sur ce, bonne nuit :p

Please Log in or Create an account to join the conversation.

  • Posts: 130
  • Thank you received: 1
9 years 8 months ago #146

Pas de soucis pour le back end demain ... bien au contraire !!!! :laugh:

Tu me diras comment te fournir les accès... j'ai pas trouvé de MP sur le forum...

Encore merci et zou !!! au dodo !!!


It's nice to be important... but more important to be nice !

Please Log in or Create an account to join the conversation.

  • Posts: 69940
  • Thank you received: 10476
  • MODERATOR
9 years 8 months ago #147

Bonjour,

Tu peux m'envoyer ca à This email address is being protected from spambots. You need JavaScript enabled to view it.

Please Log in or Create an account to join the conversation.

  • Posts: 130
  • Thank you received: 1
9 years 8 months ago #148

c'est fait...

Bon courage ;)


It's nice to be important... but more important to be nice !

Please Log in or Create an account to join the conversation.

  • Posts: 69940
  • Thank you received: 10476
  • MODERATOR
9 years 8 months ago #150

Bon et bien cela a été très utile ! :)

Q1: C'était effectivement un bug: En fait, dans la version actuelle, il ne faut pas changer la catégorie parente du module d'affichage des produits pour un menu de listing des catégories car sinon la synchro avec la catégorie courante ne fonctionne pas.

Q2: Le CSS posté précédemment ne modifiait que le listing des catégories, je l'ai mis à jour pour changer aussi le listing des catégories.

Bug 2 : En fait, le problème le problème survient seulement sous PHP4 alors que la majorité des sites utilisent PHP5 actuellement. D'où le fait que personne d'autre n'avait eu le problème. C'est corrigé en tout cas.

Bug 3 : petit bug aussi. C'est corrigé.

Please Log in or Create an account to join the conversation.

  • Posts: 130
  • Thank you received: 1
9 years 8 months ago #151

Excellentissimobravo ! :P :P :P :P

Ben c'est super tout ça.... c'est ce qu'on appelle avancer positivement dans les deux sens (le tien et le mien)...

Bon aller on continu...

Encore merci !

A la prochaine ! ;)


It's nice to be important... but more important to be nice !

Please Log in or Create an account to join the conversation.

  • Posts: 48
  • Thank you received: 0
9 years 8 months ago #452

Bonjour !

Je réactive ce sujet pour éviter d'encombrer la liste...

J'ai un soucis avec la pagination. J'ai des photos sur plusieurs pages d'une catégorie. Pas de problème pour afficher la première page et les mentions de pagination me montrent qu'il y a 2 pages. Lorsqu'on clique sur suivant ou fin, on se retrouve irrémédiablement sur la catégorie la plus haute dans la hiérarchie :blink: .
Suivre sur le site le menu "Les photos", puis "Paysages", puis "Plateau de Sault" ou "Campagne du Vaucluse". Ces 2 catégories ont plus d'une page.

Autre souci : j'ai mis un module en bas de la page d'accueil qui affiche des photos au hasard piochée dans une galerie indépendante appelée "en vedette". Les images que je veux y voir figurer appartiennent à 2 galeries : la galerie "normale" et la galerie "en vedette". Lorsqu'on clique sur une des images, on va bien sur le détail de l'image en question mais les modules qui apparaissent normalement en bas de page n'y sont plus. On peut comparer les 2 URL :
- par les liens à partir de la catégorie parente : racine_du_site/les-photos/product/show/cid-66/name-11-0012/category_pathway-16
- par l'accès direct à partir de l'accueil : racine_du_site/component/hikashop/product/show/cid-66/name-11-0012/category_pathway-0

Et pour finir, j'ai une suggestion à proposer : pourrait-on avoir sur la page de détail d'un produit, un lien vers la catégorie et sur la page à laquelle il appartient (mais que faire si il appartient à plusieurs catégories ???) et un lien sur le produit suivant, un autre sur le produit précédent, pour ne pas quitter la vue détail ?

Ah, que ces clients sont em...!


Plus un objet tombe moins vite, moins sa vitesse est plus grande.

Please Log in or Create an account to join the conversation.

  • Posts: 69940
  • Thank you received: 10476
  • MODERATOR
9 years 8 months ago #453

Nous avons mis en ligne une nouvelle version début de semaine qui corrige les problèmes de pagination que vous avez sur votre version. Je vous invite donc à télécharger la dernière version et de mettre à jour. Ensuite, dites mois si vous avez toujours le problème.

Dans cette version du début de semaine, nous avons ajouté la possibilité de lier un module à un menu. Quand vous irez dans les options HikaShop du module, vous aurez la possibilité de lié le module à un menu (itemid). De ce fait les liens du module seront modifiés pour afficher le produit/la catégorie avec les même options qu'avec le menu et donc vous devrez retrouver les modules qui apparaissent normalement.

Pour votre dernier point: C'est le but du breadcrumb que d'afficher le lien vers la catégorie parente et les catégories au dessus en fonction de la catégorie principale du menu. Pour choisir la catégorie adéquate, le système utilise la première catégorie ajoutée au produit. Pour un lien sur le produit précédent et suivant c'est une idée intéressante. On met ça dans la todo list mais c'est pas la priorité actuellement, surtout que c'est pas si simple que ça à rajouter. Vous pouvez par contre ajouter un module de produits à la page produit qui serait synchronisée avec les catégories d'un produit pour afficher les produits de la même catégorie.

Please Log in or Create an account to join the conversation.

  • Posts: 48
  • Thank you received: 0
9 years 8 months ago #472

Re... et merci pour la réactivité.

Après une mise à jour, le problème de pagination subsiste. :S

A la fin de cette mise à jour, j'ai eu les messages suivants :
JInstaller::install: WARNSAME
Erreur dans l'installation du plugin plg_community_hikashop

Après un petit tour dans Aide/A propos, il est affiché : You have the latest stable version : 1.2.0

En ce qui concerne le lien sur le menu, si j'ai bien compris, il faut que je mette dans le module qui apparait sur la page accueil, le nom du menu qui affiche la galerie à laquelle appartiennent ces photos ? :side:


Plus un objet tombe moins vite, moins sa vitesse est plus grande.

Please Log in or Create an account to join the conversation.

  • Posts: 69940
  • Thank you received: 10476
  • MODERATOR
9 years 8 months ago #477

Effectivement, vous aviez toujours un problème sur la pagination. Le problème n'apparaissait qu'après avoir navigué dans les sous catégories, pas si vous aviez le listing de produit directement sur la catégorie principale, d'où le fait que nous n'avions pas vu le problème lors de nos tests. J'ai donc corriger le bug sur votre site et nous intègrerons cela dans la prochaine version.

Pour l'erreur lors de la mise à jour, c'est encore un problème de droits d'accès sur les plugins. Pas grave pour vous, vous pouvez ignorer. Pour référence, voilà une explication du problème en anglais: forum.joomla.org/viewtopic.php?p=2197594...8e4623652a1#p2197594

Pour le module: c'est tout à fait ça.

Please Log in or Create an account to join the conversation.

  • Posts: 48
  • Thank you received: 0
9 years 8 months ago #478

Ok merci pour le debugage.

Pour le module, un problème persiste. La galerie dans laquelle sont puisées les image n'a pour vocation que de contenir les images mises en vedette. Aucun menu n'est chargé de la faire apparaitre. J'ai bien essayé de créer un menu indépendant qui est relié à un module destiné à montrer les photos en vedette, d'activer ce menu mais de ne publier le module du menu sur aucune page. On finit par s'y perdre. Et je ne suis pas sûr que tout cela ne finisse par occasionner des réactions bizarres :silly: .
Ne perdez pas votre temps pour un truc tordu.
J'y reviendrai plus tard si le besoin s'en fait sentir...
Merci de votre aide. :kiss:


Plus un objet tombe moins vite, moins sa vitesse est plus grande.

Please Log in or Create an account to join the conversation.

  • Posts: 69940
  • Thank you received: 10476
  • MODERATOR
9 years 8 months ago #479

Non non, vous avez déjà le menu photo. Donc vous avez juste à mettre dans le champ "menu" (ou itemid, je ne sais plus le nom) le nom du menu photos (donc "photos" je suppose?) dans les options du module d'affichage des images vedettes

Please Log in or Create an account to join the conversation.

Time to create page: 0.099 seconds
Powered by Kunena Forum