Problème d'affichage avec IE7 et IE8

  • Posts: 5
  • Thank you received: 0
10 years 7 months ago #32713

Bonjour,
Je m'initie à Hikashop avec Joomla 1.7
Avant de vous alerter sur un petit souci, j'ai pris soin de vérifier que le problème existait aussi avec votre site de démonstration. J'ai testé l'achat d'un article avec vos URL sur IEtester, tout se passe fort bien avec la majorité des navigateurs, sauf sous IE7 et IE 8. En effet, une fois l'article ajouté au panier, si l'on veut terminer sa commande à partir du panier (module en left), mais aussi avec la popup, celui-ci se remet à zéro et renvoie de nouveau sur la page des articles, affichant: panier vide, ceci sans proposer la page check poursuite commmande. C'est comme si l'on n'avait pas fait de commande.
Avec IE9 le problème ne se pose pas.
Avez vous déjà eu cette observation? Merci de m'orienter vers vos conclusions
Bien cordialement et sincèrement, félicitations pour votre travail qui est exemplaire en bien des points, mais certains sont sous iE7 ou 8.
( :( Mille excuses je me suis aperçu trop tard que le contact ne devait pas servir à signaler des bugs pardonnez-moi..)

Please Log in or Create an account to join the conversation.

  • Posts: 76113
  • Thank you received: 11910
  • MODERATOR
10 years 7 months ago #32746

Bonjour,

Nous avons bien entendu tester HikaShop avec IE 7 et IE 8 et tout fonctionne comme il faut, y compris sur notre site de démo. Nous utilisons pour cela l'outil de développement de IE9 qui permet de passer en mode IE7 et IE8. Quand nous faisons cela et que nous essayons sur notre site de démo, pas de problème du tout.
J'avoue que nous n'avons pas testé sous ietester que nous n'avons jamais utilisé jusqu'alors puisque nous pensions que l'outil de développement inclu dans IE9 était idéal pour cela.

Nous avons actuellement eu quelques personnes qui nous ont parlées de cela ici:
www.hikashop.com/en/support/forum/3-bug-...-users-with-ie8.html
Et nous n'avions pas réussi à reproduire le problème.

Cependant, vu le nombre de personnes qui utilisent HikaShop, je suis étonné que seulement 3 personnes aient rapportées le problème. Il semble que cela ne se produise pas tout le temps avec IE7 et IE8, mais uniquement dans certains cas.

Je vais de ce pas installer IEtester et essayer de reproduire le problème.

Please Log in or Create an account to join the conversation.

  • Posts: 5
  • Thank you received: 0
10 years 7 months ago #32761

Bien sûr, j'imagine que le problème est exceptionnel et que c'est donc probablement IEtester qui génère le souci.
Tant mieux, votre réponse sur la fréquence improbable du bug me rassure et je vous remercie d'avoir pris la peine de répondre à cette interrogation.
Encore bravo pour Hika shop, je suis ravie de l'avoir découvert, j'aime ce composant que je trouve complet, pratique et très intuitif.
www.hikashop.com/fr/support/forum/5-supp...7-et-ie8/report.html

Please Log in or Create an account to join the conversation.

  • Posts: 5
  • Thank you received: 0
10 years 7 months ago #32765

Effectivement avec les tests sous IE9 mis aux normes IE7 et IE8 le problème n'apparait pas. Seul IEtester fait bugger l'appel de la page checkout, une subtilité mystérieuse...
De quoi ;) ravir les Scherlock Holmes. Si jamais vous avez l'énigme de "l'ile perdue aux caprices improbables..." Merci de me souffler votre diagnostic Dr !.

Please Log in or Create an account to join the conversation.

  • Posts: 76113
  • Thank you received: 11910
  • MODERATOR
10 years 7 months ago #32779

J'ai essayé avec IEtester et le panier du site de démo fonctionne correctement sous IE8. Par contre, sous IE7, il y a en effet le problème que vous décrivez.
Cela ressemble à un problème de session avec IE 7:
Apparement, IE7 ne gère pas correctement les sessions lorsque des iframes sont utilisées, ce qui est le cas pour l'ajout au panier sur le site de démo par défaut.
Deux solutions sont possibles pour remédier au problème:

La plus simple, et que j'ai pu validée sur le site de démo est de désactiver l'option "Utiliser l'AJAX quand c'est possible<br/>pour les boutons d'ajout au panier" dans l'onglet Passage en caisse de la configuration. Du coup, quand vous ajoutez un produit au panier, la page est entièrement rafraichie et le problème disparait.

La seconde solution est de changer les headers P3P dans Joomla. Sous Joomla 1.7 il existe un plugin P3P qui permet de faire cela. Il faut alors le configuré comme cela:
adamyoung.net/IE-Blocking-iFrame-Cookies
Sous joomla 1.5 , il faut par contre modifier cela directement dans le code d'un fichier de joomla:
forum.joomla.org/viewtopic.php?p=2315444

Please Log in or Create an account to join the conversation.

Time to create page: 0.066 seconds
Powered by Kunena Forum