Adding Billing address not possible from back end.

  • Posts: 26
  • Thank you received: 0
  • Hikaserial Subscription Hikashop Business
1 week 6 days ago #322404

-- HikaShop version -- : 4.3.0
-- Joomla version -- : 3.9.20
-- PHP version -- : 7.3
-- Browser(s) name and version -- : chrome

This problem exist for years and I am curious why nobody fixed this as yet.
When I try to edit Delivery or Billing address from back-end I can add only Delivery address. Adding Billing address is not working as address will land on Delivery side anyway.

Please Log in or Create an account to join the conversation.

  • Posts: 70194
  • Thank you received: 10508
  • MODERATOR
1 week 5 days ago #322407

Hi,

I don't know of such problem. Are your talking about adding new addresses in the user manager ?
Or maybe you're talking about editing the billing address of an order ?
Or you're talking about selecting a billing address from the user of an order when the order doesn't have any billing address ?
Could you please provide some step by step instructions on how to reproduce the problem ?

Please Log in or Create an account to join the conversation.

  • Posts: 26
  • Thank you received: 0
  • Hikaserial Subscription Hikashop Business
1 week 5 days ago #322422

Sure, quick scenario.
1. We have user in the shop without Any address added.
2. Go to the Administrator/HikoShop/Customers and try to add Billing address
Always this address is added to the Shipping, so finally there is no way to create Billing address for such a user.

Please Log in or Create an account to join the conversation.

  • Posts: 2647
  • Thank you received: 348
  • MODERATOR
1 week 5 days ago #322436

Hello,

We followed your directions and everything works as expected, and we were able to add only a billing address.
From this, this issue must come from somewhere, but to understand to progress on this subject can you precise if you see this on several website ? Or only one ? Did you process some test with Joomla debug mode (development level) ?

Awaiting elements to be able to progress on your subject.
Regards

Last edit: 1 week 5 days ago by Philip.

Please Log in or Create an account to join the conversation.

  • Posts: 26
  • Thank you received: 0
  • Hikaserial Subscription Hikashop Business
1 week 1 day ago #322583

Hi Philip
I have only one website which is an update of the previous one. On old and on new I have the same problem. I think there might be some old files used in previous and new template. If I look into template files, Hika related are from even 2017. Any idea how to clean this up?

Please Log in or Create an account to join the conversation.

  • Posts: 2647
  • Thank you received: 348
  • MODERATOR
1 week 7 hours ago #322599

Hello,

Provide a step by step process with many details in order to allow us to reproduce your issue.
Add via our Contact us form, a backend url and references access.
The point is to be able to reproduce issue on our side, and directly on your website in order to understand what's going on.

Awaiting news from you to progress on your subject.
Regards

Last edit: 1 week 8 hours ago by Philip.

Please Log in or Create an account to join the conversation.

  • Posts: 26
  • Thank you received: 0
  • Hikaserial Subscription Hikashop Business
1 week 2 hours ago #322618

Email with login details on the way.
To reproduce steps:
1. go to your customer name in Hika Shop
2. click on Edit
3. Tray to add billing address

Please Log in or Create an account to join the conversation.

  • Posts: 70194
  • Thank you received: 10508
  • MODERATOR
6 days 19 hours ago #322630

Hi,

We got your access. However, there must be a problem with the access as I'm not able to access the backend with it.
Could you please double check it ?

Please Log in or Create an account to join the conversation.

  • Posts: 26
  • Thank you received: 0
  • Hikaserial Subscription Hikashop Business
6 days 19 hours ago #322638

Sorry, wrong rights. Try again.

Please Log in or Create an account to join the conversation.

  • Posts: 70194
  • Thank you received: 10508
  • MODERATOR
6 days 1 hour ago #322677

Hi,

Thanks. I was able to access it and found what was the problem.
It actually comes from a popup conflict between the billing and the shipping address edition due to the way the bootstrap popup system works.
To circumvent that, I've changed the "popup mode" setting of the HikaShop configuration to "vex".
That's actually the default when you install HikaShop and with next version of HikaShop we're actually removing that option to always use vex as it displays the same as the others, but works better on mobile devices and Joomla 4 and avoid compatibility problems with some templates.

Please Log in or Create an account to join the conversation.

  • Posts: 26
  • Thank you received: 0
  • Hikaserial Subscription Hikashop Business
5 days 23 hours ago #322680

Perfect, I have changed this and now all is ok. Thanks!

Please Log in or Create an account to join the conversation.

Time to create page: 0.071 seconds
Powered by Kunena Forum