Fatal Error - Blank Frontage after Joomla upgrade to 3.8.5

  • Posts: 257
  • Thank you received: 24
11 months 1 week ago #287710

-- url of the page with the problem -- : lightningridgeinfo.com.au/
-- HikaShop version -- : 3.3
-- HikaSerial version -- : 2.1
-- Joomla version -- : 3.8.5
-- PHP version -- : 7.0.27
-- Browser(s) name and version -- : Chrome and Firefox
-- Error-message(debug-mod must be tuned on) -- : Fatal error: Cannot redeclare hikaserialBuildRoute() (previously declared in /home/viewebne/public_html/lightningridgeinfo.com.au/components/com___compo_name__/router.php:12) in /home/viewebne/public_html/lightningridgeinfo.com.au/components/com_hikaserial/router.php on line 41

All was working fine until I updated to latest Joomla 3.8.5... now site is blank on the frontend. (500 Error)

Help ASAP greatly appreciated!


Don't look at what is and ask 'why?'; look at what isn't and ask 'Why Not!'

Please Log in or Create an account to join the conversation.

  • Posts: 257
  • Thank you received: 24
11 months 1 week ago #287711

Ok... I have managed to fix/track down.... still confused though..

Through the upgrade process, there seems to have been an erroneous component created and tracking that down in cpanel (file manager) there it was, with Hikaserial files in it) - attached is the now deleted folder for info.

As you can see, it had the directory name of com___compo_name__, which also corresponds to the erroneous menu item in the components.

It must have been a gremlin through the update process of either joomla, hikashop, or serial.

So that is solved....

BUT, how do I get rid of the erroneous menu item in the backed? (see image)



Any help on that GREATLY appreciated!


Don't look at what is and ask 'why?'; look at what isn't and ask 'Why Not!'
Attachments:
Last Edit: 11 months 6 days ago by Jerome.

Please Log in or Create an account to join the conversation.

  • Posts: 23199
  • Thank you received: 3592
  • MODERATOR
11 months 6 days ago #287713

Hello,

You need to use the "Joomla > Extensions > Manage > Manage" in order to uninstall the wrong named component.
There was an issue with the packaging of HikaSerial but we fixed it on Feb 09.

Regards,


Jerome - Obsidev.com
HikaMarket & HikaSerial developer / HikaShop core dev team.

Also helping the HikaShop support team when having some time or couldn't sleep.
By the way, do not send me private message, use the "contact us" form instead.

Please Log in or Create an account to join the conversation.

Moderators: Obsidev
Time to create page: 0.077 seconds
Powered by Kunena Forum