Tax of product not shown correctly in order items

  • Posts: 60
  • Thank you received: 1
  • Hikamarket Multivendor Hikashop Business
8 months 2 weeks ago #281728

-- HikaShop version -- : 3.2.1
-- HikaMarket version -- : 2.0.0
-- Joomla version -- : 3.8.1
-- PHP version -- : 7.0
-- Browser(s) name and version -- : Chrome 69
-- Error-message(debug-mod must be tuned on) -- : no error

When I order an item with the 6% TAX associated with it, it shows correctly in the checkout and in the order itself in the back-end. See the screenshots attached.

When I edit the order in the back-end it selects the 0% Tax category, but I am not sure why. (See screenshots).

When I look into the database, the initial value of "order_product_tax_info" is this:

a:1:{s:13:"0000_00000001";O:8:"stdClass":18:{s:11:"taxation_id";s:1:"1";s:12:"zone_namekey";a:1:{i:0;s:23:"country_Netherlands_150";}s:16:"category_namekey";s:11:"default_tax";s:11:"tax_namekey";s:8:"BTW Laag";s:18:"taxation_published";s:1:"1";s:13:"taxation_type";s:0:"";s:15:"taxation_access";s:3:"all";s:19:"taxation_cumulative";s:1:"0";s:18:"taxation_post_code";s:0:"";s:19:"taxation_date_start";s:1:"0";s:17:"taxation_date_end";s:1:"0";s:22:"taxation_internal_code";s:1:"0";s:13:"taxation_note";s:0:"";s:16:"taxation_site_id";s:0:"";s:17:"taxation_ordering";s:1:"0";s:8:"tax_rate";s:7:"0.06000";s:9:"zone_type";s:7:"country";s:10:"tax_amount";d:0.68999999999999995;}}

When I alter the value to the 6% Tax category manually, the value of "order_product_tax_info" changes to:
a:1:{i:0;O:8:"stdClass":18:{s:11:"taxation_id";s:1:"1";s:12:"zone_namekey";a:1:{i:0;s:23:"country_Netherlands_150";}s:16:"category_namekey";s:11:"default_tax";s:11:"tax_namekey";s:8:"BTW Laag";s:18:"taxation_published";s:1:"1";s:13:"taxation_type";s:0:"";s:15:"taxation_access";s:3:"all";s:19:"taxation_cumulative";s:1:"0";s:18:"taxation_post_code";s:0:"";s:19:"taxation_date_start";s:1:"0";s:17:"taxation_date_end";s:1:"0";s:22:"taxation_internal_code";s:1:"0";s:13:"taxation_note";s:0:"";s:16:"taxation_site_id";s:0:"";s:17:"taxation_ordering";s:1:"0";s:8:"tax_rate";s:7:"0.06000";s:9:"zone_type";s:7:"country";s:10:"tax_amount";s:7:"0.69000";}}

It seems the initial value is not stored correctly for some reason, even though the amount is registered correctly.

Is there a way to correct this? I hope you can help me out here!

Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 22525
  • Thank you received: 3509
  • MODERATOR
8 months 2 weeks ago #281729

Hello,

I don't think that your question is related to HikaMarket.

Regards,


Jerome - Obsidev.com
HikaMarket & HikaSerial developer / HikaShop core dev team.

Also helping the HikaShop support team when having some time or couldn't sleep.
By the way, do not send me private message, use the "contact us" form instead.

Please Log in or Create an account to join the conversation.

Moderators: Obsidev
Time to create page: 0.073 seconds
Powered by Kunena Forum