Australia Post Module issues

  • Posts: 14
  • Thank you received: 0
7 years 9 months ago #5276

Hi

I have been trialling the free version of Hikasoft 1.4.3 on Joomla 1.6. I have encountered some issues with the Australia Post Module.

1. When I add an item to the cart and then proceed to the checkout, without logging in, I receive a message
"The Australia Post shipping plugin requires the user to enter a postal code when goods are shipped within Australia. Please go to "Display->Custom fields" and set the post code field to required."
This has been set correctly. When I login with a user with a postcode, then the error message disappears. I think this message shouldn't be shown at this time.

2. When I have logged in and proceed to the checkout, the "Final Total" doesn't include the cost of the shipping. If I hit proceed to checkout again, then the "Final Total" is correct.

Other than those issues, I like the product and will probably replace Virtuemart with the paid version of the software. Any assistance would be appreciated.



Thanks
Peter

Attachments:
Last Edit: 7 years 9 months ago by pedrof.

Please Log in or Create an account to join the conversation.

  • Posts: 63951
  • Thank you received: 9217
  • MODERATOR
7 years 9 months ago #5282

Hi,

1. Could you try to replace the code

if(empty($order->shipping_address->address_post_code)){
by
if(hikashop::loadUser() && empty($order->shipping_address->address_post_code)){
in the file plugins/hikashopshipping/aupost.php and try again ?

2. What checkout workflow are you using ? Could you provide the URL of your website so that we can test that problem ?

Please Log in or Create an account to join the conversation.

  • Posts: 14
  • Thank you received: 0
7 years 9 months ago #5323

Thanks Nicolas, the code change worked. I will fully test the functionality of the module over the next week.

The workflow is the default of login_address_shipping_payment_confirm_coupon_cart_status_fields,end

I will send the details of the test site via your contact form.

Cheers
Peter

Please Log in or Create an account to join the conversation.

  • Posts: 63951
  • Thank you received: 9217
  • MODERATOR
7 years 9 months ago #5327

Hi,

I tried to reproduce the problem you're desribing on your website but wasn't able to.

However, I saw that you deactivated by air and by sea in the plugin options. If so, you should set the zone restriction of the shipping plugin to australia so that the users outside australia cannot proceed to the checkout.

Please Log in or Create an account to join the conversation.

  • Posts: 14
  • Thank you received: 0
7 years 9 months ago #5383

Hi Nicolas

The code change resolved the issue with the final total (I reverted to the original and the issue occured again). There is an issue still in that the tax figure is incorrect. The Taxes should include the tax component on the shipping, so for an order total of $73.70, the tax component is $6.70

I couldn't see how to restrict the zone restriction of the shipping plugin to australia. Can you point me to some instructions on that please?

One last question - is it possible to have an option so that each product has its shipping calculated individually? The issue is that I send out cartons of product and each carton is charged individually by Australia Post. When Hikashop calculates the price, it uses the total shipping weight for the postage calculations, which works out cheaper than for 2 individual items.

Thanks for the great support

Peter

Please Log in or Create an account to join the conversation.

  • Posts: 63951
  • Thank you received: 9217
  • MODERATOR
7 years 9 months ago #5393

Did you set a tax category in your shipping method ?

In the menu System->Shipping methods you can edit your AUP plugin options. There, you will have the option "zone" with an edit icon to select a zone restriction. You can choose australia there. In these options, you also have the tax category option.

If you edit the file plugins/hikashopshipping/aupost.php and change the code

								if($parcels[$i]->Weight+$product_weight>$maw_weight || $parcels[$i]->global_volume+$product_volume>$max_volume){
									unset($parcels[$i]->global_volume);
									$parcel = null;
									$parcel->Weight = 0;
									$parcel->global_volume = 0;
									$parcels[]=$parcel;
									$i++;
								}
to
									unset($parcels[$i]->global_volume);
									$parcel = null;
									$parcel->Weight = 0;
									$parcel->global_volume = 0;
									$parcels[]=$parcel;
									$i++;
in order to have one parcel per product.

Please Log in or Create an account to join the conversation.

  • Posts: 14
  • Thank you received: 0
7 years 9 months ago #5396

Hi Nicolas

I already had the zone set, so that is OK.

The tax zone Australia which has a tax category called Australia which is set to 10%. This is set in the Aupost plugin. The price returned from the Australia Post drc site includes the tax component.

The test site is still active if you wish to check it out again.

Thanks
Peter

Please Log in or Create an account to join the conversation.

  • Posts: 63951
  • Thank you received: 9217
  • MODERATOR
7 years 9 months ago #5414

Mmm. That seems to be a miss in the plugin.

Could you try to replace the code

foreach($rates as $rate){
						$usable_rates[]=$rate;
					}
by the code
$currencyHepler = hikashop::get('class.currency');
					foreach($rates as $rate){
						$rate->shipping_price = $currencyHepler->getTaxedPrice($rate->shipping_price,hikashop::getZone(),$rate->shipping_tax_id,$currencyHepler->getRounding($currency));
						$usable_rates[]=$rate;
					}
in the file plugins/hikashopshipping/aupost.php ? That should fix the problem.

Please Log in or Create an account to join the conversation.

  • Posts: 14
  • Thank you received: 0
7 years 9 months ago #5526

Hi Nicolas

Sorry for the delay in responding. The code change did not work.

Cheers
Peter

Please Log in or Create an account to join the conversation.

  • Posts: 63951
  • Thank you received: 9217
  • MODERATOR
7 years 9 months ago #5539

Could you also add the line

$info->shipping_tax_id = $rate->shipping_tax_id;
below the line
$info->shipping_images = $rate->shipping_images;
in that same file and try again ?

Please Log in or Create an account to join the conversation.

  • Posts: 14
  • Thank you received: 0
7 years 9 months ago #5544

Hi

That has had the wrong effect.

On the test site, if you select one product and ship it to the test user, the postage is $7.70 of which 10% is tax (0.70)
After the last change, it is showing the shipping price as 8.47 which is 7.70 + 10% and the tax and final totals are incorrect.

The test site is still open if you want to logon.

Cheers
Peter

Please Log in or Create an account to join the conversation.

  • Posts: 63951
  • Thank you received: 9217
  • MODERATOR
7 years 9 months ago #5557

Mmm. There indeed seems to be a problem.

We'll try to reproduce the problem on our end and see if we can fix it...

Please Log in or Create an account to join the conversation.

  • Posts: 63951
  • Thank you received: 9217
  • MODERATOR
7 years 9 months ago #5657

Just to keep you posted: We didn't had the time today to look at the problem but we'll do that tomorrow.

Please Log in or Create an account to join the conversation.

  • Posts: 14
  • Thank you received: 0
7 years 9 months ago #5661

Thanks Nicolas

As I am at the testing phase on my new site, I am not desperate for the fix.

Cheers
Peter

Please Log in or Create an account to join the conversation.

  • Posts: 63951
  • Thank you received: 9217
  • MODERATOR
7 years 9 months ago #5763

Hi,

We found some issues with the shipping taxes display today:
www.hikashop.com/en/support/forum/4-how-...eckout-incl-vat.html
We'll do a pre release tomorrow and would like to try to install that new version on your website to test that it now works ok. Are you ok with that ?

Please Log in or Create an account to join the conversation.

  • Posts: 14
  • Thank you received: 0
7 years 9 months ago #5779

Hi Nicolas


That is fine with me.

Cheers
Peter

Please Log in or Create an account to join the conversation.

  • Posts: 63951
  • Thank you received: 9217
  • MODERATOR
7 years 9 months ago #5780

Hi,

I install that new version. The taxes are calculated automatically on the shipping now and the new option to group products or not in the australia post plugin is working too. However, in some cases, there is still a problem with the shipping price not added to the total. Also there is a notice message now at the top...

It's going to take days if not weeks trying to fix something like this without being able to reproduce it on our end and just blindly changing stuff and then installing a new version on your website. Would it be possible to have an FTP access so that we could directly put traces in the code on your website to see what happens and why ? If yes, you can send us the information at This email address is being protected from spambots. You need JavaScript enabled to view it.

Please Log in or Create an account to join the conversation.

  • Posts: 63951
  • Thank you received: 9217
  • MODERATOR
7 years 9 months ago #5807

Hi,

Thank you for the access. I was able to fix the australia post plugin. It seems to be working alright now on your website.

Please Log in or Create an account to join the conversation.

  • Posts: 14
  • Thank you received: 0
7 years 9 months ago #5810

Thanks Nicolas

When do expect to release a new version with all of the updates?

Cheers
Peter

Please Log in or Create an account to join the conversation.

  • Posts: 63951
  • Thank you received: 9217
  • MODERATOR
7 years 9 months ago #5811

At the beginning of the week.
We have no bugs opened at the moment so if everything goes as planned we might do it tomorrow or on tuesday.

Please Log in or Create an account to join the conversation.

Time to create page: 0.234 seconds
Powered by Kunena Forum