Double slash // in images URL

  • Posts: 3
  • Thank you received: 0
1 month 1 week ago #284115

-- url of the page with the problem -- : www.dariusmartin.com/test/index.php/hika...oduct/1-painting-one
-- HikaShop version -- : 3.2.1
-- Joomla version -- : 3.8.2
-- PHP version -- : 5.6.32
-- Browser(s) name and version -- : Chromium 62.0.3202.94

Hi guys!

I have an art website that I'm trying to turn into an art store. So far everything works fine, kudos to Hikashop.
But I found this glitch on the product page. I changed the default Hikashop images folder to /images, where I keep my images under Joomla, and I want to continue keeping them there for SEO reasons. Everything looks fine at first, I can select the images in the Hikashop backend to show from their respective folders, but when I hover over the image on the frontend product page or open it in another tab, I get a // double slash in my URL.
I created a new test Joomla + Hikashop installation to be sure this isn't caused by a plugin conflict or something of that sort but the problem persists. Both Joomla and Hikashop are installed out-of-the-box, on a new database, with nothing else added. Turning Joomla SEF on or off makes no difference.
I created a test product, here's the link:

www.dariusmartin.com/test/index.php/hika...oduct/1-painting-one
And the image in question:
www.dariusmartin.com/test/images//painti...e-object_45x35cm.jpg

I also noticed upon on creating another new product, that even without adding an image, the default Hikashop thumbnail for product pages has the same problem:

www.dariusmartin.com/test/index.php/hika...oduct/2-painting-two
www.dariusmartin.com/test/media/com_hika.../images//barcode.png

Unfortunately, my experience ends with HTML and CSS, so even after intensive searching for a fix, I couldn't come up with a solution.
Hope you can help.

Thank you, and have a nice day! :)

Last Edit: 1 month 1 week ago by dariusmartin.

Please Log in or Create an account to join the conversation.

  • Posts: 60537
  • Thank you received: 8531
  • MODERATOR
1 month 1 week ago #284130

Hi,

Could you edit an image with the issue when you are editing its product ?
That will open a popup with the details of the image.
Please provide a screenshot of its settings there so that we can see what's going on.

Please Log in or Create an account to join the conversation.

  • Posts: 3
  • Thank you received: 0
1 month 1 week ago #284132

Hi Nicolas.

Here is the screenshot of the image modifying screen. I also added a screenshot of the image adding screen. Hope that helps.
I could provide you with the admin/password for this Joomla instance if that helps.
Thank you! :)

Attachments:
Last Edit: 1 month 1 week ago by dariusmartin.

Please Log in or Create an account to join the conversation.

  • Posts: 1521
  • Thank you received: 218
  • MODERATOR
1 month 1 week ago #284180

Hello,

Thanks for your return, it's able us to provide a patch for this issue.
This will be add to our next versions, and in order to apply the fix follow me step by step :
- First go in your website file :
YourWebsite\administrator\components\com_hikashop\helpers
- Replace your image.php file the one I provide with this message (after had unzipped it).

Process some tests and make us a return if that solve your issue or not.

Regards

Attachments:
Last Edit: 1 month 1 week ago by Philip.

Please Log in or Create an account to join the conversation.

  • Posts: 3
  • Thank you received: 0
1 month 1 week ago #284190

This worked for me. :)
Good job! Thanks, guys!

Please Log in or Create an account to join the conversation.

Time to create page: 0.086 seconds
Powered by Kunena Forum