Brands carousel not opening the correct brand page

  • Posts: 39
  • Thank you received: 0
1 year 10 months ago #243354

-- url of the page with the problem -- : www.farmakeio24.net/
-- HikaShop version -- : 2.6.5
-- Joomla version -- : 3.5.1

Hello I tried to create a carousel that shows the logos of the brands but when I press the image joomla opens a page with and id: &Itemid=842 at the end of the url. The original brands module opens the brands category page with &Itemid=475 and works just fine. If I manually change 842 to 475 on my browser it works. Is there some setting I missed in the module's settings? Is there some way I can make a change to the code?

Example:
Correct url: www.farmakeio24.net/index.php?option=com...ingelheim&Itemid=475

Empty page: www.farmakeio24.net/index.php?option=com...ingelheim&Itemid=842

Thank you in advance.
Best regards
Antonis

Please Log in or Create an account to join the conversation.

  • Posts: 61840
  • Thank you received: 8794
  • MODERATOR
1 year 10 months ago #243369

Hi,

In the module settings, there is the "menu" setting. That's what decides what will be in the Itemid parameter in the URLs. If you want 475, then you need to select the menu item with that id in that setting.
If you don't see any change after that, it could be because you have the "force canonical URLs on listings" setting of the HikaShop configuration activated or that you have some cache activated on your website.

Please Log in or Create an account to join the conversation.

  • Posts: 39
  • Thank you received: 0
1 year 10 months ago #243386

Thank you for your advice Nicolas!!!
That fixed my issue!!!

Please Log in or Create an account to join the conversation.

Time to create page: 0.067 seconds
Powered by Kunena Forum