Problem configuration checkout workflow

  • Posts: 161
  • Thank you received: 3
  • Hikashop Business
2 months 3 days ago #300568

-- HikaShop version -- : 3.5.1
-- Joomla version -- : 3.8.8
-- PHP version -- : 7.0
-- Browser(s) name and version -- : Firefox 63

Hi,

On a local XAMPP server I've tested updating Hikashop 322 to version 351 and now the configuration of the new checkout workflow is reacting in a very strange way. I wiil try to explain.

When I change a setting in a view often many settings change at the same time on the screen. And after saving sometimes nothing has changed at all, or some other setting has changed.

Example: say in Step 1 view Cart I change Show delete icons from YES to NO, then all settings on the screen change to NO.
After saving the Show delete icons still is YES but the Show link to product page has changed from YES to NO.

Another example: say in Step 2 view Login I change Show submit button from YES to NO. The other settings of this view change on the screen, but after saving it 's okay. Then in Step 4 view Fields I change Show title from YES to NO. After saving it's still YES, but now Show submit button is back to YES.

And sometimes in view Fields the Custom fields show a list of articles in stead of a list of fields.

I've tried in Joomla 3.9.0, a new installation in stead of an upgrade, Hikashop 4.0.1, Chrome in stead of Firefox. Always in XAMPP. Sometimes it seems to work better, but always there's unexpected behaviour.

Do I miss something? Some javascript problem? What is going on??

regards,
Udo

Please Log in or Create an account to join the conversation.

  • Posts: 64479
  • Thank you received: 9312
  • MODERATOR
2 months 3 days ago #300570

Hi,

No one reported such issues with HikaShop 3.5.1 so I'm surprised you would get that.
Javascript issue could indeed be the cause. Maybe some weird conflict with another extension.
Do you get any javascript error if you try again with the console of your browser opened ?
The best would be to move the website online somewhere so that we could access it in order to reproduce the problem and analyse the situation ourselves.

Please Log in or Create an account to join the conversation.

  • Posts: 161
  • Thank you received: 3
  • Hikashop Business
2 months 2 days ago #300629

Hi Nicolas,

No, the browser console does not show a javascript error.
The problem also occurs in Hikashop 4.01.
And it also occurs in a new install on a new local testsite.

I've tested an install on my personal live website and then the workflow configuration works fine !

So probably the problem is caused by XAMPP.
Some setting is blocking the workflow process.

Other parts of the configuration work fine in XAMPP. The only problem is the new checkout workflow.
Is there some specific new aspect of the new checkout workflow that might be responsible?

regards,
Udo
.

Please Log in or Create an account to join the conversation.

  • Posts: 64479
  • Thank you received: 9312
  • MODERATOR
2 months 1 day ago #300633

Hi,

The new checkout workflow editor has been added in HikaShop 3.4.0.
So if you had a previous version with the "checkout legacy" setting deactivated and updated to a more recent version, then the whole checkout workflow editor interface changed.
The new checkout workflow interface editor uses quite a bit of javascript.
However, we're also using xampp on our local computers and never had the issues you're reporting with it.
So I don't think it's linked to xampp being used.
There must be some other difference between your localhost test and the online test you did.

Please Log in or Create an account to join the conversation.

  • Posts: 161
  • Thank you received: 3
  • Hikashop Business
1 month 3 weeks ago #300853

Hi,
Indeed, it isn't linked to xampp.
I've moved the testwebsite to another xampp server on another computer en then all works fine.

So the problem is linked to some setting or bug on my xampp server or on my computer.
I've changed php.ini but this didn't have any effect.

Anyway I trust it will work fine on my live website so I will update soon.

Thanks,
Udo

Please Log in or Create an account to join the conversation.

Time to create page: 0.085 seconds
Powered by Kunena Forum