No Products Found - Filter issue!

  • Posts: 18
  • Thank you received: 0
  • Hikashop Business
6 months 2 weeks ago #289066

-- HikaShop version -- : 3.3.0 Business
-- Joomla version -- : 3.8.5
-- PHP version -- : 7.1.14
-- Browser(s) name and version -- : Edge 41.16299.15.0

After many hours today I have given up. I have even done your tutorial example in your support document. What ever I try I keep getting No Products Found. Any advise would be much appreciated.

Please Log in or Create an account to join the conversation.

  • Posts: 22799
  • Thank you received: 3544
  • MODERATOR
6 months 2 weeks ago #289067

Hello,

Would it be possible to have some details about what you have done and a link to your website product listing with the filter configured ?
Some information regarding the filter configuration would also be required to perform tests or understand the global behavior.

Regards,


Jerome - Obsidev.com
HikaMarket & HikaSerial developer / HikaShop core dev team.

Also helping the HikaShop support team when having some time or couldn't sleep.
By the way, do not send me private message, use the "contact us" form instead.

Please Log in or Create an account to join the conversation.

  • Posts: 18
  • Thank you received: 0
  • Hikashop Business
6 months 2 weeks ago #289136

Thank you for your reply. I have configured as per your tutorial. How can I send you a link to the site as it is on a test server and I do not want this public - many thanks.

Please Log in or Create an account to join the conversation.

  • Posts: 63335
  • Thank you received: 9130
  • MODERATOR
6 months 2 weeks ago #289137

Hi,

You can use our contact form:
www.hikashop.com/support/contact-us.html
Make sure you include a link to this thread.
Also, a screenshot of the filter and of the filter module (if you're using it) settings would be great so that we can better understand the situation.

Please Log in or Create an account to join the conversation.

  • Posts: 18
  • Thank you received: 0
  • Hikashop Business
6 months 2 weeks ago #289231

nicolas wrote: Hi,

You can use our contact form:
www.hikashop.com/support/contact-us.html
Make sure you include a link to this thread.
Also, a screenshot of the filter and of the filter module (if you're using it) settings would be great so that we can better understand the situation.

I have sent an email as advised. The settings are attached to this topic. Two from the Filter Module and 1 from the Filter within the Shop Component. Many thanks.

Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 63335
  • Thank you received: 9130
  • MODERATOR
6 months 2 weeks ago #289232

Hi,

In the "menu" setting of your module, you need to enter the id of a menu item of the type "products listing" which is configured to display all the products.
This is not done on your filter module and that's why it doesn't work.
Please do that.

The following user(s) said Thank You: srtdesigns

Please Log in or Create an account to join the conversation.

  • Posts: 18
  • Thank you received: 0
  • Hikashop Business
6 months 2 weeks ago #289291

nicolas wrote: Hi,

In the "menu" setting of your module, you need to enter the id of a menu item of the type "products listing" which is configured to display all the products.
This is not done on your filter module and that's why it doesn't work.
Please do that.

I created a new Menu Item Hikashop > Product Listing which will show all products. I placed this in a Hidden Menu and the filter appears to work a treat. Thank you ever so much for your help, much appreciated.

Please Log in or Create an account to join the conversation.

Time to create page: 0.089 seconds
Powered by Kunena Forum