hikashopModifyQuantity is not defined after 3.0.0 update

  • Posts: 111
  • Thank you received: 1
  • Hikashop Business
1 year 8 months ago #259838

-- HikaShop version -- : 3.0.0
-- Joomla version -- : 3.6.5
-- Error-message(debug-mod must be tuned on) -- : hikashopModifyQuantity is not defined

Hello,
I just cloned my clients website to my local MAMP installation. I then installed the HikaShop 3.0 update to take my store from Business 2.6.4 to 3.0. All seems to have worked, I have turned off all the legacy option in the Configuration.

However when i now try and add a product to my basket via the frontend, I get this error in Dev Tools:

hikashopModifyQuantity is not defined

I am using template overrides for the visual display of HikaShop but not changed any core files. Looking at the show_quantity template there appears to be changes made.

Do I have to rebuild every template override?

How can I fix the hikashopModifyQuantity is not defined error?

Thanks

Lee

Please Log in or Create an account to join the conversation.

  • Posts: 22862
  • Thank you received: 3548
  • MODERATOR
1 year 8 months ago #259843

Hi,

Can you please provide details about your current HikaShop configuration ?
How are your "advanced > legacy" settings ?
What is the base version of your quantity view override ?

If you're using overrides based on old views and your settings do not match to the new views ; your javascript issue is unfortunately normal.
HikaShop 3.0 is a major release and it introduce some breaks in the retro-compatibility about views. But we have some legacy settings which should allow you to work with some old views (if they are not too old).

Regards,


Jerome - Obsidev.com
HikaMarket & HikaSerial developer / HikaShop core dev team.

Also helping the HikaShop support team when having some time or couldn't sleep.
By the way, do not send me private message, use the "contact us" form instead.

Please Log in or Create an account to join the conversation.

  • Posts: 111
  • Thank you received: 1
  • Hikashop Business
1 year 8 months ago #259945

I turned off all the legacy settings and got the issue. Then I turned back on the legacy Add to Cart option and it now works.

However some of the template overrides I dod for the checkout process do not seem to be used anymore.

Has the template filenames etc for the checkout process been changed?

Please Log in or Create an account to join the conversation.

  • Posts: 63554
  • Thank you received: 9154
  • MODERATOR
1 year 8 months ago #259947

Hi,

When you turn off the legacy options HikaShop will use new view files. So your template overrides won't be taken into account anymore.
That's why you had to add these settings.
The view files for the checkout process now all starts with show_block_

Please Log in or Create an account to join the conversation.

  • Posts: 111
  • Thank you received: 1
  • Hikashop Business
1 year 8 months ago #260107

Nicolas,
Thanks for the reply and explanation. Can you confirm it is perfectly fine to continue to use 2.6.4 HikaShop version?

I also have a question about exporting orders should I open another post?

Lee

Please Log in or Create an account to join the conversation.

  • Posts: 63554
  • Thank you received: 9154
  • MODERATOR
1 year 8 months ago #260109

Hi,

Yes, you can continue to use the 2.6.4. I's a really stable version and there are no known security issues with it.
Yes, please open a new thread and make sure you provide the necessary information for us to understand the issue.

Please Log in or Create an account to join the conversation.

Time to create page: 0.085 seconds
Powered by Kunena Forum