Virtuemart Import missing data

  • Posts: 118
  • Thank you received: 6
  • Hikashop Business
4 weeks 20 hours ago #301891

-- HikaShop version -- : 4.0.1
-- Joomla version -- : 3.9.1
-- PHP version -- : 7.2
-- Browser(s) name and version -- : Chome

Hi,

When I import from Virtuemart a lot of date gets transfered. Product and Images are there. The only problem are the orders. A lot of orders don't have a Customer added (Image-001). Also a lot of orders are getting Files added to the product list (Image-002). The VM shop has no downloads so this doesn't make sense. hope you have a solution to fix the import.

Regards!



Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 64484
  • Thank you received: 9313
  • MODERATOR
3 weeks 5 days ago #301929

Hi,

First, the most important is that we need to know the version of VM from which you're migrating as there are different import scripts for different versions of VM.
Second, could you tell us more about these orders ?
What is the difference between the orders for which the customer was transferred and the ones for which it wasn't ?
For example, are some made as "guest" and others as normal user accounts ?
Or the users are in different user groups ?
Or something else ?
If it worked for some and not for others, it means that there must be something different between both groups of orders and understanding what that is will help a lot in trying to solve the problem.
The downloads looks like images. I suppose that these are the images of the products ? Do you confirm ?
Normally, in the table virtuemart_medias of VM, there is a column with the name file_is_product_image with either the value 0 (for downloads) or 1 (for files). Could you check via your phpmyadmin the value of that column for the entries with the same name as the downloads you got attached to the products ? I suspect that there is another value for some reason which is why this happened.

Please Log in or Create an account to join the conversation.

  • Posts: 118
  • Thank you received: 6
  • Hikashop Business
1 week 1 day ago #302448

Hi Nicolas,

I tried several things but my conclusion is that the VM database is not consistent. I used CSVi to export and import the users and products. The order history is less important. All the information I need is now present in my new installation. Thanks for looking into it though!

Regards!

Please Log in or Create an account to join the conversation.

Time to create page: 0.082 seconds
Powered by Kunena Forum