Ошибка отображения категории
1. Создаю категорию, пишу ее описание
2. Привязываю категорию к пункту меню
3. Включаю тумблер "Показывать описание категории". Сохраняю
4. Захожу в эту категорию
5. Получаю ошибку:
Что пробовал?:
Сносил плагин полностью, путем удаления из менеджера расширений и удалением с FTP и BD.
После чего началось?:
Пробовал поменять местами описание категории с листингом товаров в этой категории, путем правки шаблонов в "настройки отображения". Ничего не получилось, но и ошибки не появлялись. Больше вроде ничего не делал.
В чем может быть проблема?
Please Log in or Create an account to join the conversation.
- progreccor
-
- Offline
- SEO, webdesign
1. версия хика
2. версия php
3. версия джумла
4. может быть у вас квик старт?
Я не явлюсь официальной службой поддержки!
Я здесь добровольно!
Хочешь получить купон на скидку Hikashop? Спроси меня как!
Please Log in or Create an account to join the conversation.
2. PHP 5.3
3. Joomla!, 3.5.1
4. Нет не квикстар. Устанавливал HikaShop из менеджера расширений.
Одно ясно, что отображение описания категории работало, пока я что-то не сделал.
Please Log in or Create an account to join the conversation.
- progreccor
-
- Offline
- SEO, webdesign
угадывать что вы там "нажали" - не в моих силах...
Я не явлюсь официальной службой поддержки!
Я здесь добровольно!
Хочешь получить купон на скидку Hikashop? Спроси меня как!
Please Log in or Create an account to join the conversation.
Please Log in or Create an account to join the conversation.
- progreccor
-
- Offline
- SEO, webdesign
Я не явлюсь официальной службой поддержки!
Я здесь добровольно!
Хочешь получить купон на скидку Hikashop? Спроси меня как!
Please Log in or Create an account to join the conversation.
Я вот точно не знаю, но, кажется, что проблема в php 5.3.
У меня на хостинге php 5.6, обновила Joomla до 5.3.1. Но вылезла ошибка при оформлении заказа. Пришлось обновить HikaShop. Была 2.6.2. Новая исправленная версия 2.6.2 помогла.
Тот же сайт на локалке с php 5.3.18 с глюками (проверяла на всех встроенных шаблонах joomla). При обновлении joomla на локалке пришлось ещё и базу данных исправить.
Сейчас на локалке обновляю php до 5.6. С apache 2.2 не хочет работать, придется ещё и apache до 2.4 обновлять.
MySql тоже недавно обновила до 5.6. Как раз хостер предупредил, что на хостинге будет повышение версии до 5.6, пришлось на локалке тоже обновить, чтобы убедиться, что все ок.
Когда закончу отпишусь, помогло обновление или нет.
Удачи!
Please Log in or Create an account to join the conversation.
Переименовал корневой каталог сайта добавив нижнее подчеркивание (_public_html)
Восстановил резервную копию всех файлов до того как первый раз установил hikashop.
В факт в том что проблема не в БД была, т.к полное восстановление резервной копии таким же путем не решало проблемы.
Please Log in or Create an account to join the conversation.
Please Log in or Create an account to join the conversation.
dymok wrote: Вопрос в догонку тогда, как описание категории переместить под листинг товаров, так чтобы опять все не посыпалось?
Создать переопределение нужно для product/listing
Там такие строки отвечают за вывод описания:
В новой версии могут быть несколько другие.
Их комментируете (или вырезаете) и вставляете перед строкой:
Удачи
Please Log in or Create an account to join the conversation.
Это в Настройках отображения отредактировать нужный файл?
Please Log in or Create an account to join the conversation.
Please Log in or Create an account to join the conversation.
То есть по сути я ничего не правил, кроме одного файла listing.
И даже после отмены всех изменений ошибка остается.
Please Log in or Create an account to join the conversation.
- progreccor
-
- Offline
- SEO, webdesign
Я не явлюсь официальной службой поддержки!
Я здесь добровольно!
Хочешь получить купон на скидку Hikashop? Спроси меня как!
Please Log in or Create an account to join the conversation.
В общем я похоже ошибся, даже действия описанные www.hikashop.com/forum/11-russian/883739.html#236024 не помогли.
Я просто вместо Categories listing, стал выбирать Products listing, поэтому и решил что все заработало.
Изменения вообще никакие не производил. Ради интереса на тестовом хостинге на чистой джумале это же попробую...
Please Log in or Create an account to join the conversation.
- progreccor
-
- Offline
- SEO, webdesign
Смотрим что показывает.
ошибка этого рода может появиться только из за двух причин:
1. некорректные переопределения (например от старых версий хика)
2. неверные значения в базе. Возможно неправильно задано название.
Я не явлюсь официальной службой поддержки!
Я здесь добровольно!
Хочешь получить купон на скидку Hikashop? Спроси меня как!
Please Log in or Create an account to join the conversation.
2. Вот это да, но проблема в каких-то системных таблицах не связанных с хикой.
Поэтому остается искать эти косяченые таблицы, либо все сносить и заново ставить
Да и на чистой джумле конечно же все работает, сейчас проверил... НА той же версии PHP и Mysql.
PS. На чистой сборке, описание вниз не уходит по инструкции almika, т.к этот кусок текста и так стоит перед строкой
Please Log in or Create an account to join the conversation.
- progreccor
-
- Offline
- SEO, webdesign
Перенесите вниз.
Я не явлюсь официальной службой поддержки!
Я здесь добровольно!
Хочешь получить купон на скидку Hikashop? Спроси меня как!
Please Log in or Create an account to join the conversation.
Please Log in or Create an account to join the conversation.
Вот с таким кодом в файле listings, описание будет в самом конце прямо после "Показано 1 из 1" :
Please Log in or Create an account to join the conversation.