Errors transferring from local to working server
11 years 7 months ago - 11 years 7 months ago #192023
by filiar
Errors transferring from local to working server was created by filiar
-- HikaShop version -- : 2.3.5
-- HikaMarket version -- : 1.6.0
-- Joomla version -- : 3.3.6
-- PHP version -- : 5.4.16
-- Error-message(debug-mod must be tuned on) -- : Warning: getimagesize(/home/footst/public_html/madein-bg/w/media/com_hikashop/upload/vendor41\logo_15815.png) [function.getimagesize]: failed to open stream: No such file or directory in /home/footst/public_html/madein-bg/w/administrator/components/com_hikashop/helpers/image.php on line 414
So, after updating to HM 1.6.0 the following error appeared on uploading from local project to working:
On the image of Vendor listing in frontend and on Vendor image in edit form in backend:
And the second warning appears in the main menu only on vendor listing page:
I noticed the backslash after the vendor folder if that's the reason.
-- HikaMarket version -- : 1.6.0
-- Joomla version -- : 3.3.6
-- PHP version -- : 5.4.16
-- Error-message(debug-mod must be tuned on) -- : Warning: getimagesize(/home/footst/public_html/madein-bg/w/media/com_hikashop/upload/vendor41\logo_15815.png) [function.getimagesize]: failed to open stream: No such file or directory in /home/footst/public_html/madein-bg/w/administrator/components/com_hikashop/helpers/image.php on line 414
So, after updating to HM 1.6.0 the following error appeared on uploading from local project to working:
On the image of Vendor listing in frontend and on Vendor image in edit form in backend:
Code:
Warning: getimagesize(/home/footst/public_html/madein-bg/w/media/com_hikashop/upload/vendor41\logo_15815.png) [function.getimagesize]: failed to open stream: No such file or directory in /home/footst/public_html/madein-bg/w/administrator/components/com_hikashop/helpers/image.php on line 414
And the second warning appears in the main menu only on vendor listing page:
Code:
Warning: in_array() expects parameter 2 to be array, null given in /home/footst/public_html/madein-bg/w/modules/mod_djmegamenu/tmpl/default.php on line 53
I noticed the backslash after the vendor folder if that's the reason.
Last edit: 11 years 7 months ago by filiar.
Please Log in or Create an account to join the conversation.
11 years 7 months ago #192024
by filiar
Replied by filiar on topic Error on transverring to real server
I forgot to mention that this happens only when the modifications are made locally (XAMPP for Windows) and then uploaded to the working server. No such error appears when the vendor is added online.
Please Log in or Create an account to join the conversation.
11 years 7 months ago #192056
by Jerome
Jerome - Obsidev.com
HikaMarket & HikaSerial developer / HikaShop core dev team.
Also helping the HikaShop support team when having some time or couldn't sleep.
By the way, do not send me private message, use the "contact us" form instead.
Replied by Jerome on topic Error on transverring to real server
Hi,
Please check that the file "media/com_hikashop/upload/vendor41\logo_15815.png" exist and has been transferred.
Then you can see to edit the HikaShop helper image and replace
By
About the warning in "mod_djmegamenu" ; I can't help you, it's not HikaShop/HikaMarket related.
Regards,
Please check that the file "media/com_hikashop/upload/vendor41\logo_15815.png" exist and has been transferred.
Then you can see to edit the HikaShop helper image and replace
Code:
list($origin->width, $origin->height) = getimagesize($fullFilename);
Code:
list($origin->width, $origin->height) = getimagesize($clean_filename);
About the warning in "mod_djmegamenu" ; I can't help you, it's not HikaShop/HikaMarket related.
Regards,
Jerome - Obsidev.com
HikaMarket & HikaSerial developer / HikaShop core dev team.
Also helping the HikaShop support team when having some time or couldn't sleep.
By the way, do not send me private message, use the "contact us" form instead.
Please Log in or Create an account to join the conversation.
11 years 7 months ago #192059
by filiar
Images are there and are displayed.
I made the modifications but Still no effect.
Replied by filiar on topic Error on transverring to real server
Jerome wrote: Hi,
Please check that the file "media/com_hikashop/upload/vendor41\logo_15815.png" exist and has been transferred.
Then you can see to edit the HikaShop helper image and replaceByCode:list($origin->width, $origin->height) = getimagesize($fullFilename);Code:list($origin->width, $origin->height) = getimagesize($clean_filename);
About the warning in "mod_djmegamenu" ; I can't help you, it's not HikaShop/HikaMarket related.
Regards,
Images are there and are displayed.
I made the modifications but Still no effect.
Please Log in or Create an account to join the conversation.
11 years 7 months ago - 11 years 7 months ago #192061
by filiar
Replied by filiar on topic Error on transverring to real server
Adding this code on line 414 worked for me:
Code:
$fullFilename = str_replace( '\\', '/', $fullFilename);
$filename = str_replace( '\\', '/', $filename);
Last edit: 11 years 7 months ago by filiar.
Please Log in or Create an account to join the conversation.
11 years 7 months ago #192062
by Jerome
Jerome - Obsidev.com
HikaMarket & HikaSerial developer / HikaShop core dev team.
Also helping the HikaShop support team when having some time or couldn't sleep.
By the way, do not send me private message, use the "contact us" form instead.
Replied by Jerome on topic Error on transverring to real server
Hi,
Okay.
Windows and Linux are not using the same character for the folder separator.
I made a report for your issue to HikaShop (because it's in HikaShop, not HikaMarket) and they will made a patch for the next release.
Regards,
Okay.
Windows and Linux are not using the same character for the folder separator.
I made a report for your issue to HikaShop (because it's in HikaShop, not HikaMarket) and they will made a patch for the next release.
Regards,
Jerome - Obsidev.com
HikaMarket & HikaSerial developer / HikaShop core dev team.
Also helping the HikaShop support team when having some time or couldn't sleep.
By the way, do not send me private message, use the "contact us" form instead.
Please Log in or Create an account to join the conversation.
11 years 7 months ago #192063
by filiar
Replied by filiar on topic Error on transverring to real server
Thank You, Jerome.
And in case someone else experiences simmilar problem - the menu issue was also connected somehow with this, because after the code modifications above it is now working as expected.
Regards!
And in case someone else experiences simmilar problem - the menu issue was also connected somehow with this, because after the code modifications above it is now working as expected.
Regards!
Please Log in or Create an account to join the conversation.
Moderators: Obsidev
Time to create page: 0.249 seconds