Skip to main content

Problem with adding pictures

More
12 years 5 months ago #152266 by Ncom
Hi,

Yesterday I uploaded my shop to my server. Today I wanted to update some product but I get following problems
when I add a picture:


Error

Your host needs to disable magic_quotes_gpc to run this version of Joomla!

Could not upload the file /tmp/phprX5jw4 to /home/ncom/domains/ncom.be/public_html/media/com_hikashop/upload/ax3u2600w8g11-dgv.jpg
Notice

The folder /home/ncom/domains/ncom.be/public_html/media/com_hikashop/upload/ is not writable

The folder /home/ncom/domains/ncom.be/public_html/media/com_hikashop/upload/thumbnail/ is not writable
Warning

Warning: Failed to move file!

Can somebody help me?

Best Regards

Please Log in or Create an account to join the conversation.

More
12 years 5 months ago #152328 by sicco0803
Hi,

the error shows your problem.

Deactivate magic_quotes_gpc (ask your web hoster) and make the folder
/home/ncom/domains/ncom.be/public_html/media/com_hikashop/upload/
/home/ncom/domains/ncom.be/public_html/media/com_hikashop/upload/thumbnail/

are writeable, that should solve your problem.

Best
Mike

Please Log in or Create an account to join the conversation.

More
12 years 5 months ago #152329 by Ncom
Replied by Ncom on topic Problem with adding pictures
Hi,

The magic problem I've already fixed but when I put 777 to the 2 maps my picture doesn't show up when I push
save and close

Best Regards

Please Log in or Create an account to join the conversation.

More
12 years 5 months ago #152330 by Jerome
Replied by Jerome on topic Problem with adding pictures
Hi,

Can you please give more details about the problem that the picture doesn't show up ?
Does the image uploaded in the hikashop upload folder ? What is the problem now the upload folder have write permissions ?

Regards,

Jerome - Obsidev.com
HikaMarket & HikaSerial developer / HikaShop core dev team.

Please Log in or Create an account to join the conversation.

More
12 years 5 months ago - 12 years 5 months ago #152380 by Ncom
Replied by Ncom on topic Problem with adding pictures
Hi,

the picture doesn't load up to the folder. I get no errors.

I added a screenshot for example:

When I add picture I get this:



When I press the save button the picture disappears:



Hope you know what the problem can be
Last edit: 12 years 5 months ago by Ncom.

Please Log in or Create an account to join the conversation.

More
12 years 5 months ago #152448 by Xavier
Replied by Xavier on topic Problem with adding pictures
Hi,

Are the images displayed in frontend ?
Are they in the media/com_hikashop/upload folder ?

Thanks to set the error reporting to maximum and enable the debug mode in order to see if there is any errors returned.

Please Log in or Create an account to join the conversation.

More
12 years 5 months ago #152467 by Ncom
Replied by Ncom on topic Problem with adding pictures
The wierd thing is I get no error message.

He doesn't want to load the images to the maps he needs.

Please Log in or Create an account to join the conversation.

More
12 years 5 months ago #152468 by sicco0803
Hi,

perhaps you should look into your error log, maybe there are important informations about that.

Mike

Please Log in or Create an account to join the conversation.

More
12 years 5 months ago #152472 by Ncom
Replied by Ncom on topic Problem with adding pictures
You mean this?

[Wed Apr 16 00:10:35 2014] [warn] RSA server certificate CommonName (CN) `localhost' does NOT match server name!?
[Wed Apr 16 00:17:06 2014] [error] [client 5.10.83.2] File does not exist: /home/ncom/domains/ncom.be/public_html/images/source
[Wed Apr 16 00:17:09 2014] [error] [client 5.10.83.2] File does not exist: /home/ncom/domains/ncom.be/public_html/404.shtml
[Wed Apr 16 00:47:09 2014] [error] [client 5.10.83.73] File does not exist: /home/ncom/domains/ncom.be/public_html/images/cache
[Wed Apr 16 00:47:09 2014] [error] [client 5.10.83.73] File does not exist: /home/ncom/domains/ncom.be/public_html/404.shtml
[Wed Apr 16 00:53:39 2014] [error] [client 5.10.83.28] File does not exist: /home/ncom/domains/ncom.be/public_html/images/cache
[Wed Apr 16 00:53:39 2014] [error] [client 5.10.83.28] File does not exist: /home/ncom/domains/ncom.be/public_html/404.shtml
[Wed Apr 16 00:57:52 2014] [error] [client 5.10.83.16] File does not exist: /home/ncom/domains/ncom.be/public_html/images/source
[Wed Apr 16 00:57:52 2014] [error] [client 5.10.83.16] File does not exist: /home/ncom/domains/ncom.be/public_html/404.shtml
[Wed Apr 16 00:58:40 2014] [error] [client 5.10.83.16] File does not exist: /home/ncom/domains/ncom.be/public_html/images/source
[Wed Apr 16 00:58:40 2014] [error] [client 5.10.83.16] File does not exist: /home/ncom/domains/ncom.be/public_html/404.shtml
[Wed Apr 16 01:06:20 2014] [warn] RSA server certificate CommonName (CN) `localhost' does NOT match server name!?
[Wed Apr 16 01:06:21 2014] [warn] RSA server certificate CommonName (CN) `localhost' does NOT match server name!?
[Wed Apr 16 01:19:50 2014] [error] [client 5.10.83.16] File does not exist: /home/ncom/domains/ncom.be/public_html/images/source
[Wed Apr 16 01:19:50 2014] [error] [client 5.10.83.16] File does not exist: /home/ncom/domains/ncom.be/public_html/404.shtml
[Wed Apr 16 01:28:55 2014] [error] [client 5.10.83.73] File does not exist: /home/ncom/domains/ncom.be/public_html/images/source
[Wed Apr 16 01:28:55 2014] [error] [client 5.10.83.73] File does not exist: /home/ncom/domains/ncom.be/public_html/404.shtml
[Wed Apr 16 01:29:54 2014] [error] [client 5.10.83.2] File does not exist: /home/ncom/domains/ncom.be/public_html/images/source
[Wed Apr 16 01:29:54 2014] [error] [client 5.10.83.2] File does not exist: /home/ncom/domains/ncom.be/public_html/404.shtml
[Wed Apr 16 01:43:14 2014] [error] [client 5.10.83.67] File does not exist: /home/ncom/domains/ncom.be/public_html/images/source
[Wed Apr 16 01:43:14 2014] [error] [client 5.10.83.67] File does not exist: /home/ncom/domains/ncom.be/public_html/404.shtml
[Wed Apr 16 01:53:06 2014] [error] [client 5.10.83.16] File does not exist: /home/ncom/domains/ncom.be/public_html/images/cache
[Wed Apr 16 01:53:06 2014] [error] [client 5.10.83.16] File does not exist: /home/ncom/domains/ncom.be/public_html/404.shtml
[Wed Apr 16 01:59:09 2014] [error] [client 5.10.83.41] File does not exist: /home/ncom/domains/ncom.be/public_html/images/cache
[Wed Apr 16 01:59:09 2014] [error] [client 5.10.83.41] File does not exist: /home/ncom/domains/ncom.be/public_html/404.shtml
[Wed Apr 16 02:14:13 2014] [error] [client 5.10.83.80] File does not exist: /home/ncom/domains/ncom.be/public_html/images/cache
[Wed Apr 16 02:14:13 2014] [error] [client 5.10.83.80] File does not exist: /home/ncom/domains/ncom.be/public_html/404.shtml
[Wed Apr 16 02:19:43 2014] [error] [client 5.10.83.67] File does not exist: /home/ncom/domains/ncom.be/public_html/images/cache
[Wed Apr 16 02:19:43 2014] [error] [client 5.10.83.67] File does not exist: /home/ncom/domains/ncom.be/public_html/404.shtml
[Wed Apr 16 02:20:57 2014] [error] [client 5.10.83.28] File does not exist: /home/ncom/domains/ncom.be/public_html/images/cache
[Wed Apr 16 02:20:57 2014] [error] [client 5.10.83.28] File does not exist: /home/ncom/domains/ncom.be/public_html/404.shtml
[Wed Apr 16 02:41:44 2014] [error] [client 5.10.83.80] File does not exist: /home/ncom/domains/ncom.be/public_html/images/cache
[Wed Apr 16 02:41:44 2014] [error] [client 5.10.83.80] File does not exist: /home/ncom/domains/ncom.be/public_html/404.shtml
[Wed Apr 16 03:29:58 2014] [error] [client 5.10.83.16] File does not exist: /home/ncom/domains/ncom.be/public_html/images/cache
[Wed Apr 16 03:29:58 2014] [error] [client 5.10.83.16] File does not exist: /home/ncom/domains/ncom.be/public_html/404.shtml
[Wed Apr 16 03:37:06 2014] [error] [client 5.10.83.73] File does not exist: /home/ncom/domains/ncom.be/public_html/images/source
[Wed Apr 16 03:37:06 2014] [error] [client 5.10.83.73] File does not exist: /home/ncom/domains/ncom.be/public_html/404.shtml
[Wed Apr 16 03:48:44 2014] [error] [client 5.10.83.41] File does not exist: /home/ncom/domains/ncom.be/public_html/images/cache
[Wed Apr 16 03:48:44 2014] [error] [client 5.10.83.41] File does not exist: /home/ncom/domains/ncom.be/public_html/404.shtml
[Wed Apr 16 03:51:27 2014] [error] [client 5.10.83.46] File does not exist: /home/ncom/domains/ncom.be/public_html/images/cache
[Wed Apr 16 03:51:27 2014] [error] [client 5.10.83.46] File does not exist: /home/ncom/domains/ncom.be/public_html/404.shtml
[Wed Apr 16 04:15:52 2014] [error] [client 5.10.83.41] File does not exist: /home/ncom/domains/ncom.be/public_html/images/cache
[Wed Apr 16 04:15:52 2014] [error] [client 5.10.83.41] File does not exist: /home/ncom/domains/ncom.be/public_html/404.shtml
[Wed Apr 16 05:21:29 2014] [error] [client 5.10.83.48] File does not exist: /home/ncom/domains/ncom.be/public_html/images/cache
[Wed Apr 16 05:21:29 2014] [error] [client 5.10.83.48] File does not exist: /home/ncom/domains/ncom.be/public_html/404.shtml
[Wed Apr 16 05:29:52 2014] [error] [client 5.10.83.67] File does not exist: /home/ncom/domains/ncom.be/public_html/images/cache
[Wed Apr 16 05:29:52 2014] [error] [client 5.10.83.67] File does not exist: /home/ncom/domains/ncom.be/public_html/404.shtml
[Wed Apr 16 05:56:01 2014] [error] [client 5.10.83.16] File does not exist: /home/ncom/domains/ncom.be/public_html/images/cache
[Wed Apr 16 05:56:01 2014] [error] [client 5.10.83.16] File does not exist: /home/ncom/domains/ncom.be/public_html/404.shtml
[Wed Apr 16 06:05:08 2014] [error] [client 5.10.83.73] File does not exist: /home/ncom/domains/ncom.be/public_html/images/cache
[Wed Apr 16 06:05:08 2014] [error] [client 5.10.83.73] File does not exist: /home/ncom/domains/ncom.be/public_html/404.shtml
[Wed Apr 16 06:16:50 2014] [error] [client 5.10.83.41] File does not exist: /home/ncom/domains/ncom.be/public_html/images/source
[Wed Apr 16 06:16:50 2014] [error] [client 5.10.83.41] File does not exist: /home/ncom/domains/ncom.be/public_html/404.shtml
[Wed Apr 16 06:17:35 2014] [error] [client 5.10.83.73] File does not exist: /home/ncom/domains/ncom.be/public_html/images/cache
[Wed Apr 16 06:17:35 2014] [error] [client 5.10.83.73] File does not exist: /home/ncom/domains/ncom.be/public_html/404.shtml
[Wed Apr 16 06:36:24 2014] [error] [client 5.10.83.67] File does not exist: /home/ncom/domains/ncom.be/public_html/images/source
[Wed Apr 16 06:36:24 2014] [error] [client 5.10.83.67] File does not exist: /home/ncom/domains/ncom.be/public_html/404.shtml
[Wed Apr 16 06:50:10 2014] [error] [client 5.10.83.48] File does not exist: /home/ncom/domains/ncom.be/public_html/images/cache
[Wed Apr 16 06:50:10 2014] [error] [client 5.10.83.48] File does not exist: /home/ncom/domains/ncom.be/public_html/404.shtml
[Wed Apr 16 07:03:52 2014] [error] [client 5.10.83.46] File does not exist: /home/ncom/domains/ncom.be/public_html/images/cache
[Wed Apr 16 07:03:52 2014] [error] [client 5.10.83.46] File does not exist: /home/ncom/domains/ncom.be/public_html/404.shtml
[Wed Apr 16 07:05:12 2014] [error] [client 5.10.83.46] File does not exist: /home/ncom/domains/ncom.be/public_html/images/cache
[Wed Apr 16 07:05:12 2014] [error] [client 5.10.83.46] File does not exist: /home/ncom/domains/ncom.be/public_html/404.shtml
[Wed Apr 16 07:08:13 2014] [error] [client 5.10.83.28] File does not exist: /home/ncom/domains/ncom.be/public_html/images/source
[Wed Apr 16 07:08:13 2014] [error] [client 5.10.83.28] File does not exist: /home/ncom/domains/ncom.be/public_html/404.shtml
[Wed Apr 16 07:13:45 2014] [error] [client 5.10.83.67] File does not exist: /home/ncom/domains/ncom.be/public_html/images/source
[Wed Apr 16 07:13:45 2014] [error] [client 5.10.83.67] File does not exist: /home/ncom/domains/ncom.be/public_html/404.shtml
[Wed Apr 16 07:17:30 2014] [error] [client 5.10.83.67] File does not exist: /home/ncom/domains/ncom.be/public_html/images/source
[Wed Apr 16 07:17:30 2014] [error] [client 5.10.83.67] File does not exist: /home/ncom/domains/ncom.be/public_html/404.shtml
[Wed Apr 16 07:45:18 2014] [error] [client 5.10.83.46] File does not exist: /home/ncom/domains/ncom.be/public_html/images/source
[Wed Apr 16 07:45:18 2014] [error] [client 5.10.83.46] File does not exist: /home/ncom/domains/ncom.be/public_html/404.shtml
[Wed Apr 16 07:49:10 2014] [error] [client 5.10.83.32] File does not exist: /home/ncom/domains/ncom.be/public_html/images/cache
[Wed Apr 16 07:49:10 2014] [error] [client 5.10.83.32] File does not exist: /home/ncom/domains/ncom.be/public_html/404.shtml
[Wed Apr 16 08:48:37 2014] [error] [client 194.171.91.225] File does not exist: /home/ncom/domains/ncom.be/public_html/images/cache, referer: www.google.nl/
[Wed Apr 16 08:48:37 2014] [error] [client 194.171.91.225] File does not exist: /home/ncom/domains/ncom.be/public_html/404.shtml, referer: www.google.nl/
[Wed Apr 16 10:50:17 2014] [warn] RSA server certificate CommonName (CN) `localhost' does NOT match server name!?
[Wed Apr 16 10:50:18 2014] [warn] RSA server certificate CommonName (CN) `localhost' does NOT match server name!?
[Wed Apr 16 11:46:20 2014] [error] [client 87.64.235.46] PHP Warning: file_put_contents(/home/ncom/domains/ncom.be/public_html/media/com_hikashop/upload/thumbnails/100x100f/ax3u2800w8g12-dgv.jpg): failed to open stream: Permission denied in /home/ncom/domains/ncom.be/public_html/libraries/joomla/filesystem/file.php on line 426, referer: www.ncom.be/administrator/index.php?opti...roduct&task=edit&cid []=315
[Wed Apr 16 11:49:53 2014] [error] [client 213.118.88.222] File does not exist: /home/ncom/domains/ncom.be/public_html/favicon.ico
[Wed Apr 16 11:49:53 2014] [error] [client 213.118.88.222] File does not exist: /home/ncom/domains/ncom.be/public_html/404.shtml
[Wed Apr 16 11:49:59 2014] [error] [client 213.118.88.222] File does not exist: /home/ncom/domains/ncom.be/public_html/favicon.ico
[Wed Apr 16 11:49:59 2014] [error] [client 213.118.88.222] File does not exist: /home/ncom/domains/ncom.be/public_html/404.shtml
[Wed Apr 16 11:52:22 2014] [error] [client 87.64.235.46] PHP Warning: file_put_contents(/home/ncom/domains/ncom.be/public_html/media/com_hikashop/upload/thumbnails/100x100f/ax3u2800w8g12-dgv.jpg): failed to open stream: Permission denied in /home/ncom/domains/ncom.be/public_html/libraries/joomla/filesystem/file.php on line 426, referer: www.ncom.be/administrator/index.php?opti...roduct&task=edit&cid []=315
[Wed Apr 16 12:04:11 2014] [error] [client 87.64.235.46] PHP Warning: file_put_contents(/home/ncom/domains/ncom.be/public_html/media/com_hikashop/upload/thumbnails/50x50f/ax3u2800w8g12-dgv.jpg): failed to open stream: Permission denied in /home/ncom/domains/ncom.be/public_html/libraries/joomla/filesystem/file.php on line 426, referer: www.ncom.be/administrator/index.php?opti...ikashop&ctrl=product
[Wed Apr 16 13:00:12 2014] [warn] RSA server certificate CommonName (CN) `localhost' does NOT match server name!?
[Wed Apr 16 13:00:13 2014] [warn] RSA server certificate CommonName (CN) `localhost' does NOT match server name!?
[Wed Apr 16 16:21:31 2014] [error] [client 86.91.246.171] File does not exist: /home/ncom/domains/ncom.be/public_html/images/cache
[Wed Apr 16 16:21:31 2014] [error] [client 86.91.246.171] File does not exist: /home/ncom/domains/ncom.be/public_html/404.shtml

Please Log in or Create an account to join the conversation.

More
12 years 5 months ago - 12 years 5 months ago #152474 by sicco0803
Yupp

there is the error
[Wed Apr 16 12:04:11 2014] [error] [client 87.64.235.46] PHP Warning: file_put_contents(/home/ncom/domains/ncom.be/public_html/media/com_hikashop/upload/thumbnails/50x50f/ax3u2800w8g12-dgv.jpg): failed to open stream: Permission denied in /home/ncom/domains/ncom.be/public_html/libraries/joomla/filesystem/file.php on line 426, referer: www.ncom.be/administrator/index.php?opti...ikashop&ctrl=product

Please check the permissions of all joomla files. The line 426 in file.php is after a ftp option in joomla. You should deactivate the ftp uplodd in joomla also of a security reason and use only php as uploader.

If you won't deactivate the ftp upload in joomla, please check the ftp data maybe they are not correct.
Last edit: 12 years 5 months ago by sicco0803.

Please Log in or Create an account to join the conversation.

More
12 years 5 months ago #152482 by Ncom
Replied by Ncom on topic Problem with adding pictures
Can somebody do that for me? Because I'm not really good with these things for the moment and I don't want the screw up

Please Log in or Create an account to join the conversation.

More
12 years 5 months ago #152483 by sicco0803
Hi,

i can check this for you.
Send me all the important access data via pm.

Mike
The following user(s) said Thank You: Ncom

Please Log in or Create an account to join the conversation.

More
12 years 5 months ago #152485 by Ncom
Replied by Ncom on topic Problem with adding pictures
I sended you a pm

thx in advance :-)

Please Log in or Create an account to join the conversation.

Time to create page: 0.276 seconds
Powered by Kunena Forum