- Posts: 265
- Thank you received: 1
Deleting items from the Cart on the home page
- Holmes-Pierce
-
Topic Author
- Offline
-- HikaShop version -- : x.x.x
-- Joomla version -- : x.x
-- PHP version -- : x.x.x
-- Browser(s) name and version -- : XXXXX x.x.x
-- Error-message(debug-mod must be tuned on) -- : Error_message
Hi all,
I'm having a problem deleting items from the cart whilst on the home page. It directs me to this /component/hikashop/product/updatecart/cart_type-cart/cart_product_id-1270/quantity-0/return_url-aHR0cHM6Ly93d3cuZWxldmF0ZXlvdXJzb2xlLmNvLnVrLw==
Any ideas?
Thanks,
Hal
Please Log in or Create an account to join the conversation.
- Posts: 12953
- Thank you received: 1778
If you are using a SEF module / SEF options, can you disable it and try it again ? If it's still not working, can you give us a link to your website so that we can directly test it ?
Thanks.
Please Log in or Create an account to join the conversation.
- Holmes-Pierce
-
Topic Author
- Offline
- Posts: 265
- Thank you received: 1
Thanks for the reply. I turned off the SEF Module and options. I must say that the website didn't run very well without it! The problem was still there none the less.
I'll send you the website address by private message.
Thanks,
Hal
Please Log in or Create an account to join the conversation.
- Posts: 12953
- Thank you received: 1778
Ok, I just tested it, can you give me a temporary back-end and FTP access so that I can find out from where the problem is really coming from ?
Thanks.
Please Log in or Create an account to join the conversation.
- Holmes-Pierce
-
Topic Author
- Offline
- Posts: 265
- Thank you received: 1
I have discovered that the problem is that I have removed index.php from all the URL's. If I manually add index.php into the URL to read index.php/component/hikashop/product/updatecart/cart_type-cart/cart_product_id-1270/quantity-0/return_url-aHR0cHM6Ly93d3cuZWxldmF0ZXlvdXJzb2xlLmNvLnVrLw==
It returns to the homepage as normal.
Could you tell me the modification that I will need to make to fix this?
Thanks,
Hal
Please Log in or Create an account to join the conversation.
- Holmes-Pierce
-
Topic Author
- Offline
- Posts: 265
- Thank you received: 1
If I turn off 'URL re-writing' in global configuration, then deleting products works fine. However, I don't want index.php showing in my URL's...
Thanks,
Hal
Please Log in or Create an account to join the conversation.
That could be related on your .htaccess file. Are you using the htaccess file provided with Joomla ?
Please Log in or Create an account to join the conversation.
- Holmes-Pierce
-
Topic Author
- Offline
- Posts: 265
- Thank you received: 1
Thanks for your response. I am currently using the joomla htaccess file, it looks like this.
Thanks,
Hal
##
# @version $Id: htaccess.txt 9100 2007-10-01 22:29:10Z jinx $
# @package Joomla
# @copyright Copyright (C) 2005 Open Source Matters. All rights reserved.
# @license www.gnu.org/copyleft/gpl.html GNU/GPL
# Joomla! is Free Software
##
# Force register_globals OFF
AddType x-mapp-php5 .php
#####################################################
# READ THIS COMPLETELY IF YOU CHOOSE TO USE THIS FILE
#
# The line just below this section: 'Options +FollowSymLinks' may cause problems
# with some server configurations. It is required for use of mod_rewrite, but may already
# be set by your server administrator in a way that dissallows changing it in
# your .htaccess file. If using it causes your server to error out, comment it out (add # to
# beginning of line), reload your site in your browser and test your sef url's. If they work,
# it has been set by your server administrator and you do not need it set here.
#
# Only use one of the two SEF sections that follow. Lines that can be uncommented
# (and thus used) have only one #. Lines with two #'s should not be uncommented
# In the section that you don't use, all lines should start with #
#
#####################################################
## Can be commented out if causes errors, see notes above.
Options +FollowSymLinks
#
# mod_rewrite in use
RewriteEngine On
########## Begin - 301 Redirect
#
RewriteCond %{THE_REQUEST} ^[A-Z]{3,9}\ /([^/]+/)*(index|home)\.html?\ HTTP/
RewriteRule ^(([^/]+/)*)(index|home)\.html?$ www.mydomain.co.uk/$1 [R=301,L]
#
RewriteCond %{THE_REQUEST} !^POST
RewriteCond %{THE_REQUEST} ^[A-Z]{3,9}\ /([^/]+/)*index\.php\ HTTP/
RewriteCond %{SERVER_PORT}>s ^(443>(s)|[0-9]+>s)$
RewriteRule ^(([^/]+/)*)index\.php$ http%2://www.mydomain/$1 [R=301,L]
#
RewriteCond %{HTTP_HOST} !^(www\.mydomain\.co.uk)?$
RewriteRule (.*) www.mydomain.co.uk/$1 [R=301,L]
#
########## End - 301 Redirect
# Uncomment following line if your webserver's URL
# is not directly related to physical file paths.
# Update Your Joomla! Directory (just / for root)
RewriteBase /
########## Begin - Joomla! core SEF Section
#
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_URI} !^/index.php
RewriteCond %{REQUEST_URI} (/|\.php|\.html|\.feed|\.pdf|\.raw|/[^.]*)$ [NC]
RewriteRule (.*) index.php
#
########## End - Joomla! core SEF Section
########## Begin - Rewrite rules to block out some common exploits
## If you experience problems on your site block out the operations listed below
## This attempts to block the most common type of exploit `attempts` to Joomla!
#
# Block out any script trying to set a mosConfig value through the URL
RewriteCond %{QUERY_STRING} mosConfig_[a-zA-Z_]{1,21}(
\%3D) [OR]# Block out any script trying to base64_encode crap to send via URL
RewriteCond %{QUERY_STRING} base64_encode.*\(.*\) [OR]
# Block out any script that includes a <script> tag in URL
RewriteCond %{QUERY_STRING} (\<|%3C).*script.*(\>|%3E) [NC,OR]
# Block out any script trying to set a PHP GLOBALS variable via URL
RewriteCond %{QUERY_STRING} GLOBALS(
\[|\%[0-9A-Z]{0,2}) [OR]# Block out any script trying to modify a _REQUEST variable via URL
RewriteCond %{QUERY_STRING} _REQUEST(
\[|\%[0-9A-Z]{0,2})# Send all blocked request to homepage with 403 Forbidden error!
RewriteRule ^(.*)$ index.php [F,L]
#
########## End - Rewrite rules to block out some common exploits
Please Log in or Create an account to join the conversation.
The htaccess looks fine.
Could you please turn on the debug mode and error reporting options of the Joomla configuration and try again ? That should display an error message which will help us understand the situation better to provide you with a solution.
Please Log in or Create an account to join the conversation.
- Holmes-Pierce
-
Topic Author
- Offline
- Posts: 265
- Thank you received: 1
This is the only message I get.
Thanks,
Hal
Please Log in or Create an account to join the conversation.
With the debug mode enabled and error reporting level set to maximum, when you delete a product from the cart on the home page don't return an error message ?
Please Log in or Create an account to join the conversation.
- Holmes-Pierce
-
Topic Author
- Offline
- Posts: 265
- Thank you received: 1
Thanks,
Hal
Please Log in or Create an account to join the conversation.
And what is this message, an error one ?
If it is, thanks to give us this displayed message.
Please Log in or Create an account to join the conversation.
- Holmes-Pierce
-
Topic Author
- Offline
- Posts: 265
- Thank you received: 1
Sorry I'll try to be clearer.
With the error reporting on, the text pushes the delete icon off the page. Therefore, I can't force the error.
I'm happy to provide a Login for you to have a look.
Thanks,
Hal
Please Log in or Create an account to join the conversation.
Which text ?With the error reporting on, the text pushes the delete icon off the page
Please Log in or Create an account to join the conversation.
- Holmes-Pierce
-
Topic Author
- Offline
- Posts: 265
- Thank you received: 1
Hika_Variant_separator??
Please Log in or Create an account to join the conversation.
Please Log in or Create an account to join the conversation.
- Holmes-Pierce
-
Topic Author
- Offline
- Posts: 265
- Thank you received: 1
There is no error on the blank page... This is the URL it sends me to.
/component/hikashop/product/updatecart/cart_type-cart/cart_product_id-1474/quantity-0/return_url-aHR0cHM6Ly93d3cuZWxldmF0ZXlvdXJzb2xlLmNvLnVrLw==
Thanks,
Hal
Please Log in or Create an account to join the conversation.
- Holmes-Pierce
-
Topic Author
- Offline
- Posts: 265
- Thank you received: 1
Its still happening.
Thanks,
Hal
Please Log in or Create an account to join the conversation.
Changing the line:
Please Log in or Create an account to join the conversation.