Skip to main content

Deleting items from the Cart on the home page

More
12 years 3 months ago #161746 by Holmes-Pierce
-- url of the page with the problem -- : mywebsite.com/mypage
-- HikaShop version -- : x.x.x
-- Joomla version -- : x.x
-- PHP version -- : x.x.x
-- Browser(s) name and version -- : XXXXX x.x.x
-- Error-message(debug-mod must be tuned on) -- : Error_message

Hi all,

I'm having a problem deleting items from the cart whilst on the home page. It directs me to this /component/hikashop/product/updatecart/cart_type-cart/cart_product_id-1270/quantity-0/return_url-aHR0cHM6Ly93d3cuZWxldmF0ZXlvdXJzb2xlLmNvLnVrLw==

Any ideas?

Thanks,
Hal

Please Log in or Create an account to join the conversation.

More
12 years 3 months ago #161778 by Mohamed Thelji
Hello Hal,
If you are using a SEF module / SEF options, can you disable it and try it again ? If it's still not working, can you give us a link to your website so that we can directly test it ?
Thanks.

Please Log in or Create an account to join the conversation.

More
12 years 3 months ago #161923 by Holmes-Pierce
Hi Mohamed,

Thanks for the reply. I turned off the SEF Module and options. I must say that the website didn't run very well without it! The problem was still there none the less.

I'll send you the website address by private message.

Thanks,
Hal

Please Log in or Create an account to join the conversation.

More
12 years 3 months ago #161945 by Mohamed Thelji
Hello,

Ok, I just tested it, can you give me a temporary back-end and FTP access so that I can find out from where the problem is really coming from ?
Thanks.

Please Log in or Create an account to join the conversation.

More
12 years 3 months ago #162105 by Holmes-Pierce
Good Morning,

I have discovered that the problem is that I have removed index.php from all the URL's. If I manually add index.php into the URL to read index.php/component/hikashop/product/updatecart/cart_type-cart/cart_product_id-1270/quantity-0/return_url-aHR0cHM6Ly93d3cuZWxldmF0ZXlvdXJzb2xlLmNvLnVrLw==

It returns to the homepage as normal.

Could you tell me the modification that I will need to make to fix this?

Thanks,
Hal

Please Log in or Create an account to join the conversation.

More
12 years 3 months ago #162106 by Holmes-Pierce
Update:

If I turn off 'URL re-writing' in global configuration, then deleting products works fine. However, I don't want index.php showing in my URL's...

Thanks,
Hal

Please Log in or Create an account to join the conversation.

More
12 years 3 months ago #162342 by Xavier
Hi,

That could be related on your .htaccess file. Are you using the htaccess file provided with Joomla ?

Please Log in or Create an account to join the conversation.

More
12 years 3 months ago #162357 by Holmes-Pierce
Hi Xavier,

Thanks for your response. I am currently using the joomla htaccess file, it looks like this.

Thanks,
Hal

##
# @version $Id: htaccess.txt 9100 2007-10-01 22:29:10Z jinx $
# @package Joomla
# @copyright Copyright (C) 2005 Open Source Matters. All rights reserved.
# @license www.gnu.org/copyleft/gpl.html GNU/GPL
# Joomla! is Free Software
##

# Force register_globals OFF
AddType x-mapp-php5 .php

#####################################################
# READ THIS COMPLETELY IF YOU CHOOSE TO USE THIS FILE
#
# The line just below this section: 'Options +FollowSymLinks' may cause problems
# with some server configurations. It is required for use of mod_rewrite, but may already
# be set by your server administrator in a way that dissallows changing it in
# your .htaccess file. If using it causes your server to error out, comment it out (add # to
# beginning of line), reload your site in your browser and test your sef url's. If they work,
# it has been set by your server administrator and you do not need it set here.
#
# Only use one of the two SEF sections that follow. Lines that can be uncommented
# (and thus used) have only one #. Lines with two #'s should not be uncommented
# In the section that you don't use, all lines should start with #
#
#####################################################

## Can be commented out if causes errors, see notes above.
Options +FollowSymLinks

#
# mod_rewrite in use

RewriteEngine On

########## Begin - 301 Redirect
#
RewriteCond %{THE_REQUEST} ^[A-Z]{3,9}\ /([^/]+/)*(index|home)\.html?\ HTTP/
RewriteRule ^(([^/]+/)*)(index|home)\.html?$ www.mydomain.co.uk/$1 [R=301,L]
#
RewriteCond %{THE_REQUEST} !^POST
RewriteCond %{THE_REQUEST} ^[A-Z]{3,9}\ /([^/]+/)*index\.php\ HTTP/
RewriteCond %{SERVER_PORT}>s ^(443>(s)|[0-9]+>s)$
RewriteRule ^(([^/]+/)*)index\.php$ http%2://www.mydomain/$1 [R=301,L]
#
RewriteCond %{HTTP_HOST} !^(www\.mydomain\.co.uk)?$
RewriteRule (.*) www.mydomain.co.uk/$1 [R=301,L]
#
########## End - 301 Redirect


# Uncomment following line if your webserver's URL
# is not directly related to physical file paths.
# Update Your Joomla! Directory (just / for root)

RewriteBase /


########## Begin - Joomla! core SEF Section
#
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_URI} !^/index.php
RewriteCond %{REQUEST_URI} (/|\.php|\.html|\.feed|\.pdf|\.raw|/[^.]*)$ [NC]
RewriteRule (.*) index.php
#
########## End - Joomla! core SEF Section


########## Begin - Rewrite rules to block out some common exploits
## If you experience problems on your site block out the operations listed below
## This attempts to block the most common type of exploit `attempts` to Joomla!
#
# Block out any script trying to set a mosConfig value through the URL
RewriteCond %{QUERY_STRING} mosConfig_[a-zA-Z_]{1,21}(=|\%3D) [OR]
# Block out any script trying to base64_encode crap to send via URL
RewriteCond %{QUERY_STRING} base64_encode.*\(.*\) [OR]
# Block out any script that includes a <script> tag in URL
RewriteCond %{QUERY_STRING} (\<|%3C).*script.*(\>|%3E) [NC,OR]
# Block out any script trying to set a PHP GLOBALS variable via URL
RewriteCond %{QUERY_STRING} GLOBALS(=|\[|\%[0-9A-Z]{0,2}) [OR]
# Block out any script trying to modify a _REQUEST variable via URL
RewriteCond %{QUERY_STRING} _REQUEST(=|\[|\%[0-9A-Z]{0,2})
# Send all blocked request to homepage with 403 Forbidden error!
RewriteRule ^(.*)$ index.php [F,L]
#
########## End - Rewrite rules to block out some common exploits

Please Log in or Create an account to join the conversation.

More
12 years 3 months ago #162423 by nicolas
Hi,

The htaccess looks fine.
Could you please turn on the debug mode and error reporting options of the Joomla configuration and try again ? That should display an error message which will help us understand the situation better to provide you with a solution.

Please Log in or Create an account to join the conversation.

More
12 years 3 months ago #162481 by Holmes-Pierce
Hi,

This is the only message I get.

Thanks,
Hal

Please Log in or Create an account to join the conversation.

More
12 years 3 months ago #162491 by Xavier
Hi,

With the debug mode enabled and error reporting level set to maximum, when you delete a product from the cart on the home page don't return an error message ?

Please Log in or Create an account to join the conversation.

More
12 years 3 months ago #162609 by Holmes-Pierce
I can't delete from the cart with the error reporting 'on' as the message pushes the delete icon off the page...

Thanks,
Hal

Please Log in or Create an account to join the conversation.

More
12 years 3 months ago #162628 by Xavier
Hi,

And what is this message, an error one ?
If it is, thanks to give us this displayed message.

Please Log in or Create an account to join the conversation.

More
12 years 2 months ago #162800 by Holmes-Pierce
Hi Xavier,

Sorry I'll try to be clearer.

With the error reporting on, the text pushes the delete icon off the page. Therefore, I can't force the error.

I'm happy to provide a Login for you to have a look.

Thanks,
Hal

Please Log in or Create an account to join the conversation.

More
12 years 2 months ago #162817 by Xavier
Hi,

With the error reporting on, the text pushes the delete icon off the page

Which text ? ;)

Please Log in or Create an account to join the conversation.

More
12 years 2 months ago #162963 by Holmes-Pierce
Haha, the text on the screenshot.

Hika_Variant_separator??

Please Log in or Create an account to join the conversation.

More
12 years 2 months ago #162968 by Xavier
Oh, ok, that's because you have enabled the Language debug, thanks to disable it ,and enable only the other one.

Please Log in or Create an account to join the conversation.

More
12 years 2 months ago #163043 by Holmes-Pierce
Hi Xavier,

There is no error on the blank page... This is the URL it sends me to.

/component/hikashop/product/updatecart/cart_type-cart/cart_product_id-1474/quantity-0/return_url-aHR0cHM6Ly93d3cuZWxldmF0ZXlvdXJzb2xlLmNvLnVrLw==

Thanks,
Hal

Please Log in or Create an account to join the conversation.

More
12 years 2 months ago #165911 by Holmes-Pierce
Can anyone help further with this issue?

Its still happening.

Thanks,
Hal

Please Log in or Create an account to join the conversation.

More
12 years 2 months ago #166018 by nicolas
Hi,

Changing the line:
Code:
<a href="<?php echo hikashop_completeLink('product&task=updatecart&product_id='.$row->product_id.'&quantity=0&return_url='.urlencode(base64_encode(hikashop_currentURL('return_url')))); ?>" onclick="var qty_field = document.getElementById('hikashop_checkout_quantity_<?php echo $row->cart_product_id;?>'); if(qty_field){qty_field.value=0; <?php echo $input; ?> qty_field.form.submit();} return false;" title="<?php echo JText::_('HIKA_DELETE'); ?>">
to:
Code:
<a href="<?php echo hikashop_completeLink('product&task=updatecart&product_id='.$row->product_id.$url_itemid.'&quantity=0&return_url='.urlencode(base64_encode(hikashop_currentURL('return_url')))); ?>" onclick="var qty_field = document.getElementById('hikashop_checkout_quantity_<?php echo $row->cart_product_id;?>'); if(qty_field){qty_field.value=0; <?php echo $input; ?> qty_field.form.submit();} return false;" title="<?php echo JText::_('HIKA_DELETE'); ?>">
in the file "cart" of the view "product" via the menu Display>Views will fix the problem. I've done it for you on your website as we had the admin access form another issue we dealt with lately, and the fix will be included in next version of HikaShop.
The following user(s) said Thank You: Holmes-Pierce

Please Log in or Create an account to join the conversation.

Time to create page: 0.336 seconds
Powered by Kunena Forum