Skip to main content

PHP 5.5

More
12 years 3 weeks ago - 12 years 3 weeks ago #170730 by zebrafilm
PHP 5.5 was created by zebrafilm
-- HikaShop version -- : 2.3.2
-- Joomla version -- : 3.3.3
-- PHP version -- : 5.5
-- Browser(s) name and version -- : Chrome

We just update one hosting server to PHP 5.5 and noticed that the only extension not working seems to be Hikashop. Can you confirm that Hikashop only works on 5.4 and lower?

Backend works fine for config etc but trying to show categories or product in the frontend or backend crashes the pages. Will go through the logs to have more precise info but since this is pretty urgent I started posting already.
Tested with and without SEF switch in HIka
Last edit: 12 years 3 weeks ago by zebrafilm.

Please Log in or Create an account to join the conversation.

More
12 years 3 weeks ago #170739 by Xavier
Replied by Xavier on topic PHP 5.5
Hi,

Thanks to set the Joomla error reporting level to "Maximum" in order to see the returned errors.
I think that the errors are deprecated ones.

We will do some tests on our end.

Please Log in or Create an account to join the conversation.

More
12 years 3 weeks ago #170824 by zebrafilm
Replied by zebrafilm on topic PHP 5.5
Hi Xavier,

Debug settings don't help much if the page does not load at all. :-)
(Internal server error)

Logs are also not very helpful. Hope you can find a solution because we would love to set all sites to run under 5.5.

Bastiaan

Please Log in or Create an account to join the conversation.

More
12 years 3 weeks ago #170829 by Jerome
Replied by Jerome on topic PHP 5.5
Hi,

HikaShop is working on PHP 5.5 ; we are running test websites under PHP 5.5.12 for our developments and tests.

Regards,

Jerome - Obsidev.com
HikaMarket & HikaSerial developer / HikaShop core dev team.

Please Log in or Create an account to join the conversation.

More
12 years 3 weeks ago #170876 by zebrafilm
Replied by zebrafilm on topic PHP 5.5
Good to hear Jerome. Guess those test sites are clean installs. Our issues came after upgrading the server. All Hikashops went down from all clients. May be a PHP module or something. Not sure if Hika checks the version during install. Re-install did not help so we had to set individual sites back to 5.4.
Would love to find out what the issue is because it affects a lot of clients.

Setup a little test:
kenniskabaal.nl

on the right you can choose categories or product listing, debug is on. The same happens in the backend when displaying categories or products.

Please Log in or Create an account to join the conversation.

More
12 years 2 weeks ago #170912 by nicolas
Replied by nicolas on topic PHP 5.5
Hi,

No, the test websites we have are not clean installs. We use them intensively for our tests. So that's why we're surprised that you have a problem with HikaShop which would be caused by PHP 5.5.

The error that you have on your test website is a generic error message of apache when a fatal error occurred in PHP. What we need is the fatal error message of PHP. Please look in the PHP error log of your web server for the fatal error message and provide it. That would allow us to tell you what to do.

Please Log in or Create an account to join the conversation.

More
12 years 2 weeks ago - 12 years 2 weeks ago #170926 by zebrafilm
Replied by zebrafilm on topic PHP 5.5
Fatal error: Cannot redeclare class hikashopWysiwyg in /var/www/vhosts/kenniskabaal.nl/httpdocs/administrator/components/com_hikashop/classes/field.php on line 1870
Does that ring a bell? This popped up once in the front end.

Setup a clean site and installed Hika. The moment the wizard starts, the site crashes.But Hika installed and can be accessed.
Config can be done but clicking products gives error.

In the error log:
[Fri Sep 12 13:31:44.102485 2014] [fcgid:warn] [pid 1717] (104)Connection reset by peer: [client 10.2.5.51:45438] mod_fcgid: error reading data from FastCGI server, referer: kenniskabaal.nl/administrator/index.php?option=com_hikashop
[Fri Sep 12 13:31:44.102544 2014] [core:error] [pid 1717] [client 10.2.5.51:45438] End of script output before headers: index.php, referer: kenniskabaal.nl/administrator/index.php?option=com_hikashop

Seems it doesn't like our fastcgi settings. I will increase the timeout settings to see if that helps.

UPDATE: we have ruled out timing issues because it is an instant error. curious what you guys think of it.

UPDATE2: when switching back to apache_mod: matches the server name
[Fri Sep 12 15:06:33.070820 2014] [ssl:warn] [pid 12440] AH01909: RSA certificate configured for kenniskabaal.nl:443 does NOT include an ID which matches the server name .

But SSL is off for the site and for Hika.
Last edit: 12 years 2 weeks ago by zebrafilm.

Please Log in or Create an account to join the conversation.

More
12 years 2 weeks ago #170944 by nicolas
Replied by nicolas on topic PHP 5.5
Hi,

The class hikashopWysiwyg in only in that file and is with a bunch of other classes in the middle of the file.
So this fatal error message indicates that something else is trying to instantiate a class with the same name somewhere else on the website.

But I don't think that it is related to the problem.The error log is from the apache error log of your web server which doesn't help. Could you look at the PHP error log of your web server ?

Please Log in or Create an account to join the conversation.

More
12 years 2 weeks ago #171064 by zebrafilm
Replied by zebrafilm on topic PHP 5.5
Yes I am aware it is only a general error from the webserver but because Hika crashes instantly the PHP error log is not written.

Still hoped that some of the errors might ring a bell to a dev. IF not , the only way seems to add or switch on debug code inside Hika to know what goes wrong where. I am more than happy to open the test site for those experiments.

Please Log in or Create an account to join the conversation.

More
12 years 2 weeks ago - 12 years 2 weeks ago #171094 by Jerome
Replied by Jerome on topic PHP 5.5
Hi,

[Fri Sep 12 15:06:33.070820 2014] [ssl:warn] [pid 12440] AH01909: RSA certificate configured for kenniskabaal.nl:443 does NOT include an ID which matches the server name .

As not link at all with HikaShop or Joomla, it's just your apache configuration.

we have ruled out timing issues because it is an instant error. curious what you guys think of it.

I don't understand what you mean.

because Hika crashes instantly the PHP error log is not written

HikaShop does not crashes instantly ; your PHP 5.5 does.
Please check the full version of your PHP and check your settings too.
"5.5" is too generic, specially if you want to know the known bugs in that specific version.
I seen a lot of problems with the PHP output buffer overflow which made PHP crashed and as you can imagine ; the problem is not linked with HikaShop or Joomla.

Regards,

Jerome - Obsidev.com
HikaMarket & HikaSerial developer / HikaShop core dev team.
Last edit: 12 years 2 weeks ago by Jerome.

Please Log in or Create an account to join the conversation.

More
12 years 2 weeks ago #171939 by zebrafilm
Replied by zebrafilm on topic PHP 5.5
Guys, it doesn't seem to be a simple thing.

Plesk 12 runs standard Apache2 with NGINX as gateway for static files. Plesk makes a mess from the Apache settings so we already corrected some and got Hika working on most 5.5 websites but keep running into big and smaller issues.
Logs are not clear enough to pinpoint the issues but we will keep searching.

Question: did you try Hika under NGINX?

Please Log in or Create an account to join the conversation.

More
12 years 2 weeks ago #171968 by Jerome
Replied by Jerome on topic PHP 5.5
Hi,

Yes, I did.

Regards,

Jerome - Obsidev.com
HikaMarket & HikaSerial developer / HikaShop core dev team.

Please Log in or Create an account to join the conversation.

Time to create page: 0.239 seconds
Powered by Kunena Forum