Skip to main content

Page web inaccessible (ERR_CONTENT_DECODING_FAILED

More
12 years 1 week ago #173229 by Batikskio
-- url of the page with the problem -- : www.les-jardins-de-mahelys.fr/hydrolats
-- HikaShop version -- : HikaShop Starter 2.3.3
-- Joomla version -- : 3.3.4
-- PHP version -- : 5.4.30
-- Browser(s) name and version -- : Firefox 32.0.3
-- Error-message(debug-mod must be tuned on) -- : Console de débogage Joomla!
Session
__default
__foxcontact_component_109
hikashop_viewed_products
Profil d'information
Occupation de la mémoire
13.35 MB (13 999 868 Bytes)
Requêtes de base de données
41 requêtes exécutées 49.5 ms

9 doubles découverts!
2 requêtes dupliquées: #6 #7
2 requêtes dupliquées: #15 #39
2 requêtes dupliquées: #25 #31
3 requêtes dupliquées: #28 #29 #30

Temps de requête : 0.53 ms Mémoire de requête : 0.007 MB mémoire avant requête : 1.620 MB Rangées retournées : 1

SELECT `data`

FROM `vmzst_session`

WHERE `session_id` = '1fe426b4997172c150560ce130a2da6e'

Explication
id select_type table type possible_keys key key_len ref rows Extra
1 SIMPLE vmzst_session const PRIMARY PRIMARY 602 const 1
Profil

Bonjour,
Depuis la mise à jour de Joomla et Hikamarket ce matin, c'est la cata !
Sur les pages Hikashop du site Les jardins de Mahélys , j'obtiens le message suivant : Page web inaccessible (ERR_CONTENT_DECODING_FAILED).
Si j'active le Débogage Système, les pages s'ouvrent. Mais je suis arrivé à mon niveau d'incompétences pour comprendre et résoudre le problème...
Merci d'avance pour votre aide. (j'ai laissé activé le Débogage Système)

Please Log in or Create an account to join the conversation.

More
12 years 6 days ago #173236 by nicolas
Bonjour,

Ne voyant pas d'erreur, difficile d'analyser le problème.
Serait-il possible de désactiver le débogage système ?

Please Log in or Create an account to join the conversation.

More
12 years 6 days ago #173399 by Batikskio
Merci Nicolas de jeter un oeil.
Je viens de désactiver le debogage système et maintenant, les pages HikaShop sont inaccessibles.
Dès que j'aurai un retour de ta part, je réactiverai le débogage système. Ce sera pour l'instant toujours moins pire qu'une page blanche...
C'est quand même bizarre qu'en mode débogage les pages apparaissent... et en même temps c'est rassurant.
Quelle est donc ce bug ???

Please Log in or Create an account to join the conversation.

More
12 years 5 days ago #173449 by nicolas
C'est bizarre en effet.
Et en désactivant le plugin débug de joomla est-ce que cela aide ?
Sinon, il faudrait regarder dans le log d'erreur PHP du serveur. Il devrait y avoir une erreur fatale correspondant au problème et qui nous donnera plus d'info sur le soucis.

Please Log in or Create an account to join the conversation.

More
12 years 5 days ago #173469 by Batikskio
Je viens de désactiver le plugin Débogage, mais rien n'y change.
Quant au log erreur PHP du serveur... Je suis sur un serveur mutualisé OVH et je n'ai rien trouvé dans l'admin pour accéder au log erreur du serveur :(
Qu'est-ce qui peut bien faire qu'en mode Débogage les pages HikaShop apparaissent ???
Serais-je le seul à avoir ce problème ?

Please Log in or Create an account to join the conversation.

More
12 years 4 days ago #173476 by Jerome
Bonjour,

Je pense que vous avez un plugin system qui pose soucis.
En regardant le détails de l'appel, on remarque qu'il n'y a pas de "content-length" mais qu'il y a du transfert "chunked".
La page n'est donc pas délivrée mais on dit au navigateur que le reste arrive.. Mais il n'arrive pas puisqu'au final le lien est coupé, par une fatal error probablement.
Code:
Remote Address:213.186.33.82:80 Request URL:http://www.les-jardins-de-mahelys.fr/hydrolats Request Method:GET Status Code:200 OK Request Headers Accept:text/html,application/xhtml+xml,application/xml;q=0.9,image/webp,*/*;q=0.8 Accept-Encoding:gzip,deflate,sdch Accept-Language:fr-FR,fr;q=0.8,en-US;q=0.6,en;q=0.4 Connection:keep-alive DNT:1 Host:www.les-jardins-de-mahelys.fr User-Agent:Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/38.0.2125.77 Safari/537.36 Response Headers Cache-Control:no-store, no-cache, must-revalidate, post-check=0, pre-check=0 Connection:keep-alive Content-Encoding:gzip Content-Type:text/html; charset=utf-8 Date:Sun, 28 Sep 2014 10:50:43 GMT Expires:Mon, 1 Jan 2001 00:00:00 GMT Last-Modified:Sun, 28 Sep 2014 10:50:43 GMT P3P:CP="NOI ADM DEV PSAi COM NAV OUR OTRo STP IND DEM" Pragma:no-cache Server:Apache Set-Cookie:clusterBAK=R1564860580; path=/; expires=Sun, 28-Sep-2014 11:52:30 GMT Set-Cookie:cluster=R2881595112; path=/; expires=Sun, 28-Sep-2014 11:58:08 GMT Set-Cookie:c284cee13babce988676c7f142627f0c=cd3c92d7f88ba722de7f8fdb0397f7a4; path=/; HttpOnly Transfer-Encoding:chunked X-Powered-By:PHP/5.4.30
Ce mode de fonctionnement en "chunked" est pratique pour des sites délivrant le contenu de manière linéaire, ou le "header" est généré avant le reste de la page, ou l'on peut délivrer le contenu petit à petit. Mais je trouve cela un peu étrange pour du Joomla.

Toujours est-il que le fait même que vous ayez du transfert en "chunked" ne vous permet pas de voir clairement l'erreur.
Puisqu'on a dit au server que la page a été générée correctement (via le 200) il est difficile de lui dire "ah mais au fait non, y a une erreur !".

Cordialement,

Jerome - Obsidev.com
HikaMarket & HikaSerial developer / HikaShop core dev team.

Please Log in or Create an account to join the conversation.

More
12 years 4 days ago #173525 by Batikskio
Bonjour Jérome,
wwwhhhhaaaaooouuuu ! je n'ai rien compris :blink:

Je suis sincèrement heureux qu'on prête attention à mon problème et je vous remercie de votre analyse.
Mais concrètement, je fais quoi ? :unsure:

Please Log in or Create an account to join the conversation.

More
12 years 3 days ago - 12 years 4 days ago #173568 by Jerome
Bonjour,

Il faut trouver le plugin système qui fait cela et le désactiver, donc essayez de les désactiver un par un jusqu'à que cela marche.

A partir du moment ou les pages ne seront plus retournées en mode "chunked", les pages HikaShop seront de nouveau visible.
Je pense que le plugin système se désactive tout seul en mode debug, d'ou le fait que le problème ne soit visible que lorsque le mode debug est activé. Mais c'est peut-être une fonctionnalité de votre template... Du coup, vous pouvez aussi essayer de changer le template du site pour voir si cela aide (qui indiquerait que le problème est lié au template).
C'est la première fois que je vois ce genre de chose sur Joomla donc j'ignore d'ou cela peut venir exactement puisque je ne l'ai jamais vu auparavant.

Cordialement,

Jerome - Obsidev.com
HikaMarket & HikaSerial developer / HikaShop core dev team.
Last edit: 12 years 4 days ago by nicolas.

Please Log in or Create an account to join the conversation.

More
12 years 3 days ago #173676 by Batikskio
Bonjour Jérôme,
J'ai testé deux autres templates avec le même résultat. J'ai désactivé tous les plugins HikaShop un par un et rien n'a changé.
J'ai désactivé le plugin Système : Système SEF : Les pages HikaShop du menu déroulant "Hydrolats" réapparraissent mais la mise en page part en live, alors que la page HikaShop "Baumes" apparaît nickel ???

J'ai testé un truc à tout hasard... j'ai désactivé la compression GZIP et là, miracle tout refonctionne.

Est-ce que tous mes tests vous donnent une idée du problème ? Puis-je espérer trouver une solution pour réactiver la compression GZIP, ou dois-je laisser tomber cette option ?
En tout cas merci pour votre aide et vos idées de recherche.

Please Log in or Create an account to join the conversation.

More
12 years 2 days ago #173706 by Jerome
Bonjour,

Le GZIP est déjà géré par votre serveur web, activer le GZIP au niveau de PHP est donc pas forcement utile.
Néanmoins, il se pourrait que le soucis puisse être réglé avec la dernière version du package d'HikaShop Starter.
Lorsque Nicolas a appliqué le patch, un soucis d'encoding est apparu dans la version starter, utiliser le dernier package règle donc le soucis dans le fichier helper d'HikaShop.
Cela pourrait être la source du conflit entre le GZIP et HikaShop.

Cordialement,

Jerome - Obsidev.com
HikaMarket & HikaSerial developer / HikaShop core dev team.

Please Log in or Create an account to join the conversation.

More
12 years 2 days ago #173825 by Batikskio
En effet, la dernière mise à jour a résolu le problème.
Merci pour votre aide !

Please Log in or Create an account to join the conversation.

Time to create page: 0.269 seconds
Powered by Kunena Forum